Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 14

Thema: Servo Regler 9300 Lenze und Profibus

  1. #1
    Registriert seit
    06.11.2005
    Ort
    daheim natürlich
    Beiträge
    119
    Danke
    11
    Erhielt 2 Danke für 2 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen,
    hab da mal wieder ne Frage:
    ist jetzt zwar ein relativ spezielles Thema, aber vielleicht hat ja einer ne Idee.
    Anlage: S7- 315-2DP über Profibus 8-10 ET200 Module und ein Lenze Servo Regler 9300 auch über Profibus. An den Regler werden die Prozessdaten und Parameter übertragen. Unteranderem wird über den Paramterkanal auch der Akt. Ist Wert des Regler in die S7 übertragen.
    Solange die Übertragungsrate des Busses nicht grösser 187,5 kBit ist klappt alles wunderbar. Stellt man die Übertragung grösser, kommen die Paramter vom Regler mit einer Verzögerung von ca. 4 - 15 sec. in die SPS.
    Jemand irgendeine Idee?
    Das Thema EMV und Abschirmung wurde bereits sorgfältig geprüft und brachte keine Verbesserung. Das Profibusmodul des Lenze Reglers passt sich automatisch der Übertragungsrate des Busses bis zu 12 MBit an.
    Leitungslänge ist ok.
    Der Baustein für die Übertragung der Paramterdaten ist von Lenze, allerdings schon ein paar Jahre alt. Kann ein solches Problem durch eine schlechte/falsche Programmierung auftreten?
    Dieses Problem habe ich jetzt bereits bei der 2.ten Anlage, habe allerdings was den Bus betrifft keine Zeitkritischen Anwendungen und bin deshalb immer mit niedriger Busrate gefahren.

    MfG,
    Flo
    Zitieren Zitieren Servo Regler 9300 Lenze und Profibus  

  2. #2
    Registriert seit
    09.05.2007
    Beiträge
    188
    Danke
    16
    Erhielt 24 Danke für 23 Beiträge

    Standard

    Zitat Zitat von Flo Beitrag anzeigen
    ... Unteranderem wird über den Paramterkanal auch der Akt. Ist Wert des Regler in die S7 übertragen...
    Warum überträgts Du den Istwert über den Parameterkanal und nicht über den Prozessdatenkanal, oder hast Du dich vertippt?

  3. #3
    Flo ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    06.11.2005
    Ort
    daheim natürlich
    Beiträge
    119
    Danke
    11
    Erhielt 2 Danke für 2 Beiträge

    Standard

    Nein, hab mich nicht vertippt. Das ist halt bei den Anwendungen so, da ich mit dem Wert nicht im Ablauf arbeite, er dient nur als anzeige. Hast aber recht, den Ist WErt über Prozess zu übertragen ist besser. Aber oben beschriebenes Verhalten dabe ich auch bei anderen Werten, die ich über Paramterdaten lese, wie Akt. Stromwert, Antriebs- und Fehlerdiagnose.
    Wer ne Idee?

    MfG,
    Flo

  4. #4
    Registriert seit
    09.05.2007
    Beiträge
    188
    Danke
    16
    Erhielt 24 Danke für 23 Beiträge

    Standard

    Ich hab noch nie die Werte im Parameterkanal zeitlich verglichen.
    Wie ist es wenn Du einen Wert schreibst? Kommt der auch erst viel später an?
    Wie machst du das? Wert im GDC ankucken und mit SPS-Online vergleichen?
    Wenn ich morgen Zeit hab check ich das mal.

  5. #5
    Flo ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    06.11.2005
    Ort
    daheim natürlich
    Beiträge
    119
    Danke
    11
    Erhielt 2 Danke für 2 Beiträge

    Standard

    Ich hab bis jetzt nur die Werte gecheckt die vom Regler an die SPS kommen. Da kucke ich im GDC Monitor online auf div. Werte (Aktualisierungszeit der Monitorwerte 1sec.) und vergleiche sie mit den Werten in der SPS Online in einer Variablentabelle.

    MfG,
    Flo

  6. #6
    Registriert seit
    21.05.2004
    Beiträge
    418
    Danke
    31
    Erhielt 16 Danke für 8 Beiträge

    Standard

    könnte mir das nur eventuell vorstellen, wenn deine 93er Abarbeitungsliste mit fast 99% voll ist und du CAN kommunizierst (GDC), dann bleibt für die AIF (Profibus) Kommunikation fast nix mehr über.

    Mal RSP setzen und sehen on sich was ändert und dann - falls das mit mehr als 90% zutrifft, mal einen "großen" Block rauswerfen und schauen.
    Bei einem 9300vector sind 90% schon nicht erstrebenswert.

    Die Parameter Kommunikation wird (wenn nicht die asyklische ParaKom DPV1 angewendet wird) ja als "Ergänzung" an die Prozessdaten angehängt - übern Profibus läuft das also ganz schnell.
    Du kannst aber mal checken, wie lange ein Parameter lesen Auftrag in der SPS läuft.

    Du kannst zum Test aber auch mal einen Wert am Analogausgang des 93 ausgeben und parallel mit der SPS lesen und die Werte vergleichen - vielleicht lügt GDC.

    good Lack

  7. #7
    Registriert seit
    09.05.2007
    Beiträge
    188
    Danke
    16
    Erhielt 24 Danke für 23 Beiträge

    Standard

    Hallo,
    bei mir alles OK.
    Hab Dir Teile meines Projekts angehängt vielleicht hilft Dir das weiter.

    Hast Du den Timeouttimer doppelt belegt? Wie länge läuft der Auftrag?
    Geändert von Gecht (07.12.2007 um 10:22 Uhr)

  8. #8
    Flo ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    06.11.2005
    Ort
    daheim natürlich
    Beiträge
    119
    Danke
    11
    Erhielt 2 Danke für 2 Beiträge

    Standard

    @Kurt
    Hab heute mal ins GDC Projekt geschaut. Die Abarbeitungstabelle ist bei 88% (9300 POS). Könnte das der Grund dafür sein? Ne Idee was ich dagegen machen könnte (kann auf keine Bausteine darin verzichten)?

    MfG,
    Flo

  9. #9
    Registriert seit
    21.05.2004
    Beiträge
    418
    Danke
    31
    Erhielt 16 Danke für 8 Beiträge

    Standard

    zuerst musst du mal ergründen ob die Theorie stimmt!
    Wirf mal den Pos Block aus der Tabelle - klar das dann der Antrieb nicht mehr fährt - und schau mal an ob sich das Timing ändert.

    kurt

  10. #10
    Flo ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    06.11.2005
    Ort
    daheim natürlich
    Beiträge
    119
    Danke
    11
    Erhielt 2 Danke für 2 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ja, Theorie stimmt. Sobald ich die RSP aktiviere, aktualisieren sich die Werte sofort.

Ähnliche Themen

  1. S7 314c2DP an Lenze 9300 Servo
    Von litlegerman im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 03.11.2011, 21:57
  2. Antworten: 4
    Letzter Beitrag: 08.04.2011, 09:02
  3. Servo PLC 9300 Positionieren und Overchange
    Von swissm im Forum Antriebstechnik
    Antworten: 1
    Letzter Beitrag: 16.03.2011, 11:38
  4. Antworten: 6
    Letzter Beitrag: 22.02.2011, 08:32
  5. Lenze Pos.Regler 9300 Problem
    Von Erdferkel im Forum Antriebstechnik
    Antworten: 4
    Letzter Beitrag: 29.10.2007, 22:28

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •