Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 4 von 4

Thema: Profibus <-> Festo Controller CMMS Verbindungsproblem

  1. #1
    Registriert seit
    30.08.2008
    Ort
    55452
    Beiträge
    30
    Danke
    13
    Erhielt 0 Danke für 0 Beiträge

    Unglücklich


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,
    Ich sitze zur zeit im Rahmen meines Studiums (also noch ein Neuling) an einem Aufbau mit CPU315 2DP und Festo Controller CMMS für eine Servoachse. Hardwaremässig habe ich alles ohne Problem hinbekommen. Der CMMS besitzt in seinem Einschub eine Profibuskarte. Die erforderlichen GSD-Dateien wurden eingebunden und mittels Dip Schalter die Adresse im Controler und in der Hardware des Simatic Managers eingestellt. Als erstes Projekt habe ich einen von Festo mitgelieferten Baustein verwendet. Hardware und programm wurde in die Steuerung geladen. Sps zeigt auch keinerlei Fehler. Auch die "BUS BEREIT" Led am Controller leuchtet. Wenn ich jedoch in der variablentabelle Bits zur Ansteuerung des Controllers setze, bekomme ich keinerlei Antwort vom Controller.
    Hat zufällig jemand Erfahrung mit diesen Festo-Controllern. Kann ich die Kommunikation über deb Profibus irgendwie kontrollieren.

    Danke und Gruss
    bluesky
    Zitieren Zitieren Profibus <-> Festo Controller CMMS Verbindungsproblem  

  2. #2
    Registriert seit
    01.11.2007
    Beiträge
    1.235
    Danke
    91
    Erhielt 406 Danke für 367 Beiträge

    Standard

    Diesen Controller kenne ich leider nicht, bei anderen Systemen ist es aber i.d.R. so, dass man dem Controller über einen Parameter sagen muss, dass er über Profibus kommunizieren soll. Du kannst ja auch mal dein Projekt hier reinstellen, deiner Beschreibung nach scheint das aber o.k. zu sein.

    Grüße von HaDi

  3. Folgender Benutzer sagt Danke zu HaDi für den nützlichen Beitrag:

    bluesky (04.09.2008)

  4. #3
    Registriert seit
    30.08.2008
    Ort
    55452
    Beiträge
    30
    Danke
    13
    Erhielt 0 Danke für 0 Beiträge

    Lächeln

    Hallo, das Problem an der gnzen Sache ist das dieses Modell relativ neu ist und auch bei uns in der Firma noch nie eingesetzt wurde. Auch bei Festo selber muss man etwas suchen bis man jemanden findet, der sich mit dem Modell auskennt.
    Letztendliches Problem war das der Controller, der über den FB10 gestuert wird. Im Aufruf des Bausteins werden die Ein-und Ausgangadressbereiche in Hex eingestellt, welche mit denen im Hardwaremanager übereinstimmen müssen. Standardmässig sind Ein- und Ausgangsbereiche jeweils mit Hex 100 programmiert, was eigendlich recht wenig Sinn macht. Ändert man den Eingangsbereich auf Hex 104 setzt sich "das Monster" in Bewegung.

    Danke an alle die, die sich meinem Problem angetahn haben.
    Zitieren Zitieren Lösung gefunden  

  5. #4
    Registriert seit
    01.11.2007
    Beiträge
    1.235
    Danke
    91
    Erhielt 406 Danke für 367 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Schön, dass du es zum Laufen bekommen hast, das freut mich.
    Dass du den E-Bereich auf Hex104 ändern musstest deutet m.E. darauf hin, dass dieser FB10 möglicherweise noch nicht ganz ausgereift ist. Es ist an sich nicht ungewöhnlich, dass sowohl E- als auch A-Bereich auf Hex100 eingestellt sind, weil man damit i.d.R. außerhalb des Prozessabbilds liegt und wenn der E/A-Bereich größer als 4Byte ist (wird hier wohl auch so sein), werden dann gerne SFC14/15 benutzt, um die Daten konsistent mit dem Slave auszutauschen.

    Grüße von HaDi

Ähnliche Themen

  1. OP177b - Verbindungsproblem via Profibus
    Von ElektroElch im Forum HMI
    Antworten: 0
    Letzter Beitrag: 20.10.2011, 23:40
  2. Verbindungsproblem mit OP73 am Profibus
    Von LT Smash im Forum HMI
    Antworten: 7
    Letzter Beitrag: 02.02.2010, 13:39
  3. Festo CMMS-ST Verkettete Verfahrsätze ?
    Von erzteufele im Forum Antriebstechnik
    Antworten: 1
    Letzter Beitrag: 08.10.2009, 11:54
  4. Festo SPC200 über Profibus ansteuern
    Von davka im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 04.09.2008, 19:20
  5. VPC3+CLF3 PROFIBUS-DP Slave Controller neue Version
    Von profichip im Forum Werbung und Produktneuheiten
    Antworten: 0
    Letzter Beitrag: 18.06.2008, 09:19

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •