Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 2 ErsteErste 12
Ergebnis 11 bis 14 von 14

Thema: Positionieren mit Lenze 9400 Servodrive

  1. #11
    olitheis ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    26.07.2005
    Beiträge
    454
    Danke
    22
    Erhielt 1 Danke für 1 Beitrag

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo, das hört sich sehr interessant an. Also hast Du die komplette Achsregelung über TwinCAT PLC realisiert(?).
    Ich würde mich freuen, wenn Du mir ein Projekt für meine Applikation zukommenlassen würdest, allerdings kommt eine honorierung hier leider nicht in Frage. Wenn Du es nur gegen Honorar machen möchtest, kann ich das natürlich auch verstehen.

    Wie gesagt, es läuft mit Abstrichen:
    Ein Lenze Techniker hat uns eine eigene Applikation zur Verfügung gestellt, in der 3 Positionen in eine Tabelle geschrieben werden können, wobei es dann hier einen Overwrite für Position, Geschwindigkeit und Beschleunigung für 2 dieser Datensätze gibt. Nicht ganz das, was ich benötige, aber naja.
    Leider habe ich es bis jetzt auch noch nicht hinbekommen, die Werte aus dem HMI vorzugeben. Müssen hier INT bzw. DINT Werte übergeben werden oder skalierte, wie z.B. 2450,00 mm?

    Danke nochmal
    Press "Play" on Tape
    -------------------------------
    TwinCAT
    Step7
    Barber-Colman MacoDS
    Schneider Momentum SPS
    Wonderware 8.0
    Concept 2.2 SR2
    Vipa
    Allen-Bradley

  2. #12
    olitheis ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    26.07.2005
    Beiträge
    454
    Danke
    22
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Hallo, ich muss das Thema noch einmal auffassen:
    Ich habe bei der Achse noch 2 Probleme:
    1. Wir haben vor dem 9400 ein Netzschütz installiert. Was sich im Nachhinein als nicht sehr praktisch erwießen hat. Das Netzschütz wurde aus der SPS heraus angesteuert. Das Problem hierbei ist, dass die interne Kommunikation zwischen Regler und EtherCAT-Schnittstellen-Modul scheinbar erst zustande kommt, wenn der Regler auch seine 400V am Eingang hat. Z. B. beim Einschalten der Anlage (Kaltstart) läuft der Bus nicht korrekt hoch, da der lenze Regler mit Error INIT hängenbleibt. Ich beiß mich quasi in den eigenen Schwanz... Das Schütz ist also rausgeflogen, wie nutzen eine SM100 bei Not-Aus.
    2. Nach jedem Spannungsfreischalten des Reglers muß die Achse neu referenziert werden. Ist das so gewollt bzw. normal?
    Vielen Dank nochmal
    Press "Play" on Tape
    -------------------------------
    TwinCAT
    Step7
    Barber-Colman MacoDS
    Schneider Momentum SPS
    Wonderware 8.0
    Concept 2.2 SR2
    Vipa
    Allen-Bradley

  3. #13
    Registriert seit
    02.09.2007
    Ort
    Wels, Austria
    Beiträge
    61
    Danke
    0
    Erhielt 11 Danke für 9 Beiträge

    Standard

    Es gibt am 9400er eine 24Volt Versorgung, die muss immer an sein, die Leistung bräuchtest du auch nicht wegschalten, da du ein SM100 verwendest. = STO Safe Torque off
    Das mit dem Referenzpunkt ist auch klar, wenn der Regler ausgeschaltet wird, ist auch die Ref weg, könnte man zwar speichern mit einem Parameter.
    Das mit Ethercat ist etwas ähnliches, du solltest den Teilnehmer nicht wegschalten, es gibt hier aber eine FB der den Ethercatbus wieder Initialisieren kann
    IOF_DeviceReset, dort kannst du dann den Ethercatmaster reseten PLC-Library IO_Funktionen im mTC-Hilfesystem

  4. #14
    olitheis ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    26.07.2005
    Beiträge
    454
    Danke
    22
    Erhielt 1 Danke für 1 Beitrag

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Danke nochmal für Deine Hilfe!
    Press "Play" on Tape
    -------------------------------
    TwinCAT
    Step7
    Barber-Colman MacoDS
    Schneider Momentum SPS
    Wonderware 8.0
    Concept 2.2 SR2
    Vipa
    Allen-Bradley

Ähnliche Themen

  1. Lenze Servo Drive 9400 - Kurvenscheibe / CAM
    Von swissm im Forum Antriebstechnik
    Antworten: 1
    Letzter Beitrag: 07.06.2011, 15:47
  2. Antworten: 6
    Letzter Beitrag: 22.02.2011, 08:32
  3. Vergleich SEW Moviaxis oder Lenze 9400 Highline
    Von uwe-huebner im Forum SEW-EURODRIVE
    Antworten: 0
    Letzter Beitrag: 09.04.2010, 21:55
  4. FU Lenze L-Force 9400 & Drivecom
    Von stefmaster im Forum Antriebstechnik
    Antworten: 1
    Letzter Beitrag: 19.07.2007, 15:34
  5. Beckhoff Twincat System Manager und L-Force 9400
    Von stefmaster im Forum Sonstige Steuerungen
    Antworten: 0
    Letzter Beitrag: 19.07.2007, 00:25

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •