Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 9 von 9

Thema: SimoDrive 611A Zugriff über Software / IBS v3.3 an HSA 6SN1121-0BA12-0AA0

  1. #1
    Registriert seit
    27.02.2011
    Beiträge
    10
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo!

    Vor kurzem musste bei uns ein Regeleinschub mit Komfort-Interface (also mit Display) gewechselt werden. Alle Parameter wurden dabei von Hand an dem neuen Regeler eingestellt.
    Nun habe ich nach der Software gesucht und bin auf die IBS v3.3 gestossen. In der Anleitung zum SimoDrive 611A gibt's einen Kabelplan.
    9pol männlich auf 9pol weiblich. Die Pins 2, 3, 5, 7 und 8 sollen 1 zu 1 verbunden werden. Ein solches Kabel habe ich dann erstellt. An einem Testaufbau mit dem Nachfolgetyp 6SN1121-0BA11-0AA1 ließ sich mit diesem Kabel und der Software eine Verbindung aufbauen. Die Parameter konnten auf's PG geladen und wieder zurück geschrieben werden.
    Leider lässt sich aber an der Maschine mit den dort verbauten Regler 6SN1121-0BA12-0AA0 keine Verbindung aufbauen.
    Betriebssystem ist Win 2000.
    Firmware des 6SN1121-0BA12-0AA0: 2.4
    Firmware des 6SN1121-0BA11-0AA1: 3.2
    genutzte Schnittstelle: RS232 an X411

    Da in der Anleitung zur Inbetriebnahme Software eine andere Belegung vorgegeben ist, wurde auch diese Version versucht. (Pins 2 und 3 kreuzen und 7 / 8 im Stecker brücken) Mir dieser Kabelversion konnte aber weder an der Maschine noch am Versuchsaufbau eine Verbinung aufgebaut werden.
    Versuchsweise wurden alle Stecker vom E/R-Modul und vom Regler entfernt; auch ohne Erfolg. (beim Versuchsaufbau ist auch nichts angeschlossen)

    Daher wüsste ich gerne ob die Software-Version für dieses Modul geeignet ist? Die paasende FW-Version kann ausgewählt werden. Laut Siemens ist der Regler 6SN1121-0BA11-0AA1 der Nachfolger für den z.Z. eingesetzten 6SN1121-0BA12-0AA0 und war auch schon in der Maschine eingesetzt. Wo kann das Problem liegen?

    Inzwischen habe ich zusätzlich noch an einem 6SN1151-1cx10-2ab0 versucht eine Verbindung zu erhalten; auch hier ohne Erfolg.

    MfG

    herby
    Zitieren Zitieren SimoDrive 611A Zugriff über Software / IBS v3.3 an HSA 6SN1121-0BA12-0AA0  

  2. #2
    Registriert seit
    25.06.2007
    Ort
    Dresden
    Beiträge
    3.930
    Danke
    465
    Erhielt 878 Danke für 634 Beiträge

    Standard

    Welche Version von SIMUCOM U hast du denn auf deinem Rechner?

    Gruß

    Frank
    Grüße Frank

  3. #3
    herby ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    27.02.2011
    Beiträge
    10
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo Frank

    Inzwischen habe ich den Zugriff auf 2 PGs versucht. Ein altes mit Win98 und da ist keine SimoCom U drauf. Das neuere Fiel-PG hat zwar eine SimoCom U drauf, aber die Version kenn nicht. Bin erst am Montag wieder in der Firma.
    Ich denke aber, dass Du eigenlich die Version der SimoCom A Inbetriebnahmesoftware wissen willst, die an dem Regler genutzt wurde.
    Die Software heisst IBS.exe und hat Version 3.3.
    Nach allem was ich gelesen habe müsste das eigentlich passen. Neue Software kam immer mit neuer Firmware auf den Markt. Die v3.3 beherrscht alle FW ab v2.0. Ein Regler hat die FW 2.4 drin (da komm ich nicht ran), und der zweite ist ein Nachfolger mit der FW 3.2 (da bekomm ich Verbindung).
    Zuletzt hatte ich die Idee den Com-Port langsamer einzustellen. Von den üblichen 9600bit/sec ging's schrittweise bis auf 110bit/sec. runter. Auch alle anderen Einstellungen wurden getestet. Nix!

    Gruß

    herby

  4. #4
    Registriert seit
    25.06.2007
    Ort
    Dresden
    Beiträge
    3.930
    Danke
    465
    Erhielt 878 Danke für 634 Beiträge

    Standard

    SIMODRIVE 611 universal HRS CD mit Toolbox 6SN1153-2NX22-1AG0 mit Software Version: 12.01

    http://support.automation.siemens.co...ew/de/34675909

    Da sollte alles dabei sein - auch die Gerätetypdateien.

    Ich habe alle meine 611er immer nur mit SIMUCOM U parametriert.
    Da ein DP-Modul eingebaut war, war es für mich natürlich einfacher
    als mittels serieller Verbindung. Allerdings muss man dann vorher
    die die richtigen Parameter kennen um die Adresse einzugeben und
    in den EEPROM zu speichern.

    Gruß

    Frank
    Grüße Frank

  5. #5
    herby ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    27.02.2011
    Beiträge
    10
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Danke erst mal. Bei Gelegenheit wird das einfach mal probiert. Ich fürchte aber mir fehlt in den nächsten Wochen die Zeit dafür; Feedback dauert also vermutlich ne Weile. Gruß herby

  6. #6
    Registriert seit
    01.11.2007
    Beiträge
    1.237
    Danke
    91
    Erhielt 407 Danke für 368 Beiträge

    Standard

    Ich geb dann auch mal mein fundiertes Halbwissen dazu:
    Mit der IBS-Software bist du bei 611A richtig unterwegs, SimocomU nimmt man m.W. nur für 611U- und Posmo-Antriebe.
    6SN1121-0BA11-0AA0 : HSA-Regelung analog, kein dir. Messsystem, alte Version
    6SN1121-0BA11-0AA1 : HSA-Regelung analog, kein dir. Messsystem, neue Version
    6SN1121-0BA12-0AA0 : HSA-Regelung analog, dir. Messsystem mit TTL-Signalen
    Ich verwende die IBS V3.2 und folgende Kabelbelegung (die 1:1 sollte aber auch gehen):
    Code:
    PG, 25p.       Antrieb, 9p.
    2------------------3
    3------------------2
    7------------------5
    
    4-I              I-7
    5-I              I-8
    
    6 -I
    20-I
    
    bzw.
    
    PG, 9p.         Antrieb, 9p.
    2------------------2
    3------------------3
    5------------------5
    
    7-I              I-7
    8-I              I-8
    
    4-I
    6-I
    Unter Win2000 (besser wäre wohl ein "echtes" DOS) ist die Onlineverbindung recht instabil, d.h. bis zum Verbindungsaufbau kann es schon mal 3-4 Versuche dauern, auch kann die Verbindung immer mal abbrechen, man kann aber damit arbeiten. Ich habe in dieser Konstellation schon mehrfach Diagnose betrieben und auch Baugruppen getauscht bzw. wieder in Betrieb genommen.
    Dass es abhängig vom SW-Stand oder HW-Stand Probleme gibt ist mir nicht bekannt (heißt aber nix!), wenn eine Baugruppe nicht mit dir sprechen will ist sie (bzw. die Schnittstelle) vielleicht einfach nur defekt?

    Grüße von HaDi

  7. #7
    herby ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    27.02.2011
    Beiträge
    10
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Also es war mir heute gegönnt es mit der SimoCom U kurz zu testen. Wie erwartet kam es aber zu keiner Verbindung. Es wurden wieder die 1zu1 und die gekreuzte Version probiert.

    @HaDi: 1. warst Du an den von Dir aufgezählten Reglern schon online?
    2. Mit dem neueren Regler konnte ich unter Win 2000 arbeiten. Abstürze gab's allerdings einige Male. Das wäre mit aber egal. Mit Win98, das ja noch ein echtes DOS als Unterbau hat kam ich auch nicht an besagten Reglern online.
    3. defekte Schnittstelle hatte ich auch schon gedacht. Leider fehlt mit ein Regler gleichen Typ's zum Testen. Es wären aber auch schon 2 defekte Regler unterschiedlichen Typ's die defekt sein müssten.
    4. Kannst Du die Version 3.2 mal per Mail schicken? Es reichen die installierten Dateien, weil es ja auf DOS basiert und keine Einträge in die Registry vornimmt. Oder war die Version noch nicht kostenlos?

    In jedem Fall schon mal Danke für eure Tipps.

    Gruß

    herby

  8. #8
    Registriert seit
    01.11.2007
    Beiträge
    1.237
    Danke
    91
    Erhielt 407 Danke für 368 Beiträge

    Standard

    Ich hab jetzt noch mal im Handbuch geblättert und weiß nun, dass die 0AA0-Baugruppen nur FW bis 2.X können und die 0AA1 für FW3.x sind, ein FW-Hoch- bzw. Runterrüsten (von 2.x auf 3.x bzw. entgegengesetzt) geht dann auch nicht. In den gesicherten Daten (reine ASCII-Files) wird der FW-Stand abgelegt, das führt dazu, dass es Mecker gibt, wenn die Zielbaugruppe einen kleineren FW-Stand hat.
    Die Version 3.3 der IBS-Software läuft bei mir ohne Murren, sowohl unter Win98-DOS als auch unter XP auf einem aktuellen FieldPG M3 (getestet mit einer 6SN1122-0BA11-0AA1), an eine 0AA0-Baugruppe komme ich z.Zt. nicht ran.
    Mit welchem Gerät arbeitest du?
    Hat es eine Com-Schnittstelle oder benutzt du einen Adapter/Converter?
    Welche Meldung kommt genau beim Online-Gehen?

    Grüße von HaDi

  9. #9
    herby ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    27.02.2011
    Beiträge
    10
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo HaDi!

    Das mit den FW-Ständen hatte ich auch schon gelesen. Die Software erlaubt mir ja die FW 2.x auszuwählen. Sollte ja eigentlich klappen. Darum bleib ich auch so hartnäckig am Ball.
    Gesicherte Daten gibt's noch keine. Genau die will ich gerne anlegen, bzw. die Daten bei Defekt auslesen und halt wieder einspielen. (anstatt es wieder von Hand einzugeben)
    Zum Testen versuche ich einfach online Werte zu ändern. Bei den neuen Baugruppen klappt das. Die erwähnten älteren Regler mit FW 2.x melden dann aber "Verbindung zum Umrichter gestört" bevor eine Verbindung aufgebaut wird. Das passiert mit beiden Reglern vom älteren Typ, die mir zur Verfügung stehen. Leider stehen bei uns auch keine weiteren Einschübe alter Bauart zur Verfügung.

    Als PG kommt ein altes Field-PG zum Einsatz. Da ist noch so ein Adapter-Klotz dran, an dem neben der S5-Schnittstelle noch der Drucker und Com2 zur Verfügung stehen. => Win2000
    Darüber hinaus haben wir noch ein ganz altes PG. Der Typ fällt mir jetzt nicht ein. Vorgänger der Field-PGs und wurde mit Win98 ausgeliefert. Hier wurde direkt am Gerät die Com2-Schnittstelle genutzt.

    Die Einstellungen des Com-Ports wurden auch schon verändert. Geschwindigkeit schrittweise bis auf's Minimum und auch allen anderen "Schrauben" wurde gedreht.

    Gruß

    herby

Ähnliche Themen

  1. Suche: S7-300 Busverbinder 6ES7390-0AA0-0AA0
    Von DasF im Forum Suche - Biete
    Antworten: 0
    Letzter Beitrag: 05.05.2010, 16:12
  2. Antworten: 0
    Letzter Beitrag: 06.04.2009, 13:45
  3. Siemens 611A 6SC 6112-0AA00
    Von Guste im Forum Antriebstechnik
    Antworten: 7
    Letzter Beitrag: 11.03.2009, 15:03
  4. Tippbetrieb mit Simodrive 611U über FB83
    Von Rodewijn im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 06.08.2007, 16:06
  5. Simodrive 611U Ändern der Verfahrsätze über Profibus
    Von chr.vogel im Forum Antriebstechnik
    Antworten: 0
    Letzter Beitrag: 02.07.2006, 18:21

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •