Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 2 ErsteErste 12
Ergebnis 11 bis 15 von 15

Thema: S7 T-CPU Betriebsart Tippen gesteuert

  1. #11
    Registriert seit
    17.07.2006
    Beiträge
    352
    Danke
    0
    Erhielt 79 Danke für 70 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Die Normierung zwischen 611A und T-CPU muss passen. D.h. in diesem Fall gibt die Max Geschwindigkeit (siehe unter Begrenzungen) den Wert an, bei dem die IM174 10V ausgibt. Das kannst Du prüfen, wenn Du mit
    Move_Velocity und Position Control = False die Achse verfährst, dann müssen bei genau dieser Geschwindigkeit am Ausgang an der IM174 10 V rauskommen, was nat. auch der tatsächlichen Geschwidigkeit (Motorumdrehungen bei 10 V am Umrichter) entsprechen muss. Wenn das nicht passt arbeitet der Lageregler falsch !
    Ansonsten sollten die Werte für Beschleunigung etc. plausible Werte enthalten, dann läuft das Ganze problemlos (hab ich früher X-Mal gemacht)

  2. #12
    mitchih ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    09.11.2006
    Beiträge
    693
    Danke
    36
    Erhielt 31 Danke für 29 Beiträge

    Standard

    Zitat Zitat von offliner Beitrag anzeigen
    Die Normierung zwischen 611A und T-CPU muss passen. D.h. in diesem Fall gibt die Max Geschwindigkeit (siehe unter Begrenzungen) den Wert an, bei dem die IM174 10V ausgibt. Das kannst Du prüfen, wenn Du mit
    Move_Velocity und Position Control = False die Achse verfährst, dann müssen bei genau dieser Geschwindigkeit am Ausgang an der IM174 10 V rauskommen, was nat. auch der tatsächlichen Geschwidigkeit (Motorumdrehungen bei 10 V am Umrichter) entsprechen muss. Wenn das nicht passt arbeitet der Lageregler falsch !
    Ansonsten sollten die Werte für Beschleunigung etc. plausible Werte enthalten, dann läuft das Ganze problemlos (hab ich früher X-Mal gemacht)
    Hi,
    kann es sein das deine beschriebene Vorgehensweise genau meiner gesuchten Vorgehensweise entspricht??
    Also um meine Achse zu testen suche ich ja nach einer Möglichkeit einen festen Analogwert vorzugeben. Oder regelt der Move Velocity auch?? bei der von dir beschriebenen Beschaltung? Ich möchte ja meine Achse einfach steuern.

    Am besten wäre es wenn nicht mal eine Störung kommen würde wenn die Achse nicht fährt, z.B. weil ich die Reglerfreigabe abziehe.

    Dann hätte ich ja alles was ich Suche.
    Zeige nie deine Verblüffung, wenn dir etwas auf Anhieb gelingt.

    Praxis: Es funktioniert aber keiner weiß warum!

  3. #13
    Registriert seit
    17.07.2006
    Beiträge
    352
    Danke
    0
    Erhielt 79 Danke für 70 Beiträge

    Standard

    Mit Position Control = FALSE am MoveVelocity ist der Lageregler nicht aktiv, d.h. es wird rein gesteuert ein Sollwert ausgegeben. Wenn nun also die Sollgeschwindigkeit am MoveVelocity der Max Geschwindigkeit unter Begrenzungen entspricht, werden 10 V ausgegeben (wenn man nicht in der Expertenliste die Spannungsnormierung ändert). Die Reglerfreigabe wird ja eigentlich über einen DO der IM174 auf den Antrieb geschaltet und mittels MC_Power gesetzt. Wenn mich nicht alles täuscht, gibt es auch einen DI für die Rückmeldung, der dann den Status des MC_Power auf TRUE setzt. Wenn diese Rückmeldung nicht weggenommen wird, dürfte auch kein Fehler kommen, wenn die Reglerfreigabe nicht über die IM174, sondern extern erfolgt.

  4. Folgender Benutzer sagt Danke zu offliner für den nützlichen Beitrag:

    mitchih (05.01.2012)

  5. #14
    mitchih ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    09.11.2006
    Beiträge
    693
    Danke
    36
    Erhielt 31 Danke für 29 Beiträge

    Standard

    Hallo,

    vielen Dank,
    ich denke damit komme ich auf jeden Fall weiter.
    Ich wollte als erstes mal die RFG abgezogen lassen. Die T-CPU kann sie ja ruhig einschalten. Dann kann ich in Ruhe den Sollwert messen. Habe ja meine Altanlage und einen Referenzwert, daher kann ich dann die Skalierung einfach prüfen.
    Wenn das alles passt, dann ist das ganze ja kein Problem. Dann sollte sich der Fehler finden lassen.

    Vielen Dank.
    Zeige nie deine Verblüffung, wenn dir etwas auf Anhieb gelingt.

    Praxis: Es funktioniert aber keiner weiß warum!

  6. #15
    Registriert seit
    17.07.2006
    Beiträge
    352
    Danke
    0
    Erhielt 79 Danke für 70 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Drive Ready Signal nicht vergessen, sonst liefert der MC_Power kein Status = TRUE und es wird kein Sollwert über die Klemmen ausgegeben.

Ähnliche Themen

  1. Wendeschützschaltung über SPS gesteuert
    Von student_ieb im Forum Simatic
    Antworten: 13
    Letzter Beitrag: 03.06.2011, 17:58
  2. Schutztüre gesteuert mit der Siemens Logo
    Von pat im Forum Programmierstrategien
    Antworten: 40
    Letzter Beitrag: 10.04.2008, 18:01
  3. Antworten: 5
    Letzter Beitrag: 28.03.2008, 16:06
  4. Empfehlung Antriebspaket PC-gesteuert aus einer Hand?
    Von SIMajo im Forum Antriebstechnik
    Antworten: 12
    Letzter Beitrag: 24.05.2007, 23:16
  5. Antworten: 6
    Letzter Beitrag: 01.03.2005, 20:17

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •