Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 13

Thema: Simodrive 611 - Störung/Ausfall - Ursache unbekannt

  1. #1
    Registriert seit
    07.03.2012
    Beiträge
    18
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo

    ich habe an einer Drehmaschine ein Problem mit der Hauptspindel.
    Nach einem merkwürdigen Zwischenfall regelt die Simodrive nicht mehr so richtig. Bei diesem Zwischenfall sollte die Spindel positionieren, sie hat aber willkürlich bis auf Maximaldrehzahl gedreht.

    Man kann die 100kW Hauptspindel, wenn sie jetzt in Positionsregelung ist, mit der Hand um einige Grad wegdrücken und sie pendelt wieder zurück.

    Auch wenn die Hauptspindel in Drehzahlregelung ist, pendelt sie sich langsam in Richtung Solldrehzahl. Laut Oszi auf der Sinumerik pendelt der Motorstrom sowohl bei Drehzahlregelung als auch bei Positionsregelung.

    Zur Maschine:
    1. Sie ist ca. 2 Jahre alt
    2. Die Spindel wird oft bis zu 100% Auslastung betrieben
    3. 100% programmierte Leistung sind 100% Motorleistung
    4. Motor ist ein Torque Motor der Marke Kessler mit 100kW (11.000Nm)
    5. Antriebs- sowie Achsparameter sind noch im Auslieferungszustand (alle kontrolliert)

    Wir bekommen heute sowohl die Regeleinheit als auch den Leistungsteil. Ich vermute, dass das Regelmodul defekt ist und werde auch daher dieses zuerst tauschen.

    Hat schon mal jemand etwas ähnliches erlebt? Ich würde gerne die Ursache kennen. Denn wenn schon nach 2 Jahren unterdurchschnittlichen Betrieb der Antrieb defekt ist, sollten wir entweder die 100% Leistungsgrenze senken oder ein paar Regelmodule auf lager legen.

    MfG
    Zitieren Zitieren Simodrive 611 - Störung/Ausfall - Ursache unbekannt  

  2. #2
    Registriert seit
    05.04.2012
    Beiträge
    962
    Danke
    97
    Erhielt 217 Danke für 192 Beiträge

    Standard

    ... wenn man den Motor jetzt wegdrücken kann, was wohl zuvor nicht ging, dann hat der nun weniger Drehmoment. Ursache könnte sein, dass der Geberanbau nicht mehr ganz passt - ist ja auch ein Direktantrieb (Synchronmotor), der nun etwas fehlorientiert sein könnte. Ebenso werden hier die Geber "irgendwie" in die Maschine verbaut.
    Dass das Leistungsteil einen Schaden hat, glaube ich weniger (aber kannst ja mal tauschen und berichten ...).

    Grüße
    Zako

  3. Folgender Benutzer sagt Danke zu zako für den nützlichen Beitrag:

    bigmachines (21.01.2013)

  4. #3
    bigmachines ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    07.03.2012
    Beiträge
    18
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo Zako,

    an das habe ich auch gleich gedacht. Wenn ich die ca. 1t schwere Vertikalspindel drehe zählt der Geber schön mit. Der Geber ist auch direkt mit dem Rotor verbunden. Die Spindel regelt auf eine gewisse Position, aber das ziemlich lasch, wie wenn die Regelparameter nicht mehr passen würden. Die Position stimmt aber immer, egal wie fest und oft ich drücke.

    Habe heute das Regelmodul getauscht, leider mit dem selben Ergebnis. Das richtige Leistungsmodul kommt morgen.

    Unten sind 2 Abbilder vom Oszi. Hier sieht man wie der Stromregler bei konstanter Fahrt und Positionierung verrückt spielt.

    20130118_115410.jpg20130118_115628.jpg

  5. #4
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.752
    Danke
    323
    Erhielt 1.526 Danke für 1.286 Beiträge

    Standard

    Das der Geber noch Zählt, und das u.U. auch "richtig" mag schon sein,
    aber die Nullmarke des Gebers muss sich in einer exakt justierten Position "Rotorlage" befinden,
    diese dient praktisch als Feldorientierung für das Antriebssystem, ohne diese eine exakt definierte Position,
    kann der Motor nicht korrekt geregelt werden.

    Mfg
    Manuel
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

  6. Folgender Benutzer sagt Danke zu MSB für den nützlichen Beitrag:

    bigmachines (21.01.2013)

  7. #5
    bigmachines ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    07.03.2012
    Beiträge
    18
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Danke für den Hinweis. Ich dachte die Rotorlage wird nur über Hall-Sensoren, Absolutencoder oder die rückinduzierte Spannung ermittelt.

    In dieser Anleitung ist aber beschrieben wie die Rotorlage für Linearmotoren und Spindelmotoren mit Inkrementalgebern neu eingelernt werden kann: http://support.automation.siemens.co..._050324_00.pdf

    Werde das morgen gleich probieren bevor ich das Leistungsmodul wechsle.

  8. #6
    Registriert seit
    03.04.2008
    Beiträge
    6.206
    Danke
    237
    Erhielt 817 Danke für 691 Beiträge

    Standard

    Zitat Zitat von bigmachines Beitrag anzeigen
    Bei diesem Zwischenfall sollte die Spindel positionieren, sie hat aber willkürlich bis auf Maximaldrehzahl gedreht.

    Man kann die 100kW Hauptspindel, wenn sie jetzt in Positionsregelung ist, mit der Hand um einige Grad wegdrücken und sie pendelt wieder zurück.

    Auch wenn die Hauptspindel in Drehzahlregelung ist, pendelt sie sich langsam in Richtung Solldrehzahl. Laut Oszi auf der Sinumerik pendelt der Motorstrom sowohl bei Drehzahlregelung als auch bei Positionsregelung.
    Welche Steuerung ist denn verbaut? Siemens 840 oder 810 ?
    Ich würde ein Programm für die Spindel schreiben, damit diese mit verschiedenen Drehzahlen, Richtungen und Positionieren betrieben wird.
    Dann mit dem Servotrace die Kurven aufnehmen, dann siehst du was geschieht.
    Zusätzlich verschiedene Position mechanisch prüfen ob die Wiederholung genau ist.

    Wenn dir einmal die Spindel durchgegangen ist, würde ich nicht mehr so viel Versuche machen, bis du weißt warum es geschehen ist.
    Wenn ein Spindel richtig durchgeht, dann hilft auch kein Schutz mehr.


    bike
    "Any fool can write code that a computer can understand.
    Good programmers write code that humans can understand."
    --Martin Fowler

  9. #7
    bigmachines ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    07.03.2012
    Beiträge
    18
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Welche Steuerung ist denn verbaut? Siemens 840 oder 810 ?
    Ich würde ein Programm für die Spindel schreiben, damit diese mit verschiedenen Drehzahlen, Richtungen und Positionieren betrieben wird.
    Dann mit dem Servotrace die Kurven aufnehmen, dann siehst du was geschieht.
    Zusätzlich verschiedene Position mechanisch prüfen ob die Wiederholung genau ist.
    Siehe zweiter Beitrag von mir. 2 Bilder zeigen den Servotrace in Positionsregelung und Drehzahlregelung. Steuerung ist 840D SL

  10. #8
    Registriert seit
    03.04.2008
    Beiträge
    6.206
    Danke
    237
    Erhielt 817 Danke für 691 Beiträge

    Standard

    Also ich sehe eigentlich nicht, wie sich der Antrieb beim Bremsen und positionieren verhält.
    Außerdem war der Hinweis darauf ausgerichtet, ob die Spindel sich bei mehrenen Positionierungen gleich verhält oder verschieden.
    Wenn ich die Kurven so sehe, dann würde ich zunächst den Nullpunkt mechanisch einstellen und dann den Abtrieb darauf abgleichen.

    Ich denke weder Regler noch Leistungsteil sind defekt.


    bike
    "Any fool can write code that a computer can understand.
    Good programmers write code that humans can understand."
    --Martin Fowler

  11. #9
    bigmachines ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    07.03.2012
    Beiträge
    18
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Im ersten Bild sieht man wie sich der Antrieb beim Positionieren verhält. Man sieht 3 Stufen und wie sich die Achse einpendelt.
    Die Stromregelung werkt wie verrückt.

    Im zweiten Bild sieht man wie der Motor im Beschleunigungsvorgang um die Solldrehzahl schwingt und auch wenn die programmierte Drehzahl erreicht ist, schwingt die Ist-Drehzahl weiter, die Amplitude schwächt aber ab.

    Egal in welchem Quadraten oder Anstellung man positioniert, es ist immer das selbe. Im JOG-Modus sieht es noch deutlich schlimmer aus. Da schwingt die Drehzahlamplitude im ersten Ausschlag zuerst auf 200% Nenndrehzahl, dann auf 0% und schwingt sich innerhalb von 10s auf die vorgegebene JOG-Drehzahl ein.

    Morgen bin ich klüger. Werde zuerst den Inbetriebnahmetechniker der Anlage zu Rate ziehen, bevor ich die Rotorlagenidentifikation durchführe. Mir kommt das doch ein wenig Merkwürdig vor.

    Wir können immerhin die Maschine stromlos machen, das Backenfutter drehen und beim Einschalten ist die Maschine trotzdem sofort in Positionsregelung. Das dürfte grundsätzlich nicht funktionieren, wenn der Inkrementalgeber die Rotorlage misst.

  12. #10
    bigmachines ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    07.03.2012
    Beiträge
    18
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Habe heute die Rotorlageidentifikationsmethode ermittelt. Die Maschine ermittelt beim Antriebsstart die Rotorlage nicht über den Geber, sondern so wie es üblich ist, über eine Messung des magnetischen Flußmaximums.

    Über den Geber wird nur die Position festgehalten. Der Geber kann also willkürlich zum Motor orientiert sein. Man muss den Antrieb nur neu starten und die Rotorlage ist wieder bekannt.
    Mittels dem Parameter 1736 kann ein erneute Ausrichtung initiiert werden. Das Ergebnis bestätigt meine Befürchtung, dass das Leistungsteil defekt ist. Die Rotororientierdifferenz (1737) ändert sich von 1° auf bis zu 20°. Der Wert muss unter 2° liegen.
    Irgendwas haut mit der Strommessung also nicht so recht hin.

Ähnliche Themen

  1. Simodrive 611 Fehlercode F09
    Von CZach001 im Forum Antriebstechnik
    Antworten: 5
    Letzter Beitrag: 03.04.2012, 07:53
  2. Simodrive 611 - Überspannung Zwischenkreis
    Von ToBo im Forum Antriebstechnik
    Antworten: 3
    Letzter Beitrag: 21.05.2010, 08:58
  3. Biete Simodrive 611 Module
    Von WL7001 im Forum Suche - Biete
    Antworten: 3
    Letzter Beitrag: 14.07.2009, 20:26
  4. Simodrive 611
    Von M-Arens im Forum Antriebstechnik
    Antworten: 3
    Letzter Beitrag: 21.02.2007, 08:11
  5. simodrive 611 analog
    Von tommy im Forum Suche - Biete
    Antworten: 1
    Letzter Beitrag: 24.03.2005, 19:12

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •