Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 5 von 5

Thema: Parameterzugriff auf FU über Profibus

  1. #1
    Registriert seit
    28.03.2013
    Beiträge
    3
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo alle zusammen,
    ich hätte paar Fragen, was Parameterzugriff auf FU FC 300 Danfos angeht. Ich will die Parameter im FU über WinCC ändern können. Dafür habe ich den FU an S7-400 über Profibus angeschlossen. Das Program im S7 ist auch ziemlich einfach und dafür eine einfache grafische Oberfläche im WinnCC gemacht. Was man machen muss ist nur die Variable, die über WinCC geändert wird, auf die zugeordnete Eingangsadresse auf Profibus schreiben oder wenn man lesen will, dann die zugeordnete Ausgangsadresse benutzen.
    Bei dem FU Danfos ist es so, dass man zum Steuern und Überwachen des FUs über den Profibus den Prozessdatenteil PPO benutzt. Parameterzugriff erfolgt über PCV-Kanal. Die ganzen Werte, ParameterNr, Parameterwert, Subindex, RC-teil….schreibe ich auf die richtige Stelle im PCV-Teil ein.
    Das Problem ist es: wenn ich im WinnCC (oder in S7 als Steuerwert) einen Wert eingebe, übernimmt der FU die Werte erstmal nicht. Erst wenn ich die SPS mit dem Betriebsschalter in STOP bringe (oder wenn ich FU ausschalte und wieder einschalte), dann übernimmt er die Werte. Und die sind im LCP (am Display) des FUs zu sehen. Die Antwort vom FU, dass die Werte übernommen wurden, kommt auch erst bei der Umschaltung.
    Mein Verdacht war, dass man im FU einen Parameter einstellen muss, so dass der FU die Werte immer übernimmt und in LCP speichert. Aber laut der Anleitung für den FU habe ich alle nötigen Parameter eingestellt. Bei Danfos Suport angerufen, die meinen auch alles gut eingestellt. Jetzt ist mein Verdacht an SPS. Vielleicht muss ich da was einstellen, dass man den Zustand oder den Fall bekommt, was es bei der Umschlatung von RUN auf STOP passiert.
    Fragen: Was passiert da auf dem Bus und in SPS bei bei der Umschaltung (oder wenn ich FU aus- und einschalte)?
    Hat jemand Erfahrung mit dem Parameterzugriff auf FU über Profibus?

    Danke
    Zitieren Zitieren Parameterzugriff auf FU über Profibus  

  2. #2
    Registriert seit
    29.03.2004
    Beiträge
    5.731
    Danke
    143
    Erhielt 1.685 Danke für 1.225 Beiträge

    Standard

    Was für Parameter willst du denn verändern? Es lassen sich nicht alle Parameter bei laufendem Motor umstellen.

  3. #3
    cravate ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    28.03.2013
    Beiträge
    3
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Ich will alle Parameter ändern können. Aber es muss nicht sein bei laufendem Betrieb.

    Der FU ist nicht mit einem Motor verbunden, sondern liegt auf meinem Tisch und ist nur mit SPS verbunden. (Testen) Mit Steuer wort habe ich auch den Motor ausgeschaltet.

    Zum Test nehme ich immer Rampenzeit (Parameter 3-41). Mit anderen habe ich auch gemacht, z.B. 8-03 (Steuerwort-Timeout-Zeit). Immer dasselbe.

  4. #4
    Registriert seit
    29.03.2004
    Beiträge
    5.731
    Danke
    143
    Erhielt 1.685 Danke für 1.225 Beiträge

    Standard

    Was antwortet dir denn der FU wenn du den Schreibbefehl an ihn abgesetzt hast, gibt es da eine Fehlernummer?

  5. #5
    cravate ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    28.03.2013
    Beiträge
    3
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Der antwortet erst bei der Umschaltung...oder wenn ich den aus- und einschalte...und das meist positive anwort, dass der Wert übernommen wurde oder negative antwort wenn ich was falsches eingebe...und die ANwort steht dann bis zur nächsten Umschaltung (FU Ein- Aus)!

Ähnliche Themen

  1. Antworten: 4
    Letzter Beitrag: 05.11.2012, 15:21
  2. Antworten: 1
    Letzter Beitrag: 18.04.2012, 10:35
  3. Über Ethernet auf Profibus
    Von Domi55 im Forum HMI
    Antworten: 6
    Letzter Beitrag: 02.03.2009, 19:39
  4. Über MPI auf OP am Profibus routen?
    Von SPS_79 im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 14.08.2007, 19:32
  5. Antworten: 14
    Letzter Beitrag: 04.12.2006, 10:19

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •