Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 2 ErsteErste 12
Ergebnis 11 bis 19 von 19

Thema: Positionierproblem Sinamics

  1. #11
    Registriert seit
    05.04.2012
    Beiträge
    949
    Danke
    94
    Erhielt 216 Danke für 191 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    ... kontrolliere bitte mal Deine AUS1 und AUS3 Rampen (p1131, p1135 (?))
    Wenn Du z.B. einen Schleppabstandsfehler hast, dann reagiert der Antrieb mit einer Fehlerreaktion (z.B. AUS1, ist auch parametrierbar). Da solltest Du geeignete Rücklauframpen einstellen (die beziehen sich ja auf die Maximaldrehzahl (p1082) und nicht auf EPos- Maximalgeschwindigkeit).
    Wenn Du z.B. mit SINAMICS G (mit EPos- Funktionalität) im TIA Portal arbeiten würdest, dann würden entsprechende Rampen automatisch vorgeschlagen. Wenn Du mit STARTER arbeitest, dann sind zumindest in den EPos- Rampeneinstellungen entsprechende Hinweise, aber eben nicht so gut gelöst wie im TIA Portal.

    Ich weiss jetzt nicht ob das wirklich die Ursache für Dein Problem ist, wäre aber eine Möglichkeit.
    Geändert von zako (29.06.2014 um 21:12 Uhr)

  2. #12
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    12.220
    Danke
    533
    Erhielt 2.696 Danke für 1.948 Beiträge

    Standard

    Zitat Zitat von zako Beitrag anzeigen
    ... kontrolliere bitte mal Deine AUS1 und AUS3 Rampen (p1131, p1135 (?))
    Wenn Du z.B. einen Schleppabstandsfehler hast, dann reagiert der Antrieb mit einer Fehlerreaktion (z.B. AUS1, ist auch parametrierbar). Da solltest Du geeignete Rücklauframpen einstellen (die beziehen sich ja auf die Maximaldrehzahl (p1082) und nicht auf EPos- Maximalgeschwindigkeit).
    Wenn Du z.B. mit SINAMICS G (mit EPos- Funktionalität) im TIA Portal arbeiten würdest, dann würden entsprechende Rampen automatisch vorgeschlagen. Wenn Du mit STARTER arbeitest, dann sind zumindest in den EPos- Rampeneinstellungen entsprechende Hinweise, aber eben nicht so gut gelöst wie im TIA Portal.

    Ich weiss jetzt nicht ob das wirklich die Ursache für Dein Problem ist, wäre aber eine Möglichkeit.
    Ich sehe mit das morgen natürlich mal an, danke.

    Das würde ich trotzdem nicht verstehen, denn ich habe die Maximaldrehzahl im Servo begrenzt und zwar unterhalb der, die der Motor eigentlich leisten sollte. Bis zum Crash, war der Schleppfehler unter 150 als unter 1,5 mm. Ich testendes Ganze morgen mal mit freiem Servomotor, so dass nichts passieren kann.

    Auch würde ich nicht verstehen, warum er bei einem Schleppabstandsfehler seine Zielposition ignoriert und über das Ziel hinausschießt, denn das berechnete und im Sollprofil vorgegebene Ziel ändert sich ja nicht.
    Er ist auch statt nach 700mm anzuhalten 500mm weitergefahren, so groß kann der Schleppabstandsfehler eigentlich nicht angewachsen sein.
    Geändert von Ralle (29.06.2014 um 22:02 Uhr)
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

  3. #13
    Registriert seit
    05.04.2012
    Beiträge
    949
    Danke
    94
    Erhielt 216 Danke für 191 Beiträge

    Standard

    Zitat Zitat von Ralle Beitrag anzeigen
    Auch würde ich nicht verstehen, warum er bei einem Schleppabstandsfehler seine Zielposition ignoriert und über das Ziel hinausschießt, denn das berechnete und im Sollprofil vorgegebene Ziel ändert sich ja nicht.
    Naja wenn Du eine Störreaktion AUS1, AUS2 oder AUS3 hast, dann bedeutet das bei AUS1 oder AUS3, dass der Antrieb drehzahlgeregelt an einer Rücklauframpe abbremst - der Einfachpositionierer ist da schon abgehängt. Bei AUS2 würde der Antrieb einfach ausdrudeln und somit je nach Reibung erst recht übers Ziel schießen.
    Bei SAFETY ist das ja auch so, dass die Sollwerte von überlagerten Interpolator (egal ob EPos, irgendeine MotionControl Steuerung etc.) ignoriert werden und der Antrieb bei SS1 seine AUS3 Rampe macht. Wäre halt nicht so toll, wenn da z.B. 5 Sekunden drinn stehen würden und man normallerweise in 500ms bremsen würde.
    Die Zielposition wird hier nicht berücksichtigt, da müsste man der AUS1/3- Rampe den Bremseinsetzpunkt des EPos (incl. Rampen) übergeben und wäre dann trotzdem nur drehzahlgeregelt.
    Und was wollte man dann mit den Anwendungen machen, wo man z.B. mit DC- Einprägung oder Ankerkurzschlussbremsung etc. abbremsen muss - da hätte man kaum noch ein definiertes Verhalten.

  4. Folgender Benutzer sagt Danke zu zako für den nützlichen Beitrag:

    Ralle (30.06.2014)

  5. #14
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    12.220
    Danke
    533
    Erhielt 2.696 Danke für 1.948 Beiträge

    Standard

    @zako
    p1131 gibt es bei mit nicht (Sinamics S110) p1135(0) Aus3 ist auf 0.0 (standard), da nehme ich an, so schnell wie möglich, oder?
    Ich bin auch ziemlich sicher, dass mein Handling mit voller Kraft in den Crash gegangen ist, da war nichts mit austrudeln oder runterrampen.

    Es kommt tatsächlich der Schleppabstand.
    Die Fehlerreaktion ist mit aber unklar, sieht aus, als wenn er mit einer Riesenrampe runterrampen will, dann aber die Epos-Freigabe weggenommen wird (Ich fahre im Moment über Starter).
    Geändert von Ralle (30.06.2014 um 07:20 Uhr)
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

  6. #15
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    12.220
    Danke
    533
    Erhielt 2.696 Danke für 1.948 Beiträge

    Standard

    @zako
    Argh, ich hab es gefunden.
    p1121 steht Standardmäßig auf 10s (Denke mal den meintest du oder)
    Na toll, weg seine Achse mit Epos zu schnell fahren will, bekommt eine Schleppabstand und dann rampt die Achse in 10 Sekunden runter, bum.
    Das hab ich jetzt mal auf 0.2 Sekunden gestellt und schon sieht das viel besser aus. Danke zako für den Hinweis.
    Sollte Siemens da nicht besser den sicheren Weg gehen und eine kleinere Rampe als Standard einstellen? Oder gibt es andere Gründe für diese 10 Sekunden-Rampe?
    Das kenne ich von anderen Herstellern genau umgekehrt.
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

  7. #16
    Registriert seit
    05.04.2012
    Beiträge
    949
    Danke
    94
    Erhielt 216 Danke für 191 Beiträge

    Standard

    Zitat Zitat von Ralle Beitrag anzeigen
    p1121 steht Standardmäßig auf 10s (Denke mal den meintest du oder)
    Ja richtig, habe leider auch nicht alle Parameter im Kopf

    Zitat Zitat von Ralle Beitrag anzeigen
    @zako
    Sollte Siemens da nicht besser den sicheren Weg gehen und eine kleinere Rampe als Standard einstellen? Oder gibt es andere Gründe für diese 10 Sekunden-Rampe?
    Der EPos kam ja erst später rein - zuvor gab es als Sollwertquelle nur den Drehzahlhochlaufgeber, da waren die 10 Sekunden als Rampen wohl okay (erst recht, wenn man bedenkt, dass der SINAMICS bis in den MW- Bereich geht). Da wollte man wohl aus Kompatibilitätsgründen nichts mehr ändern.
    Wie gesagt, im STARTDRIVE werden nun neben den Beschleunigungs-/Verzögerungswerten auch die entsprechenden Beschleunigungs-/Verzögerungszeiten angezeigt, welche man mit einem Button als AUS1/AUS3- Rücklauframpen übernehmen kann.
    Geändert von zako (30.06.2014 um 08:33 Uhr)

  8. Folgender Benutzer sagt Danke zu zako für den nützlichen Beitrag:

    Ralle (30.06.2014)

  9. #17
    Registriert seit
    16.03.2006
    Ort
    Franken
    Beiträge
    3.793
    Danke
    30
    Erhielt 916 Danke für 797 Beiträge

    Standard

    Zitat Zitat von zako Beitrag anzeigen
    Wie gesagt, im STARTDRIVE werden nun neben den Beschleunigungs-/Verzögerungswerten auch die entsprechenden Beschleunigungs-/Verzögerungszeiten angezeigt, welche man mit einem Button als AUS1/AUS3- Rücklauframpen übernehmen kann.
    Schön für den STARTDRIVE nur leider nüzt das für die betreffenden Geräte der S110/S120 Linie nix, weil die ja nicht vom STARTDRIVE unterstützt werden.

  10. #18
    Registriert seit
    05.04.2012
    Beiträge
    949
    Danke
    94
    Erhielt 216 Danke für 191 Beiträge

    Standard

    Zitat Zitat von ChristophD Beitrag anzeigen
    Schön für den STARTDRIVE nur leider nüzt das für die betreffenden Geräte der S110/S120 Linie nix, weil die ja nicht vom STARTDRIVE unterstützt werden.
    ... siehe Beitrag #11

  11. #19
    Registriert seit
    03.04.2008
    Beiträge
    6.200
    Danke
    237
    Erhielt 815 Danke für 689 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von Ralle Beitrag anzeigen
    Sollte Siemens da nicht besser den sicheren Weg gehen und eine kleinere Rampe als Standard einstellen? Oder gibt es andere Gründe für diese 10 Sekunden-Rampe?
    Das kenne ich von anderen Herstellern genau umgekehrt.
    Hat Siemens nicht auch einen Vertrieb, der mechanische Komponenten verkaufen will?
    Ralle, Siemens denkt an alle und alles, solange es dem Gewinn hilft, sonst nicht.
    Es wird an den bevorzugten Universitäten wird ein Studiengang "Siemens für Anfänger" und "Siemens für bezahlende Kunden" eingerichtet.
    Mensch mir geht das auch immer wieder auf den Geist.
    Ich bin heilfroh, dass wir Kollegen von BigS im Büro sitzen haben, die uns kompetent und schnell helfen. Sonst wären wir verloren.


    bike
    "Any fool can write code that a computer can understand.
    Good programmers write code that humans can understand."
    --Martin Fowler

Ähnliche Themen

  1. 1FK7 an SINAMICS
    Von Sockenralf im Forum Antriebstechnik
    Antworten: 8
    Letzter Beitrag: 12.05.2011, 20:31
  2. Sinamics S120
    Von arena im Forum Antriebstechnik
    Antworten: 2
    Letzter Beitrag: 15.03.2010, 16:47
  3. Sinamics an S7-1200
    Von Spiff im Forum Antriebstechnik
    Antworten: 12
    Letzter Beitrag: 10.11.2009, 16:56
  4. Sinamics Motorenregelung
    Von Mike1983 im Forum Antriebstechnik
    Antworten: 2
    Letzter Beitrag: 21.05.2007, 07:36
  5. Sinamics
    Von mbredi im Forum Antriebstechnik
    Antworten: 1
    Letzter Beitrag: 31.03.2006, 19:33

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •