Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 7 von 7

Thema: Umbau Problem Danfoss FC3D00 -> FCD302

  1. #1
    Registriert seit
    09.01.2019
    Beiträge
    3
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Guten Tag zusammen,

    ich bin neu hier, kurz zu mir: Ich heiße Daniel, bin 24 Jahre alt und habe Elektroniker für Betriebstechnik gelernt. Seit meinem neuen Job (01.11.201 habe ich öfters mit S7 Programmen zutun. (Im alten Betrieb hatten wir Programmierer). Bei weiteren Fragen könnt ihr sie gerne stellen.

    Nun zu meinem Problem. Ich versuche es mal möglichst genau zu schildern:

    Ich habe die Aufgabe bekommen einen Danfoss FCD300 auf einen FCD302 umzubauen, der nur über Profibus angesteuert wird. Grund dafür ist, da wir anscheinend keine FCD300er mehr bekommen. So habe ich Hardwaretechnisch alles problemlos umgebaut. Danach habe ich die Busadresse eingestellt, Spannungslos gemacht und da fing das erste Problem an, fazit: Die GSD-Datei war veraltet, also habe ich sie aktualisiert (PPO1 wird verwendet) und dann war die Profibusverbindung da. Jetzt kommen wir zu meinem aktuellen Problem:

    Am Bedienpult zeigt das Panel Motorschutz FU gefallen. Hardwaretechnisch ist alles einwandfrei, die Telegramme stimmen überein, Profidrive Profil ist aktiviert aber es funktioniert nicht. In einem Datenbaustein wird die Motorschutz Meldung abgefragt (1= OK, 0= Motorschutz gefallen), durch Rausprogrammieren der Meldung läuft der FU dennoch nicht auf Automatik, Meldung am Danfosspanel "Auto Fern Start block." Auf Hand läuft er problemlos, wenn die Motorschutzmeldung rausprogrammiert wurde. Da wir unzählige FU's haben wurde ein seperater FC erstellt dort wird die Motorschutz Meldung gebildet, welche ich wahrscheinlich auf mangelnder Erfahrung nicht verstehe:
    In etwa so:
    L 2#1011
    UW
    L 2#11
    =I==
    =Motorschutz_OK

    Dort werden quasi zwei Werte verglichen, sobald die Werte übereinstimmen ist der Motorschutz OK?! Welche Werte werden denn hier verglichen? Die Danfosshotline meinte, dass eine Brücke von 12 auf 27 fehlt, gesagt getan, dennoch keine Funktion. Da man die Klemme 27 in den Parametern auf "keine Funktion" setzen kann, habe ich es von vornerein angezweifelt, natürlich war dann ab 16:30 Uhr keiner mehr zu erreichen (ich hatte Mittagschicht, und nebenbei Störungsdienst).

    Ich schreibe von Zuhause aus, da wir auf der Arbeit keinen freien Internetzugang haben.

    Ich hoffe, dass ich alles relativ genau beschreiben konnte und hoffe auf einige gute Tipps bzw. Lösungsansätze.

    Ich wünsche euch einen schönen Tag.

    Liebe Grüße Daniel
    Zitieren Zitieren Umbau Problem Danfoss FC3D00 -> FCD302  

  2. #2
    Registriert seit
    14.01.2015
    Beiträge
    3.548
    Danke
    822
    Erhielt 735 Danke für 564 Beiträge

    Standard

    Kann es evtl. sein, dass du die alte GSD Datei gelöscht hast, die neue dann eingefügt hast mit passender Profibus Adresse aber die E/A Bereiche unten
    in der HW Konfig nicht wieder so eingestellt hast, wie sie bei der alten GSD waren?
    Mit Grüßen

    >> Wer nicht mit der Zeit geht, der geht mit der Zeit <<

  3. #3
    Thimm94 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    09.01.2019
    Beiträge
    3
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Danke für die schnelle Antwort. Doch, die E/A-Adressen habe ich auch so eingestellt wie bei der alten Datei.

  4. #4
    Registriert seit
    14.01.2015
    Beiträge
    3.548
    Danke
    822
    Erhielt 735 Danke für 564 Beiträge

    Standard

    Ja, dann muss dir jemand anderes helfen. Ich habe mit Danfoss FU´s nicht viel zu tun.
    Mit Grüßen

    >> Wer nicht mit der Zeit geht, der geht mit der Zeit <<

  5. #5
    Registriert seit
    19.07.2013
    Beiträge
    61
    Danke
    2
    Erhielt 10 Danke für 9 Beiträge

    Standard

    Bei Danfoss gibt es verschiedene Busprofile (mit verschiedenen, teilweise frei programmierbaren Parametern). In allen Profilen steht aber im jeweils ersten Datenwort das Steuerwort bzw. das Statuswort.

    Byte x Bit-Belegung Datenbyte
    Dx.0 Danfoss FU Steuerwort Festdrehzahl (JOG) 1=JOG
    Dx.1 Danfoss FU Steuerwort Rampe ½ 1=Rampe 2
    Dx.2 Danfoss FU Steuerwort Daten un-/gültig 1=gültig
    Dx.3 Danfoss FU Steuerwort Relais 1 1=ein
    Dx.4 Danfoss FU Steuerwort Relais 2 1=ein
    Dx.5 Danfoss FU Steuerwort Parametersatz 1=Isb
    Dx.6 Danfoss FU Steuerwort Parametersatz 1=msb
    Dx.7 Danfoss FU Steuerwort Reversierung 1=rev.
    Byte x+1 Bit-Belegung Datenbyte
    Dx.0 Danfoss FU Steuerwort Sollwert 1=Isb
    Dx.1 Danfoss FU Steuerwort Sollwert 1=msb
    Dx.2 Danfoss FU Steuerwort DC-Bremse 1=Rampe
    Dx.3 Danfoss FU Steuerwort Motrofreilauf 0=Freilauf
    Dx.4 Danfoss FU Steuerwort Schnellstopp 1=Rampe
    Dx.5 Danfoss FU Steuerwort Ausgangsfrequenz speichern 1=Rampe
    Dx.6 Danfoss FU Steuerwort Start/Stopp 1=Start
    Dx.7 Danfoss FU Steuerwort Reset 1=Reset

    Byte x Bit-Belegung Datenbyte
    Dx.0 Danfoss FU Statusword Drehzahl <> Sollwert 1= Drehzahl = Sollwert
    Dx.1 Danfoss FU Statusword Ortbetrieb 1=Bussteuerung
    Dx.2 Danfoss FU Statusword Außerhalb Frequenzgrenze 1= Frequenzgrenze ok
    Dx.3 Danfoss FU Statusword kein Betrieb 1= Betrieb
    Dx.4 Danfoss FU Statusword FU ok 1=gestoppt, autom. Start
    Dx.5 Danfoss FU Statusword Spannung ok 1= Spannung überschritten
    Dx.6 Danfoss FU Statusword Moment ok 1= Moment überschritten
    Dx.7 Danfoss FU Statusword Timer ok 1=Timer überschritten
    Byte x+1 Bit-Belegung Datenbyte
    Dx.0 Danfoss FU Statusword Regler nicht bereit 1=Regler bereit
    Dx.1 Danfoss FU Statusword FU nicht bereit 1=FU bereit
    Dx.2 Danfoss FU Statusword Motorfreilauf 1=aktivieren
    Dx.3 Danfoss FU Statusword kein Fehler 1=Abschaltung
    Dx.4 Danfoss FU Statusword kein Fehler 1= Fehler (keine Abschaltung)
    Dx.5 Danfoss FU Statusword Reserviert
    Dx.6 Danfoss FU Statusword kein Fehler 1= Abschaltblockierung
    Dx.7 Danfoss FU Statusword keine Warnung 1= Warnung


    Im Statuswort muß zunächst das Bit 'Ortbetrieb' auf 1 sein (Bussteuerung), vorher kannst du von der SPS her nicht steuern (Einstellung am FU).
    Es gibt kein Statusbit für Motorschutz, diese Meldung wird dann vielleicht aus den Fehlerbits kombiniert?
    Geändert von Fireman_Frank (09.01.2019 um 13:01 Uhr)

  6. #6
    Thimm94 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    09.01.2019
    Beiträge
    3
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Also ich habe am FU quasi die Parameter wo vom Werk aus, Bus oder Klemme eingestellt wurde, auf Bus stehen, Führungshoheit ist auch auf Bussteuerung eingestellt. Gibt es da seperat noch einen Parameter für Ortbetrieb? Und danke für die Antwort.

  7. #7
    Registriert seit
    19.09.2011
    Beiträge
    148
    Danke
    0
    Erhielt 20 Danke für 20 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Servus,

    der FCD300 ist ja schon einige Jahre alt aber der Nachfolger ist der FCD302 (Basis FC302 im dezentralen Gehäuse).
    Während der FCD300 parametermäßig wie VLT2800 war.
    Wenn du Umrüstest dann ist neben der Hardware natürlich auch Parameter / Software zu beachten.
    Sofern ein Motorschutz über SPS und nicht direkt am FU gelöst wurde so musst du es herausfinden und kann nicht die Hotline wissen.
    Bei FCD300 war es in Gruppe 1 (Motorgruppe) und Gruppe 3 (E/A) aufgeteilt, beim Nachfolger im Parameter 1-9x hintereinander ob Warnung oder Abschaltung und wo der Anschluss ist.
    Dann natürlich die richtige GSD Datei runterladen, PPO Typ usw....aber du hast ja gesagt dass der Bus läuft.
    "Startblock" usw. kann am ProfiDrive Profil liegen....047F , adnn 047E und dann erst beim nächsten 047F läuft der Antrieb ( wenn zudem ein Sollwert kommt).
    Ortbetrieb geht ja hast du gesagt....und es ist korrekt dass früher die 27 (Freilauf inv.) gebrückt sein musste....heute kannst du die Klemmen deaktivieren und wenn auf keiner Klemme was ist wird es keinen Freilauf geben.
    Wichtig bei Profibus ist Gruppe 8 und 9 sowie Beobachtung (am LCP oder so von der Veriablen Steuerwort und Sollwert bzw. Zustandswort.
    Evtl. im Profibushandbuch mal schaun und Zustandmeldung mit Bits checken was dem Antrieb fehlt.


    Gruß
    DOC
    Geändert von doctorVLT (02.02.2019 um 00:41 Uhr)

Ähnliche Themen

  1. Danfoss VLT 6000 problem
    Von ibric70 im Forum Antriebstechnik
    Antworten: 5
    Letzter Beitrag: 23.12.2017, 01:30
  2. Problem mit Danfoss -DP /Zustandsübergangdiagramm
    Von kiestumpe im Forum Antriebstechnik
    Antworten: 1
    Letzter Beitrag: 14.06.2007, 09:48
  3. Problem 10V mit Danfoss FC302
    Von OschiLePro im Forum Antriebstechnik
    Antworten: 0
    Letzter Beitrag: 12.06.2007, 12:46
  4. Problem mit Profibuskommunikation Danfoss FU
    Von Anonymous im Forum Feldbusse
    Antworten: 7
    Letzter Beitrag: 14.09.2006, 21:59
  5. Problem mit Drive ES und Danfoss Umrichter
    Von Anonymous im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 03.05.2004, 23:57

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •