PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Verbindung INAT OPC zur S7 300 über MPI



lugo
10.06.2007, 16:35
Hallo SPS Gemeinde,

ich möchte mit Daten aus er SPS ziehen und Sie mit Labview visualisieren. Soweit ich das nun heraus gefunden habe benötige ich einen OPC Server. Ich benutze nun den 72 Std. Testserver von Inat.

Mein Problem ist nun, das ich keine Werte aus der SPS ziehen kann. Habe ihn laut Bedienungsanleitung konfiguriert, aber nix passiert. :confused:

Mit dem Testclient und Labview funzt das ganze.

Ohne Testclient sondern nur mit dem Server kommt die Meldung, dass er conected ist, aber ich bekomme in Labview nichts angezeigt!?

Muss ich in der SPS noch was einstellen oder wo liegt der Hund begraben?

Als Alternative, was ist denn bei Ethernet zu beachten? TSAP-Adresse etc.? Vielleicht kann ich meinen Prof. davon ja überzeugen!?:cool:
Leider will er erstmal eine Lösung für MPI!? :(


Hardware ist ne S7 - 300

Schon mal danke im voraus!


Lugo

JandeFun
13.06.2007, 09:29
Hallo Lugo

eine Verbindung über die MPI Schnittstelle mit dem Inat OPC Server habe ich selbst noch nicht direkt gemacht.

Ich hatte den Netlink von der Firma Helmholz benutzt.

Für die Einstellungen mit direktem Zugriff über den CP habe ich dir einige Bilder für die Einstellungen angehangen.

Ansonsten kannst du auch in der Betriebsanleitung des Inat Servers mehr über den TSAP lesen.

Hast du denn die Möglichkeit über eine TCP / IP Verbindung mit deiner CPU zu koppeln?

lugo
13.06.2007, 10:33
Supi, danke!!!!

Hat sich aber soeben erledigt!
habe einen anderen OPC Server genommen und nach kurzer Zeit hat es funktioniert!!!!


MfG

Lugo