PDA

View Full Version : ACCON-NetLink-USB compact



natarajan
30.12.2013, 09:08
Hi,
I am using Accon-Netlink-USB-compact to establish PROFIBUS connection between PC and drive ( not the PLC). I am not able to read and write the device parameter. I used the API's (drive_readmix, drive_writeMix) but still I couldnt read/write to the device.

I have a doubt , is it possible to use Accon-Netlink-USB compact and establish the PROFIBUS connection without PLC ? if it is so, please tell me how to do read and write from/to device..


Thanks alot,

natarajan.

Rainer Hönle
30.12.2013, 09:19
I think you are using ACCON-AGLink. Do you get a connection to the drive? If not, in which function do you get an error? What is the error code?

natarajan
30.12.2013, 09:26
yes i am using Accon-AGLink latest version ,
open connection, dial-up , init adapter (adapter is detecting), exit adapter, hang-up, close device are successful..
AGL_DriveReadMix, AGL_DrivewriteMix functions producing error.
error code is -1048569 ( the error code is Device Not Opened)...
How to make read and write??


Thanks..

Rainer Hönle
30.12.2013, 09:45
You got AGL40_SUCCESS from AGL_InitAdapter? To read parameters from the drive, you must use AGL40_PLCConnect with the busaddress of the drive to get a connection to the drive. Which result do you get from this function?

natarajan
30.12.2013, 10:03
Yes, I got AGL40_SUCCESS from AGL_InitAdapter.. The API AGL40_PLCconnect is not successful error code is ( -720868 ) which means PLC not found..

I have entered the bus parameters properly still i am getting error in PLCConnect.. Please reply..


Thanks.

Rainer Hönle
30.12.2013, 10:47
Which busaddress has the drive? Which parameters do you use for AGL_PLCConnect?

natarajan
30.12.2013, 10:49
I used PlcNr paramter in PLCconnect function,..

The drive is in address - 2..

still it is not connecting...

Rainer Hönle
30.12.2013, 11:15
Please post you code. 2 is normal the address of the plc and not the address of the drive! You must use the profibusaddress of the drive for AGL_PLCConnect.

natarajan
30.12.2013, 11:25
code :

int doPLCconnect(int timeout, long userval)
{
int connnr = 1;
int devnr = 0;
int plcnr = 2;
int result = AGL_PLCConnect(devnr, plcnr, &connnr, timeout, userval);


if (result == AGL40_SUCCESS)
{
std::cout<<"plc connect is successfull"<<std::endl;
return 0;
}
std::cout<<"error in PLC connect"<<std::endl;
return result;
}

this is the function I used for PLC connect..

Rainer Hönle
30.12.2013, 11:29
And one last time: which profibusaddress has the drive? What happens, if you use this address? see #4 ...

natarajan
30.12.2013, 11:32
Now I changed my profibus address to 3..
Result --- The drive is not detecting...

why my drive is not detecting ??? what should i do ?

Rainer Hönle
30.12.2013, 11:49
Call AGL_GetLifeList after AGL_InitAdapter. Which addresses are online? You can connect only to devices which are in the lifelist.

natarajan
30.12.2013, 12:11
I used the above API Getlifelist.. The function result is success but none of the address are in online.,..
Screenshot :22753




Waiting for ur valuable reply: Confused:

Thanks..

Rainer Hönle
30.12.2013, 12:40
The result of AGL_LifeList is AGL40_SUCCESS. What is in the lifelist-array, the array with the active and passive stations?
I think it is best, if you use the api-guide for testing and displaying the results.
If realy nobody ist online, you must fix your bus problems first.

natarajan
30.12.2013, 12:46
ok.. I us22754ed API guide as you suggested please take a look at the screenshot and tell me the problem ... please..

Rainer Hönle
30.12.2013, 12:54
There is no device online. You must fix your bus problems first.
Power on your PLC and try it again (perhaps a termination problem).

natarajan
30.12.2013, 13:47
Hi, I have entered the bus parameters properly and there is no termination problem..

Same problem I couldnt see any devices online.... confused... Tell me any other troubleshooting method..
Thanks..

Rainer Hönle
30.12.2013, 14:06
If you terminate at the plc connector and the plc is switched off, there is no propper termination. So you have a termination problem. And because of that: power on your PLC and try it again.

natarajan
30.12.2013, 14:29
If i put the termination at the connector to OFF and PLC ON the code i am getting when using PLCConnect function:- is
An error happend at the following" PLCConnect :Connection end received"..

If i put the termination at the connector to ON and PLC ON the code i am getting when using PLCConnect function:- is
An error happend at the following: PLCConnect :PLC not found

I tested using APi guide..


what does it means??

Thanks...

Rainer Hönle
30.12.2013, 15:00
power the PLC and the termination on. What shows lifelist in the API Guide?

natarajan
31.12.2013, 05:58
I did as u said : When Using PLCConnect function: - is An error happend at the Following: PLCConnect: PLC not found same error

None of the stations are in online in lifelist. what to do?

LowLevelMahn
31.12.2013, 06:09
Ideas:

1. What Tools do you use for driver configuration (what is the driver type)? Is the driver reachable through these tools?
2. more bold doesn't help here

natarajan
31.12.2013, 06:35
Through MCT10 tool the driver is reachable and I could access it using some mft PRofibus adapter.. I use MCT10 to configure the driver..
I couldnt access the driver using ACCON-NetLink-USB Compact (which is also a Profibus adapter)..

LowLevelMahn
31.12.2013, 06:43
I don't know MCT10 - is the driver a siemens kompatible SINAMICS or Micromaster?
i think that are the ones AGLink supports - what make you think AGLink can work with your driver - is there a compatiblity list or something?

natarajan
31.12.2013, 06:50
Yes the driver is SIEMENS compatible .. Bit more, The driver can be accessed using Siemens CP5711, 5611, 5613 profibus adapters..

I am trying to access the same driver using Accon Netlink USB compact adapter , it is not working this is my problem precisely.

LowLevelMahn
31.12.2013, 07:01
The driver can be accessed using Siemens CP5711, 5611, 5613 profibus adapters

so your AGLink program works if you using the CPs, right?

natarajan
31.12.2013, 07:23
No the driver is not accessible through AGlink program when using CPs...

22763

22764

LowLevelMahn
31.12.2013, 07:26
nice unreadable micro screenshots :)

and can you connect to the driver with your MTC10 program when using USB Compact? (i think you need to switch something in the Siemens CP config)

natarajan
31.12.2013, 07:31
sorry for that screenshot 22765 22766

natarajan
31.12.2013, 07:32
No I cannot connect it through MCT10 also with USB compact .. everything is fine with Cp configuration..

LowLevelMahn
31.12.2013, 07:40
your current state is this:

MTC10 + CPxyz works
MTC10 + USB Compact isn't working (you can't connect? or what)
Step7/TIA whatever + CPxyz works
Step7/TIA whatever + USB Compact works
API-Guide + CPxyz does not work
API-Guide + USB Compact does not work

natarajan
31.12.2013, 07:43
ya Mct10 + CP works well and detect the driver...
but

AGlink + USB compact doesnt work and
AGlink + CP doesnt works and couldnt detect driver.

yes this is my state.. how to detect the driver ?

LowLevelMahn
31.12.2013, 07:50
im getting out of questions...

-could be still a problem with the profibus (yes i know your CPs working...) but lifelist should(must) work - that isn't even specific to the drive, should list all profibus players in bus

-what version is your USB Compact firmware? latest version running?

-and your plc is connect able through USB Compact?
Step7/TIA whatever + CPxyz works
Step7/TIA whatever + USB Compact works

natarajan
31.12.2013, 08:09
USB compact Firmware version is : 6.0.0.1 (latest version)..
yes step 7 + Cp works
step7 + USB compact is working..

any plc can be detected by accon netlink usb compact , if it uses the simatic s7-200..

So my driver is also detectable by USB compact is it right??

Rainer Hönle
31.12.2013, 08:51
The drive-functions are only implemented for Sinamics and Micromaster. I think MCT10 is from danfoss and is not supported by the ACCON-AGLink drive function.
But you should see your drive and the other devices in the lifelist. Use your Siemens CP in auto mode, go to diagnosis andcheck your busparameters and the lifelist. Post the screenshots. Post the screenshot of you ACCON-NetLink USB compact configuration.

natarajan
31.12.2013, 09:38
Yes MCT10 doesnot support AGlink drive function
22769 22770 22771 22772

I hope these screenshot are clear and explain u the problems ...:confused:

natarajan
31.12.2013, 09:40
I missed one screenshot AGlink + siemens adapter
22773

Rainer Hönle
31.12.2013, 10:17
Change the HSA from 15 to 126. What do you get now? First of all, we need the device in the lifelist.
Btw: you can't connect the MCT10 with ACCON-AGLink, neither with CP5711 nor ACCON-NetLink-USB compact, but the MCT10-Software should run with ACCON-NetLink-USB compact.

natarajan
31.12.2013, 10:50
I didnt get any devices in lifelist..

Rainer Hönle
31.12.2013, 10:56
How do you switch from Siemens-CP to ACCON-NetLink-USB compact? Do you have both connected to the bus at the same time? Or do you unplug one and connect the other?
Which devices are connected to the bus, which plc etc.?

natarajan
31.12.2013, 11:01
No both are not connected at sametime.

I unplug one and connect another to my PC..

It is not PLC , its a drive ....

Rainer Hönle
31.12.2013, 12:04
The PC connection is not the problem, I want to know the profibus connection.
Do you have only the drive and nothing else connected to profibus?

natarajan
31.12.2013, 12:06
Yes only the drive is connected to Profibus ...

natarajan
02.01.2014, 10:19
Hi, I tried all the ways which you mentioned still I am unable to access my drive.. Please help me on connection to drive..

ChristophD
02.01.2014, 11:02
Hi,

first Screen in Post #36.
On the SIEMENS CP the Option "is the only master on bus" is set, and the Screen in Post #37 show in the LifeListCommand 2 Entries.
This 2 Entries i think are 1 and 2 like the CP5711 dialog in post #36.

Check if there a option "master on the bus" is availabe for the AGLink, the MCT10 is a passive Slave and needs a PROFIBUS Master for communication.
The SIEMENS CP support this Master option but the AGLINK?

Regards
Christoph

natarajan
02.01.2014, 11:10
In AGLink there is no option available under S7-Netlink USB to set my PC as master..
I also had a doubt that how to set my PC as master when communicating Accon-Netlink USB compact via AGLink?? I think my drive search for Master ...
but in AGlink there is no option available to make my PC as master..
could you please check it ?

Rainer Hönle
02.01.2014, 11:14
Only for testing: do you have any other master (for example a PLC), which you can connect to the bus?

Rainer Hönle
02.01.2014, 11:15
It is not an problem with ACCON-AGLink, it is a problem with profibus an ACCON-NetLink-USB compact. So we can use ACCON-AGLink only for testing and verification.

natarajan
02.01.2014, 11:19
No i dont have PLC.. is there any other way to do ?

ChristophD
02.01.2014, 11:22
in post #34
"any plc can be detected by accon netlink usb compact , if it uses the simatic s7-200.."

So I think the Adapter "ACCON-NetLink-USB compact" works correct if a active device is connected.

Hmm no PLC? But you have a SIEMENS CP on your side? Can your make a test with a connection between SIEMENS CP and NetLink?

natarajan
02.01.2014, 11:28
I dont get your point on "can you make a test with a connection in between Siemens CP and NetLink" ..??

ChristophD
02.01.2014, 11:32
connect both, the SIEMENS CP and the Netlink , to the drive.
with a little luck the SIEMENS CP take the Master Role on the PROFIBUS and the NetLink find the devices.
That's the only idea i have on this time

natarajan
02.01.2014, 11:50
My drive doesnt have facility to connect both profibus adapter ...

ChristophD
02.01.2014, 12:02
WTF? Which drive do you use? MCT10 ist the Software for the drive but not the drive type!
Why you can't connect it, one Connector from SIEMENS CP to NetLink, an the on Connector from Netlink to the Drive. Where is the problem?

natarajan
02.01.2014, 12:35
I am using Danfoss FC102 drive ... MCT10 is the software for the drive and I know using this MCT10 we cant access through Accon Netlink USB compact....


MY question is :- why I am unable to detect the FC102 drive using Accon Netlink USB compact ???

ChristophD
02.01.2014, 12:43
because the Accon NetLink USB Compact support the following PLC's: S7-200, S7-300, S7-400
Other devices can be work but is not a "Must" ;)

natarajan
02.01.2014, 12:45
so does it mean, it wont work with Danfoss FC102 drive????

ChristophD
02.01.2014, 12:56
yes i think so.
in the mct10 manuall you find the followed :
The following Master class 2 cards are currently supported from Siemens:
• CP 5411
• CP 5511
• CP 5512
• CP 5611
• CP 5613
• CP 5614
• CP 5711

In the Manual of the NetLink i can't find any word to the supported Master Classes.

natarajan
02.01.2014, 13:02
ok I will try to connect Danfoss FC102 using one of the ( #58 ) adapter mentioned with Accon AGLink and check whether it is working or not !! ... I ll give a try ....

LowLevelMahn
02.01.2014, 13:35
because the Accon NetLink USB Compact support the following PLC's: S7-200, S7-300, S7-400

1. Accon NetLink Supports mostly all Devices that are Supported by Siemens CPs - because its just an USB<->Profibus Converter
2. AGLink supports ON TOP of Profibus the device specific protocolls of LOGO,S7-200,300,400,1200,1500 AND some SIEMENS driver protocols
3. natarajan (http://www.sps-forum.de/members/72458.html) can't find the Profibus-Device using the USB Compact <- PROBLEM1
4. natarajan (http://www.sps-forum.de/members/72458.html) isn't even able to connect to his plc using the USB Compact (what is meant as a test - because this is the main usage situation) <- PROBLEM2

as i understand it correct the danfoss driver isn't speaking a siemens kompatible protocol - so it will not work (i don't know where natarajan (http://www.sps-forum.de/members/72458.html) got the information that it should/could)
but the main problem is that his USB Compact isn't able to see anything on profibus

ChristophD
02.01.2014, 13:47
@LowLevelMahn
4.) nastarjan have no PLC only the Danfoss FC102 Drive !
In Post #34 he tell that's the Adapter work with PLC S7-200 correctly, but at this time he have no PLC!
The Danfoss work with DPV1 Parameter Sequences to communicate with the MCT10 Software Suite.
To establish a DPV1 connection to a passive PROFIBUS Slave you need a PROFIBUS Master Class 2 , this mode is
available on the SIEMENS CP's when you set the Option "Is the Only Master in the bus".
So this doesn't look like a protocol problem but a Operating Mode Problem of the NetLink USB Compact!

LowLevelMahn
02.01.2014, 14:00
nastarjan have no PLC only the Danfoss FC102 Drive !

his hardware scenario seems to be a bit floaty


To establish a DPV1 connection to a passive PROFIBUS Slave you need a PROFIBUS Master Class 2 , this mode is
available on the SIEMENS CP's when you set the Option "Is the Only Master in the bus".


could that explain why he can't find the driver on the lifelist?


So this doesn't look like a protocol problem but a Operating Mode Problem of the NetLink USB Compact!

it will not work with AGLink if the danfoss driver isn't speeking the siemens driver protocol, but he could use the USB Compact for driver configuration through MCT10 then

ChristophD
02.01.2014, 14:15
No with the USB Compact he can't configure the danfoss trough MCT10 because the Software needs the Checkbox "is the only master on the bus" (MCT10 manual).

Rainer Hönle
02.01.2014, 15:15
If the the ACCON-NetLink-USB compact can't go online, the AGL_InitAdapter returns an error. If the check box "Automatic.." isn't check, the adapter will go online even if no other master is present. So I don't know, where the problem ist. I think it is best, to use an additional master (Siemens CP) for testing (thanks to ChristophD). Hope that helps.Btw: ACCON-NetLink-USB (compact) and ACCON-NetLink-PRO (compact) can be used with the MCT-Software.

natarajan
03.01.2014, 02:35
Thanks to ChristophD and Rainer .. I will try the method Christophd said.

natarajan
08.01.2014, 13:53
Hi , sorry for the delay...PLC is detecting with Accon Netlink USB compact..
Danfoss FC102 board is also detecting but I dont know how to read and write parameter from the Danfoss board..

AGL_DRIVE_write and AGL_Drive_read is not working...

Rainer Hönle
09.01.2014, 07:21
As I wrote above, the ACCON-AGLink drive functions are only for Micromaster and Sinamics. You must use your Danfoss software to change the parameters.
Btw: what was the problem of not seeing the drive in the lifelist? What did you change?

natarajan
09.01.2014, 08:27
I dont know how it is showing drive in lifelist (surprise).. Danfoss software (MCT10) wont work with Accon Netlink USB compact ..
So, is that I should connect PLC and Danfoss Drive via Accon Netlink USB compact and do read &write???

Rainer Hönle
09.01.2014, 09:15
One last time: you must see your drive in the lifelist (test it with API-Guide or AGLink40_Config), then your Danfoss software can access your drive via ACCON-NetLink-USB compact. If you don't see it in the lifelist, nobody can access the drive via ACCON-NetLink-USB compact.
What do you mean with #66? What have you tested the last days? What are you doing? What ist your equipement? Sorry, but I don't have a crystal ball to guess what ist going on. And your informations are very rare.

natarajan
21.01.2014, 10:52
Hi one last time : could you please tell me why with AGL_Drive_write and AGL_Drive_read I couldnt read/write parameter from danfoss drive.
Even though the drive is showing in lifelist...


Thanks...

LowLevelMahn
21.01.2014, 10:57
profibus is just the communication way (thats why you see your driver on the lifelist) - and AGLink supports Profibus-Lifelists ... BUT: profibus is not an device communication protocoll, so there is normaly a protocoll on top of profibus - and these on-top-of-profibus-protokoll varys from manufacturere/devices - sometimes described in documents or sometimes closed, AGLink supports the special protocols of Siemens Drivers - which are totaly different to your Danfoss-Protokolls - thats the reason, but that was said more then 10 times before

LowLevelMahn
21.01.2014, 11:08
maybe that could help: Danfoss "seems" to use this protocoll for driver communication

http://www.danfoss.com/BusinessAreas/Solar+Energy/Downloads/ComLynx+Protocol.htm

PDF describing the profibus-protocoll
http://www.danfoss.com/NR/rdonlyres/18FA1022-2FF1-484A-8460-B6A51BE202BF/0/ComLynx_User_Guide_16_20120817_A7.pdf

did you ever ask Danfoss for help - maybe there is a simple communication solution available

natarajan
21.01.2014, 11:42
Hi in Danfoss they support profibus communication only through Siemens adapter..

I am trying to use Accon Netlink USB compact without siemens drivers to establish profibus communication. I dont know is it possible or not.: Confused:

LowLevelMahn
21.01.2014, 12:23
your stlye of mixing statements, questions etc. is very frustrating

1. Accon Netlink USB compact is a Siemens CP replacement device - AND it works with MCT10 (many times proofed)
start with the very first Post an re-read them all - i don't know how you get the driver currently in the liflist...

2. Accon AGLink is a Software-Library that speak SOME Device Protocols over Profibus - but NOT the Protocol of your FC120 - so
AGL_Drive_write and AGL_Drive_read will never work (only if the AGLink Developers implement the Danfoss-Protokoll)

re-read the manuals many times more - and stop asking questions in a totaly uncontrolled way

LowLevelMahn
21.01.2014, 12:36
and to make it more clear

the MTC10 software JUST USES the Accon Netlink USB compact to gain access to the profibus - BUT ONLY the MTC10 software itself implements the correct
Danfoss Protokoll for the FC120 and other devices - and the AGLink-Software DOES NOT HAVE this Danfoss Protokoll implementation

LowLevelMahn
21.01.2014, 13:05
so AGLink will not help in your case - what next?

1. you can implement the Danfoss "ComLynx" Protkoll yourself - see previous Post with Specification
2. ask Danfoss if there is something else you can do