Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Results 1 to 9 of 9

Thread: Kein upgrade von Tc 3.1.4022.20 auf 3.1.4024.10 funktioniert nicht

  1. #1
    Join Date
    01.02.2018
    Posts
    118
    Danke
    6
    Erhielt 5 Danke für 5 Beiträge

    Default


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen,

    ich wollte heute auf einem CX-5130 PC das Upgrade von der TC 3.1.4022.20 auf 3.1.4024.10 durchführen. Bei der Deinstallation der alten Runtime bekomme ich folgende Fehlermeldung:




    Auch die Installation der neuen Runtime scheitert.

    Hat einer von Euch eine Idee wie ich die alte Version deinstallieren kann?

    Danke für Eure Hilfe.

    gruss
    martin
    Reply With Quote Reply With Quote Answered: Kein upgrade von Tc 3.1.4022.20 auf 3.1.4024.10 funktioniert nicht  

  2. "Nachdem ich über TcSwitchRuntime die aktive Runtime deaktiviert hatte, konnte ich die alte deinstallieren und anschließend die neue installieren. Warum das nur sorüber funktioniert weiss ich nicht. Aber es hat funktioniert.

    Aber danke schonmal für Eure Hilfe.
    gruss
    martin"


  3. #2
    Join Date
    13.12.2011
    Location
    Bückeburg
    Posts
    3,476
    Danke
    475
    Erhielt 556 Danke für 462 Beiträge

    Default

    Hallo Martin,
    mit der TC 3.1.4022.20 und dem Versuch diese zu deinstallieren hast Du voll in die braune Masse gegriffen. Zu dem Thema hatte ich hier damals auch eine Warnung ausgesprochen, dass man diese nicht deinstallieren darf, außer automatisiert über eine neuere Version, weil danach beim Windows Installer nichts mehr geht. Übrigens muss man eine alte Runtime nicht selber deinstallieren ehe man eine neue installiert, dass macht der Installer der neueren Version schon für einen.
    Entweder musst Du auf dem CX ein Image einspielen oder die Hotline kontaktieren und fragen, wie Du aus der Nummer wieder rauskommst.
    Last edited by oliver.tonn; 23.02.2021 at 13:05.
    Von irgendwas mit Internetzugang gesendet.

  4. Folgender Benutzer sagt Danke zu oliver.tonn für den nützlichen Beitrag:

    DaPivo (23.02.2021)

  5. #3
    msauerpb is offline Erfahrener Benutzer
    Themenstarter
    Join Date
    01.02.2018
    Posts
    118
    Danke
    6
    Erhielt 5 Danke für 5 Beiträge

    Default

    Hallo Oliver,
    danke für den Hinweis. Habe gerade gesehen, dass ich mich bei den Versionen Vertan hatte. Ich hatte die 3.1.4022.22 und wollte das Upgrade auf die 3.1.4024.10 machen.
    gruss
    martin

  6. #4
    Join Date
    13.12.2011
    Location
    Bückeburg
    Posts
    3,476
    Danke
    475
    Erhielt 556 Danke für 462 Beiträge

    Default

    Das sollte allerdings problemlos funktionieren, aber wie gesagt ein vorheriges Deinstallieren ist nicht notwendig.
    Von irgendwas mit Internetzugang gesendet.

  7. #5
    msauerpb is offline Erfahrener Benutzer
    Themenstarter
    Join Date
    01.02.2018
    Posts
    118
    Danke
    6
    Erhielt 5 Danke für 5 Beiträge

    Default

    Bei der direkten Installation kommt die selbe Meldung.

  8. #6
    Join Date
    13.12.2011
    Location
    Bückeburg
    Posts
    3,476
    Danke
    475
    Erhielt 556 Danke für 462 Beiträge

    Default

    Könntest Du die Meldung noch nachreichen.
    Mit der Übertragung des Bildes hat bei Deinem ersten Beitrag was nicht geklappt.
    Von irgendwas mit Internetzugang gesendet.

  9. #7
    msauerpb is offline Erfahrener Benutzer
    Themenstarter
    Join Date
    01.02.2018
    Posts
    118
    Danke
    6
    Erhielt 5 Danke für 5 Beiträge

    Default

    Ja hier:

    You cannot update to TwinCAT Runtime 3.1.4022.22 without updating TwinCAT Engineering (currently installed 3.1.4022.22). Please refer to XAE Setup package.

    Dabei ist eigentlich verwunderlich, dass auf dem CX immer nur ein XAR Runtime installiert war.

  10. #8
    Join Date
    13.12.2011
    Location
    Bückeburg
    Posts
    3,476
    Danke
    475
    Erhielt 556 Danke für 462 Beiträge

    Default

    Das sieht aber anders aus. Kannst Du mal einen Screenshot von der Systemsteuerung-->Programme & Features machen
    Vielleicht wurde der XAE Installer genommen, aber dann nur die Runtime installiert. Hast Du es schon mit dem XAE Installer probiert und da dann nur die Runtime ausgewählt?
    Last edited by oliver.tonn; 23.02.2021 at 15:19.
    Von irgendwas mit Internetzugang gesendet.

  11. #9
    msauerpb is offline Erfahrener Benutzer
    Themenstarter
    Join Date
    01.02.2018
    Posts
    118
    Danke
    6
    Erhielt 5 Danke für 5 Beiträge

    Default


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Nachdem ich über TcSwitchRuntime die aktive Runtime deaktiviert hatte, konnte ich die alte deinstallieren und anschließend die neue installieren. Warum das nur sorüber funktioniert weiss ich nicht. Aber es hat funktioniert.

    Aber danke schonmal für Eure Hilfe.
    gruss
    martin

Similar Threads

  1. Probleme beim Umstieg TC 3.1.4022.22 auf 3.1.4024.10
    By msauerpb in forum CODESYS und IEC61131
    Replies: 7
    Last Post: 09.10.2020, 08:44
  2. TIA Upgrade von V11 auf V14
    By the bimo in forum Simatic
    Replies: 11
    Last Post: 30.10.2018, 13:22
  3. Replies: 7
    Last Post: 20.09.2017, 14:39
  4. TIA Liznez Upgrade von 11 Combo auf 12
    By IPC Bernhard in forum Simatic
    Replies: 4
    Last Post: 19.04.2013, 12:06
  5. Replies: 2
    Last Post: 17.04.2012, 15:55

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •