Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 8 von 8

Thema: Beckhoff CX, Probleme mit serieller Schnittstelle

  1. #1
    Registriert seit
    29.02.2008
    Beiträge
    4
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen,
    ich habe eine Beckhoff Cx1001-0111 mit einer Cx1000-N000 daneben für TCP/IP und Com1.
    An der Com-Schnittstelle hängt eine waage die einwandfrei sendet(im hyperterminal getestet).
    Jetzt habe ich das Beispielprogramm für serielle Kommunikation aus dem InfoSys von Beckhoff geladen und mir im SystemManager ein Projekt angelegt. Es ist alles lauffähig nur kann ich nicht auf die Daten der Schnittstelle zugreifen, bzw. wenn ich im SystemManager beim ComPort auf Data oder Status gehe stehen da im Online Mode immer die gleichen Werte die sich eigentlich verändern müssten, da die Waage belastet wird.
    Die Einstellungen des ComPorts habe ich dem Handbuch der Waage entnommen, also Baudrate etc. Das müsste alles passen.
    Wer kann mir weiterhelfen?
    Thomas
    Zitieren Zitieren Beckhoff CX, Probleme mit serieller Schnittstelle  

  2. #2
    Registriert seit
    11.06.2007
    Beiträge
    162
    Danke
    3
    Erhielt 16 Danke für 16 Beiträge

    Standard

    Zitat Zitat von thensel Beitrag anzeigen
    Es ist alles lauffähig nur kann ich nicht auf die Daten der Schnittstelle zugreifen, bzw. wenn ich im SystemManager beim ComPort auf Data oder Status gehe stehen da im Online Mode immer die gleichen Werte die sich eigentlich verändern müssten, da die Waage belastet wird.
    Hast Du im Systemmanager die Variablen aus dem SPS Programm mit der Hardware verknüpft?

    Gruss
    Thomas

  3. #3
    thensel ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    29.02.2008
    Beiträge
    4
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hi Thomas,

    ja, jetzt zeigt mir das Array auch Daten an die sich auch ändern.
    An was kann es denn liegen, dass im Systemmanager einige Ascii Zeichen nicht aufgelöst werden können(wenn ich beim SPS Programm im SystemManager auf Zeige Zeichen klicke). Und, heißt das ich muss im PLC Programm die Hex_Zeichen im Array selbst auswerten?
    Gibt es da keinen einfachen Weg mir einfach die Messwerte im PLC Programm anzuzeigen?
    THomas

  4. #4
    Registriert seit
    14.08.2004
    Beiträge
    824
    Danke
    45
    Erhielt 73 Danke für 66 Beiträge

    Standard

    Du musst in jedem Fall ein Programm laufen lassen, dass den com-port bedient, sonst funktioniert das nicht.

  5. #5
    Registriert seit
    11.06.2007
    Beiträge
    162
    Danke
    3
    Erhielt 16 Danke für 16 Beiträge

    Standard

    Zitat Zitat von thensel Beitrag anzeigen
    An was kann es denn liegen, dass im Systemmanager einige Ascii Zeichen nicht aufgelöst werden können(wenn ich beim SPS Programm im SystemManager auf Zeige Zeichen klicke).
    Bei Ascii gibt es Hexwerte, welche kein sichtbares Zeichen haben. z.B. 0x01.

    Siehe: http://www.asciitable.com/

    Nur für die Hexwerte 0x20 bis 0x7E gibt es ein Zeichen.

    Zitat Zitat von thensel Beitrag anzeigen
    Und, heißt das ich muss im PLC Programm die Hex_Zeichen im Array selbst auswerten?
    Gibt es da keinen einfachen Weg mir einfach die Messwerte im PLC Programm anzuzeigen?
    Ja die Auswertung musst du selbst machen. Vielleicht gibt es eine Funktion zum umwandeln eines Hexwertes in ein Ascii Wert. Da müsste ich auch zuerst suchen.

    Gruss

    Thomas

  6. #6
    thensel ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    29.02.2008
    Beiträge
    4
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hi Thomas,
    dank der Hinweise funktioniert das Auslesen jetzt.
    Werd mich ans Schreiben von Werten machen, da die Waage vor meiner Anwendung jedesmal einen Nullabgleich braucht. Mit den HEX-Werten sollte das gehen.
    Also danke nochmal und bis zur nächsten Frage...
    Thomas

  7. #7
    Registriert seit
    08.12.2006
    Beiträge
    17
    Danke
    3
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Hallo,

    darf ich fragen, wo genau hast Du das Beispielprogramm runtergeladen?
    Ich bin dabei AT kommandos zu einem Moden zu schicken.

    Danke im Voraus!

    MfG

  8. #8
    thensel ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    29.02.2008
    Beiträge
    4
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hi,
    das Beispiel gibts beim Beckhoff Infomation System http://infosys.beckhoff.com/ oder du lädst dir das runter.
    Dann unter //twincat PLC/twincatplc spsbibliotheke /spsbibliotheken für PC/serielle kommunikation

    Thomas

Ähnliche Themen

  1. Probleme mit FDL Schnittstelle und WinProc.
    Von Jochen Kühner im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 14.07.2011, 12:33
  2. Prg.-Schnittstelle Wago/Beckhoff
    Von Onkel Dagobert im Forum CODESYS und IEC61131
    Antworten: 2
    Letzter Beitrag: 05.02.2010, 07:21
  3. Probleme mit OPC-Schnittstelle
    Von Blanker Draht im Forum HMI
    Antworten: 3
    Letzter Beitrag: 26.11.2009, 19:44
  4. Antworten: 6
    Letzter Beitrag: 05.07.2007, 21:59
  5. Antworten: 4
    Letzter Beitrag: 02.03.2007, 18:20

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •