Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 4 123 ... LetzteLetzte
Ergebnis 1 bis 10 von 31

Thema: Emailversand

  1. #1
    Registriert seit
    28.09.2008
    Beiträge
    53
    Danke
    9
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo liebe Forumgemeinde

    Hat jemand von euch schonmal Erfahrungen sammeln können wie das mit dem Email versenden bei einer XC201 von Klöckner und Möller geht. Ich möchte über eine EmailAddy die über POP und SMTP Servern verfügt eine Email senden lassen von der SPS. Also mit dem ganzen einloggen / Passwort und so.

    Leider hab ich keinen Anfang wo ich eventuell drauf aufbauen könnte. Vielleicht kann mir jemand von euch helfen.

    Vielen Dank im vorraus für eure Hilfe.

    MFG Dennis
    Zitieren Zitieren Emailversand  

  2. #2
    Registriert seit
    29.07.2006
    Beiträge
    78
    Danke
    17
    Erhielt 5 Danke für 4 Beiträge

    Standard

    Hi,
    das könnte Dir glaube ich weiter helfen


    ftp://ftp.moeller.net/AUTOMATION/DOW...CONTROL/EMAIL/

  3. #3
    Registriert seit
    28.09.2008
    Beiträge
    53
    Danke
    9
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hi Enter

    Damit habe ich es schon versucht nur leider funktioniert dies nicht. Darum hatte ich ja einen Beitrag eingetragen. Aber trotzdem danke für deine Hilfe.

    MFG Dennis

  4. #4
    Registriert seit
    11.07.2004
    Beiträge
    1.597
    Danke
    10
    Erhielt 213 Danke für 183 Beiträge

    Standard

    Also bei mir funktioniert das, allerdings nicht auf Moeller Hardware

    Im Zweifelsfall mal Dein Projekt hier posten.

  5. #5
    Registriert seit
    28.09.2008
    Beiträge
    53
    Danke
    9
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hier mal mein Testprogramm. Aber wie ich schon sagte es funktioniert nicht. Ich habe zwar keine Fehlermeldung des Bausteins, daher denke ich er schickt ne Email ab aber es kommt keine an. Vielleicht kannst mir da helfen.

    MFG Dennis



    PROGRAM PLC_PRG
    VAR
    send_mail: SMTP_SendMail;
    start: BOOL;
    absender: STRING(80) := 'Master_SPS';
    empfaenger: STRING := 'test@online.de'; (*von uns eingerichtete test email adresse*)
    smtp_server: STRING := '192.168.0.1'; (* adrersse des verwendeten routers*)
    passwort: STRING := 'test'; (* eingestelltes passwort des email accounts*)
    username: STRING := 'test@online.de'; (* benutzername unserer email adresse*)
    betreff: STRING := 'fehlermeldung';
    inhalt: STRING := 'hallo hier kommt eine TestEmail';
    END_VAR


    send_mail(
    xStrobe:=start ,
    sFrom:=absender ,
    sTo:=empfaenger ,
    sSMTPAddress:=smtp_server ,
    xUseSMTPPassword:=TRUE ,
    sSMTPUserName:=username ,
    sSMTPPassword:=passwort ,
    dtTimeStamp:= ,
    sSubject:=betreff ,
    sMessage:=inhalt ,
    sAttachment:= ,
    xBusy=> ,
    byError=>);

  6. #6
    Registriert seit
    06.07.2007
    Beiträge
    2.811
    Danke
    174
    Erhielt 274 Danke für 253 Beiträge

    Ausrufezeichen

    Nächstes Mal doch bitte mit Code-Tags!! Die findet ihr beim Anworten über dem Text-Fenster. Das #-Zeichen!!
    A programmer is just a tool which converts caffeine into code.
    Zitieren Zitieren Verwendet doch die Code-Tags, machts um einiges übersichtlicher!!  

  7. #7
    Registriert seit
    11.07.2004
    Beiträge
    1.597
    Danke
    10
    Erhielt 213 Danke für 183 Beiträge

    Standard

    Code:
    absender: STRING(80) := 'Master_SPS';
    sollte was in der Art sein:
    Code:
    absender: STRING(80) := 'MeineAbsenderEmailAdresse@wasauchimmer.de';
    aber natürlich eine tatsächlich existierende und auch übereinstimmend mit der Adresse die unten beim SMTP-Versand angegeben wird!


    Code:
    empfaenger: STRING := 'test@online.de';  (*von uns eingerichtete test email adresse*)
    sollte diese Adresse nicht zum verschicken der Mails sein oder soll das wirklich der Empfänger sein?


    Code:
    smtp_server: STRING := '192.168.0.1';                (* adrersse des verwendeten routers*)
    betreibt Ihr im lokalen Netzwerk einen SMTP_Server? Wohl eher nicht, ansonsten gehört da die entsprechende IP des E-Mail-Anbieters rein.

  8. #8
    Registriert seit
    28.09.2008
    Beiträge
    53
    Danke
    9
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hi Oberchefe

    Also wir betreiben keine SMTP-Server auf unserem Computer. Würden das zwar gerne machen, haben aber keine Vorstellung mit welchem Prog dies möglich ist. Also haben wir erstmal eine test email angelegt die wir nutzen möchten. Du schreibst wir müssen die IP von dem SMTP-Server wissen. Wo genau bekomm ich die her. Die Email wurde über den Webmailer von 1und1 eingerichtet. Kann ich dort irgendwie die IP nachlesen?

    MFG Dennis

  9. #9
    Registriert seit
    11.07.2004
    Beiträge
    1.597
    Danke
    10
    Erhielt 213 Danke für 183 Beiträge

    Standard

    Bei 1&1 im Administrationsbereich nachschauen. Dort sollten die POP3 und SMTP-Daten stehen. Könnte beispielsweise smtp.online.de für den E-Mail-Versand lauten. In diesem Fall einen Ping auf online.de abschicken, ergibt 212.227.0.72 als IP-Adresse für den SMTP-Server.

    Um dem Admin hier eine Mail über diesen E-Mail-Acount zu schicken würde das dann beispielsweise so aussehen:
    Code:
    PROGRAM PLC_PRG
    VAR
        send_mail: SMTP_SendMail;
        start: BOOL;
        absender: STRING(80) := 'test@online.de';
        empfaenger: STRING := 'markus.uhl@uhltronix.com';  
        smtp_server: STRING := '212.227.0.72';                (* Adresse des verwendeten SMTP-Servers*)
        passwort: STRING := 'test';                             (* eingestelltes Passwort des E-Mail accounts*)
        username: STRING := 'test@online.de';      (* Benutzername unserer E-Mail Adresse *)
        betreff: STRING := 'Fehlermeldung';
        inhalt: STRING := 'Hallo hier kommt eine Test-E-Mail';
    END_VAR

  10. #10
    Registriert seit
    28.09.2008
    Beiträge
    53
    Danke
    9
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Also ich hab es mal im Simulationsstatus getestet und bekomme immer wieder die Error ID 10. Die steht für nicht gesendet. Muss das irgendwie mit meiner IP geändert werden? Hab auch die richtige IP Adresse von dem SMTP.1und1.de Server rausbekommen mit dem PING '212.227.0.72'. Aber ich bekomme die Fehlermeldung.

    Ich gehe über W-Lan und einem Router ins Netz. Ich hab die SPS mit einem Kabel an meiner Netzwerkkarte angeschlossen und hab die W-Lan Karte auch freigegeben für die anderen Netzwerkteilnehmer damit sie zugreifen können. Hab das auch mit meinem Laptop getestet und der Laptop geht über die Netzwerkkarte des Computers ins Internet. Nur die SPS gibt diesen FehlerCode raus. Weißt du wie ich einen SMTP Server auf meinem Rechner einrichten kann mit welchem Programm oder der gleichen?

    MFG Dennis

Ähnliche Themen

  1. Sage blockiert beim Emailversand komplettes Outlook
    Von maxi im Forum PC- und Netzwerktechnik
    Antworten: 6
    Letzter Beitrag: 11.05.2011, 16:18
  2. Problematik mit Emailversand
    Von dennish23 im Forum CODESYS und IEC61131
    Antworten: 0
    Letzter Beitrag: 30.09.2008, 16:42

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •