Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 12

Thema: EL6001 mit COMlibV2.lib?

  1. #1
    Registriert seit
    07.10.2008
    Beiträge
    2
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    ich bin relativ neu in diesem Forum. Hier ist auch schon mein erstes Problem.

    Hardware:

    CX9010-0101
    ... diverse Klemmen
    EL6021 RS485 Klemme
    EL6001 RS232 Klemme

    Die Klemme EL6021 habe ich mit Hilfe der Tips im Forum zum laufen gebracht. Ich verwende dazu keine Library.

    Jetzt wollte ich die Klemme EL6001 in Betrieb nehmen, sie pollt einen Scanner ab. Ich habe mir dazu die Library COMlibV2.lib installiert. In der Beschreibung wird ausschliesslich von der Klemme KL6001 gesprochen.

    Erst mal eine generelle Frage: Kann ich die EtherCat Klemme EL6001 mit der Library auch ansprechen?

    Des weiteren habe ich das Problem dass ich die Klemme im System Manager nicht parametrieren kann. Kann es sein dass sich die beiden Kommunikationsklemmen gegenseitig stören? Ich kann keine Baudrate usw. eingeben.

    Vielen Dank schon im voraus.

    Gruß
    Helmut
    Zitieren Zitieren EL6001 mit COMlibV2.lib?  

  2. #2
    Registriert seit
    06.07.2007
    Beiträge
    2.811
    Danke
    174
    Erhielt 274 Danke für 253 Beiträge

    Standard

    Zitat Zitat von hs_soft Beitrag anzeigen
    Erst mal eine generelle Frage: Kann ich die EtherCat Klemme EL6001 mit der Library auch ansprechen?
    Klar kannst du die EL6001 mit der Lib ansprechen. Kannst sogar die 6021 mit der Lib ansprechen. Würde dir auch mal das InfoSystem empfehlen. da gibts bestimmt irgendwo en Beispielprogramm.

    Zitat Zitat von hs_soft Beitrag anzeigen
    Des weiteren habe ich das Problem dass ich die Klemme im System Manager nicht parametrieren kann. Kann es sein dass sich die beiden Kommunikationsklemmen gegenseitig stören? Ich kann keine Baudrate usw. eingeben.
    Dass sich die beiden Klemmen gegenseitig stören, wäre mir neu. Ich vermute eher, dass es daran liegt, dass du nicht im Run- bzw. Freerun-Mode bist.
    A programmer is just a tool which converts caffeine into code.

  3. Folgender Benutzer sagt Danke zu Cerberus für den nützlichen Beitrag:

    hs_soft (06.11.2008)

  4. #3
    hs_soft ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    07.10.2008
    Beiträge
    2
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Vielen Dank für die schnelle Antwort!

    Also ich war schon im Run-Modus. Wenn ich im System Manager, bei der Klemme auf den Reiter CoE-Online gedrückt habe wurden mir die Parameter der Klemme nicht angezeigt, jetzt habe ich auf den Button "Erweitert" gedrückt und dann "All Objects" aktiviert und siehe da, es ging...

    Dann kann ich jetzt ja weiter machen mit der Implementierung der Klemme. Vielen Dank nochmals und ich finde das Forum genial.

    Ciao
    Helmut

  5. #4
    Registriert seit
    06.07.2007
    Beiträge
    2.811
    Danke
    174
    Erhielt 274 Danke für 253 Beiträge

    Standard

    Okay dann lag es daran.

    Kein Problem. Ist immer wieder schön wenn man helfen kann!
    A programmer is just a tool which converts caffeine into code.

  6. #5
    Registriert seit
    25.11.2008
    Ort
    Wilhelmshaven NDS
    Beiträge
    28
    Danke
    10
    Erhielt 2 Danke für 2 Beiträge

    Rotes Gesicht



    moin moin,

    habe mich gerade erst angemeldet - also tach auch.

    Ich habe eine CX 1020 - ein paar EL 1xxx 2xxx 3xxx und eine EL 6001 + 2* ProfiBus EL6731

    jetzt habe ich ein (fast fertiges) Programm geerbt und die TwinCat PLC Control sagt mir: "kann die Biliothek ComLib2V.Lib nicht laden"

    evtl. Blöde frage , aber wo bekomme ich diese Com*.lib her?

    gut von www.Beck..... aber die wollen eine Serien Nr. - da ich aber hier im Office nur die 30 Tage test Version installiert habe -


    Gruß,
    Danke,

    Friese_250
    Zitieren Zitieren ich häng mich mal dran  

  7. #6
    Registriert seit
    06.07.2007
    Beiträge
    2.811
    Danke
    174
    Erhielt 274 Danke für 253 Beiträge

    Standard

    Die ComLibV2 musst du von Beckhoff kaufen. Näheres hierzu siehe hier.

    Wenn du sie dann gekauft hast, kannst du sie unter C:\Programme\TwinCAT\PLC\Lib einfügen.

    Wenn du dann nochmal das Programm laufen lässt, müsste alles funktionieren.
    Geändert von Cerberus (25.11.2008 um 12:43 Uhr) Grund: Hab was vergessen
    A programmer is just a tool which converts caffeine into code.

  8. Folgender Benutzer sagt Danke zu Cerberus für den nützlichen Beitrag:

    Friese_250 (26.11.2008)

  9. #7
    Registriert seit
    25.11.2008
    Ort
    Wilhelmshaven NDS
    Beiträge
    28
    Danke
    10
    Erhielt 2 Danke für 2 Beiträge

    Daumen hoch

    moin moin,

    nee muss ich nicht kaufen

    nur einen Kollegen (weit weg auf der Baustelle) per email erreichen

    und schon war sie im Postkasten

    ach so, nur der Vollständigkeit halber die Lib ist natürlich für unser Haus bezahlt worden.


    Danke für die promte Antwort
    Friese
    Zitieren Zitieren Danke  

  10. #8
    Registriert seit
    10.04.2008
    Beiträge
    38
    Danke
    5
    Erhielt 1 Danke für 1 Beitrag

    Unglücklich

    Hallo!

    Ich muss das Thema nochmals aufgreifen, da ich selbst Probleme mit der EL6001 habe.

    Ich habe nur diese eine Klemme am CX9010 und versuche damit mit dem MotionController eines FaulhaberMotors zu kommunizieren.
    Das Programm funktioniert bereit auf einem CX9000 mit KL-Klemmen.

    Das Problem ist ich kann keine Nachricht senden und weiß nicht an welcher Einstellung das liegt. Mir wurde geraten Brücken von TxD nach RTS und von RxD nach CTS einzubauen.

    Wenn ich nun die Brücke zwischen TxD und RTS im Betrieb entferne und wieder einbaue bekomme ich eine Antwort vom Motor im Programm.
    Wenn die Ich einen Befehl sende reagiert der Motor nicht! Sende ich einen Befehl und warte einige Augenblicke und baue dann die Brücke wieder aus reagiert der Motor plötzlich.

    Ich verstehe nicht was ich falsch mache?? Der Motor funktioniert an einer anderen SPS und ich habe es auch geschafft den Motor zu starten aber eben nur mit Brücke rein und raus und rumprobieren??

    Kann vielleicht jemand helfen??

  11. #9
    Registriert seit
    19.11.2006
    Beiträge
    1.346
    Danke
    6
    Erhielt 254 Danke für 231 Beiträge

    Standard

    Zitat Zitat von Friese_250 Beitrag anzeigen
    nee muss ich nicht kaufen

    nur einen Kollegen (weit weg auf der Baustelle) per email erreichen

    und schon war sie im Postkasten

    ach so, nur der Vollständigkeit halber die Lib ist natürlich für unser Haus bezahlt worden.
    ich meine zu wissen, dass die Beckhoff-Libs immer "pro CPU" lizensiert werden müssen. Einmal bezahlen und dann beliebig weitergeben ist glaub ich nicht erlaubt ... ...

  12. #10
    Registriert seit
    06.07.2007
    Beiträge
    2.811
    Danke
    174
    Erhielt 274 Danke für 253 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von trinitaucher Beitrag anzeigen
    Einmal bezahlen und dann beliebig weitergeben ist glaub ich nicht erlaubt ...
    ... aber gängige Praxis.

    Würde ich jetzt zumindest mal behaupten.
    A programmer is just a tool which converts caffeine into code.

Ähnliche Themen

  1. ComlibV2 ohne Zugriff auf PC Schnittstelle
    Von amedotom im Forum CODESYS und IEC61131
    Antworten: 8
    Letzter Beitrag: 09.11.2010, 15:57
  2. Bibliothek ComlibV2
    Von Cerberus im Forum CODESYS und IEC61131
    Antworten: 6
    Letzter Beitrag: 12.09.2008, 15:37

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •