Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 3 von 3

Thema: Wiedermal ein Programm problem

  1. #1
    Registriert seit
    22.07.2009
    Beiträge
    98
    Danke
    18
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hey Leute ich Bräuchte eure Hilfe mal wieder.
    So nun is die Frage ob das alles so richtig deklariert ist. Denn iwie funktoniert der Vergleich in dem Funktionsblock nicht:
    Weil auch wenn die sUserID eigentilch mit der Benutzerliste[2].sUserID überinstimmt überspringt er einfach das ganze.
    Im online modus zeigt er mir auch nich an ob die Benutzerliste[0] etc. deklariert ist.
    Mfg
    COOLT

    EDIT:
    Hat sich. Nach längerem hin und her überlegen hat sich alles aufgeklärt.
    Geändert von COOLT (28.07.2009 um 16:55 Uhr)
    Zitieren Zitieren Wiedermal ein Programm problem  

  2. #2
    Registriert seit
    22.03.2007
    Ort
    Detmold (im Lipperland)
    Beiträge
    11.718
    Danke
    398
    Erhielt 2.399 Danke für 1.999 Beiträge

    Standard

    Hallo,
    dein Code sieht nicht schlecht aus - allerdings :
    Bei SCL kann man Strings nicht direkt miteinander vergleichen - ich vermute, dass das auch in deinem Fall so ist.
    Versuch doch mal für den Vergleich die Funktion EQ_STRNG und schau dir dazu mal die Hilfe an ...

    Gruß
    LL

  3. #3
    COOLT ist offline Benutzer
    Themenstarter
    Registriert seit
    22.07.2009
    Beiträge
    98
    Danke
    18
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Doch man kann bei TwinCAT im ST die Strings miteinander Vergleichen. In meinem Fall handelt es sich zwar um Zahlen die allerdings vorher irgendwo zu Strings werden aber es funktioniert jetzt trotzdem alles einwandfrei.
    Mfg
    COOLT

Ähnliche Themen

  1. Problem mit SPS-Programm
    Von Puch14 im Forum Simatic
    Antworten: 10
    Letzter Beitrag: 21.05.2009, 14:43
  2. Antworten: 2
    Letzter Beitrag: 18.12.2007, 10:21
  3. Problem mit Beckhoff PLC-Programm
    Von Cerberus im Forum Sonstige Steuerungen
    Antworten: 32
    Letzter Beitrag: 11.07.2007, 16:23
  4. Programm Problem??
    Von Anonymous im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 02.08.2005, 10:37
  5. Antworten: 0
    Letzter Beitrag: 09.11.2004, 20:12

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •