Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 3 ErsteErste 123 LetzteLetzte
Ergebnis 11 bis 20 von 24

Thema: Lampe tasten

  1. #11
    Registriert seit
    07.03.2004
    Beiträge
    4.369
    Danke
    946
    Erhielt 1.158 Danke für 831 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von andy11 Beitrag anzeigen
    was macht das XOR?
    ich versteh das ganze nicht, in B&R muss man da nur ein p oder n Kontakt hingeben, wieso sind 2 KOP's so unterschiedlich?
    Mein Beispiel im Bild ist eh unschön auch wenn es seltsamerweise Funktioniert (ich habe mit KOP nicht viel am Hut). Das XOR sollte lieber in ein eigenes Netzwerk darunter verfrachtet werden.


    Nun zu Deiner Frage XOR ist eine Exklusiv oder der Ausgang eines XORs ist nur dann TRUE wenn Exakt ein Eingang True ist. Wenn mehr oder weniger Eingänge True sind ist der Ausgang False.
    If you open your Mind too much, your Brain will fall out.

  2. #12
    Registriert seit
    11.07.2004
    Beiträge
    1.597
    Danke
    10
    Erhielt 213 Danke für 183 Beiträge

    Standard

    ich habe es so wie im folgenden Bild versucht mit dem ABB Programm zu lösen aber es scheint nicht zu funktionieren.
    Logisch, die Lampe bleibt immer aus. Warum programmierst Du nicht einfach so wie man es Dir vorschlägt?
    Und damit Du nicht dumm sterben mußt, erklären wir mal kurz warum es nicht funktioniert:
    Im zweiten Netzwerk wird bei der steigenden Flanke des Tasters die Lampe eingeschaltet falls sie noch aus ist. Jetzt kommt aber das dritte Netzwerk zum Zuge, hier wird wieder der Taster abgefragt, die Lampe wurde aber eins drüber eingeschaltet, demzufolge ist die Bedingung auch wahr und die Lampe wird gleich wieder ausgeschaltet. Nicht umsonst habe ich im obigen Vorschlag einen Hilfsmerker verwendet. Er hat zur Aufgabe sich zu merken daß die Lampe eben noch aus war und demzufolge wird in meinem Beispiel die Lampe eingeschaltet und bleibt ein.
    Der Hilfsmerker für den Taster macht im Prinzip nichts anderes als Deine Funktionen zur Flankenbildung, nur daß es diese nicht unbedingt so bei jedem Hersteller gibt.

  3. #13
    andy11 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    28.02.2010
    Beiträge
    11
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    ok danke dir einmal da hast du recht, ich bin aber auch dann selber draufkommen, jetzt habe ich aber sowas ähnliches wie du gemacht funktioniert aber trotzdem nicht, was mache ich aber falsch``??
    Angehängte Grafiken Angehängte Grafiken

  4. #14
    Registriert seit
    07.03.2004
    Beiträge
    4.369
    Danke
    946
    Erhielt 1.158 Danke für 831 Beiträge

    Standard

    Wie wäre es wenn Du mal ganz einfach die Lösung von Oberchefe nach malen würdest?

    Alternativ hätte ich auch noch eine Lösung im Anhang die man auch nach malen kann.
    Angehängte Grafiken Angehängte Grafiken
    If you open your Mind too much, your Brain will fall out.

  5. #15
    andy11 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    28.02.2010
    Beiträge
    11
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    das Problem ist, dass ich ja schon eine Idee habe und ich nur ungern über anderer Lösungen zugreife, da ich später im Job auch auf mich selbst gestellt bin, jetzt ist noch meine Lernphase, ich bin jetzt zwar schon 4.HTL aber bisher habe ich nur in FUP programmiert und dieses Kop macht mich echt fertig, also bitte helft mir mit meiner Idee und bitte erklärts ihr Spezialisten wieso es nicht so hinhaut wie es sollte

    lg andy

  6. #16
    Registriert seit
    07.03.2004
    Beiträge
    4.369
    Danke
    946
    Erhielt 1.158 Danke für 831 Beiträge

    Standard

    Zitat Zitat von andy11 Beitrag anzeigen
    das Problem ist, dass ich ja schon eine Idee habe und ich nur ungern über anderer Lösungen zugreife...
    Warum Deine Lösung nicht funktioniert ist mir schon klar. Nur wie soll ich Dir das erklären?

    Wenn Dein Netzwerk 2 den Zustand hat das der Ausgang gesetzt wird ist die Bedingung eben automatisch (einen Zyklus später) auch im Netzwerk 3 erfüllt die den Ausgang wieder zurücksetzt.
    Geändert von zotos (07.03.2010 um 20:17 Uhr)
    If you open your Mind too much, your Brain will fall out.

  7. #17
    andy11 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    28.02.2010
    Beiträge
    11
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Wenn Dein Netzwerk 2 den Zustand hat das der Ausgang gesetzt wird ist die Bedingung eben automatisch auch im Netzwerk 3 erfüllt die den Ausgang wieder zurücksetzt.
    Nein das stimmt nicht, denn ich setze ja Zustand zurück, somit kann die erfüllung der Bedinguing im 3ten Netzwerk nicht geschehen

    aber es funzt trotzdem nicht

    lg andy

  8. #18
    Registriert seit
    11.07.2004
    Beiträge
    1.597
    Danke
    10
    Erhielt 213 Danke für 183 Beiträge

    Standard

    erklärts ihr Spezialisten wieso es nicht so hinhaut wie es sollte
    Ganz einfach,
    nehmen wir mal an der Ausgang war vorher aus, mit dem Taster wird in NW1 "Zustand" auf 1 gesetzt, in NW2 gibt es folglich eine steigende Flanke, der Ausgang wird auf 1 gesetzt, das Bit Zustand zu 0. Jetzt kommen wir in NW3, "Zustand" ist jetzt 0, der Rest wird nicht abgearbeitet.
    Zweiter Programmdurchlauf, Taster immer noch gedrückt. In NW1 wird Zustand wieder zu 1. In NW2 passiert nichts (der Ausgang von R_TRIG wird zu 0 da der Eingangspfad im vorhergehenden Durchlauf bereits 1 war).
    Jetzt kommt aber NW2. Da war im vorhergehenden Durchlauf das Bit "Zustand" 0, daher wird mit R_TRIG eine steigende Flanke gesetzt, der Ausgang ist ja mittlerweile 1 und wird daher wieder auf 0 gesetzt. Wird der Taster jetzt losgelassen bleibt der Ausgang aus.

  9. #19
    Registriert seit
    07.03.2004
    Beiträge
    4.369
    Danke
    946
    Erhielt 1.158 Danke für 831 Beiträge

    Standard

    Zitat Zitat von andy11 Beitrag anzeigen
    Nein das stimmt nicht, denn ich setze ja Zustand zurück, somit kann die erfüllung der Bedinguing im 3ten Netzwerk nicht geschehen

    aber es funzt trotzdem nicht

    lg andy
    Ich habe den Fehler in der Beschreibung auch bemerkt und vorhin schon einen Zyklus später ergänzt.

    Das Netzwerk 3 ist deshalb erfüllt weil Dein Taster ja die Variable "Zustand" wieder setzt.

    Wenn man Dein Beispiel anpasst das es geht hat es nicht mehr viel mit dem Ansatz zu tun.

    Siehe Anhang mit Lösung 3, 4 oder 5?
    Angehängte Grafiken Angehängte Grafiken
    If you open your Mind too much, your Brain will fall out.

  10. #20
    andy11 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    28.02.2010
    Beiträge
    11
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    das hast du fantastisch erklärt und jetzt weiß ich auch was du meinst.
    Jedoch haben wir das im Werkstättenlabor !sehhr! ähnlich gelöst und mit dem selben denkansatz, das kann doch nicht so falsch sein was ich gemacht hab, da fehlt bstimmt nur eine Kleinigkeit, aber ich schau mir mal eure Beispiele an obwohl ich komme mit Ideen anderer wie schon gesagt nicht gut zurecht
    danke euch

Ähnliche Themen

  1. Blinkende Lampe
    Von Bobbel87 im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 06.10.2009, 15:06
  2. SF DP Lampe leuchtet
    Von ReHu im Forum Simatic
    Antworten: 20
    Letzter Beitrag: 28.04.2008, 14:58
  3. Antworten: 4
    Letzter Beitrag: 23.02.2007, 20:19
  4. 24 V LEd Lampe mit 0-10V dimmen
    Von maxi im Forum Elektronik
    Antworten: 10
    Letzter Beitrag: 05.04.2006, 19:40
  5. analogausgangskarte sf lampe
    Von Jochen Kühner im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 22.09.2004, 22:06

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •