Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 9 von 9

Thema: Wago Webvisu, Texteingabe

  1. #1
    Registriert seit
    06.10.2009
    Beiträge
    26
    Danke
    1
    Erhielt 2 Danke für 1 Beitrag

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Zusammen

    Ich möchte gerne über ein Rechteck einen Wert (Temperatur) eingeben und diesen dann in einen Programm verwenden.
    Aber ich scheitere schon an der Texteingabe.
    Die Einstellung des Rechtecks findet ihr im Anhang.
    Was mache ich falsch?

    Vielen Dank
    Iwan
    Angehängte Grafiken Angehängte Grafiken
    Zitieren Zitieren Wago Webvisu, Texteingabe  

  2. #2
    Registriert seit
    13.06.2008
    Beiträge
    182
    Danke
    15
    Erhielt 25 Danke für 22 Beiträge

    Standard

    Hast du auch eine Var für die Textausgabe definiert?
    Zu finden unter "Variablen".

  3. #3
    iwan ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    06.10.2009
    Beiträge
    26
    Danke
    1
    Erhielt 2 Danke für 1 Beitrag

    Standard

    Hat geklappt, super!

    Vielen Dank
    Iwan

  4. #4
    Registriert seit
    22.03.2016
    Beiträge
    22
    Danke
    18
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Hallo,

    auch wenn der Beitrag schon ein wenig älter ist.


    Kann mir jemand sagen was ich wie definieren muss, damit ein in der Visu einen Wert eingeben kann.

    Irgendwie mache ich da immer was falsch bei

    Also ich habe die Einstellungen so wie oben getroffen ich muss ja denke jetzt nur eine entsprechende Variable in das passende Feld eintragen.

    Leider klappt das nicht.


    Danke

  5. #5
    Registriert seit
    26.11.2012
    Ort
    Gummersbach
    Beiträge
    502
    Danke
    18
    Erhielt 71 Danke für 69 Beiträge

    Standard

    Was genau klappt daran nicht?

    Du musst in der Registerkarte "Variablen" in der Zeile Textausgabe eine Variable eintragen, in die Deine Eingabe geschrieben werden soll.
    Diese sollte zuvor Global definiert und nicht gerade Bool sein...
    Ganz kurz ganz hell
    ganz lange ganz dunkel....

  6. Folgender Benutzer sagt Danke zu Morymmus für den nützlichen Beitrag:

    Erdberquark (25.01.2017)

  7. #6
    Registriert seit
    22.03.2016
    Beiträge
    22
    Danke
    18
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Hi,

    hatte die Variable nur Lokal angelegt

    Also nur in dem Objekt wo ich die benötige.

    Dann kannst du mir doch auch sagen warum ich die jetzt nicht angezeigt bekomme


    Ich kann die übers Nummernpad zwar eingeben, aber es wird null angezeigt.

    Die Variable
    Temp_Soll_Bad: INT := 25;

    Was muss ich jetzt bei Text\Inhalt eintragen, damit mir die Zahl auch angezeigt wird.

    Danke

  8. #7
    Registriert seit
    13.06.2008
    Beiträge
    182
    Danke
    15
    Erhielt 25 Danke für 22 Beiträge

    Standard

    Kurzer Auszug aus der Hilfe:

    Wenn Sie im Text "%s" eingeben,
    wird im Online Modus an dieser Stelle der Wert der Variablen aus dem Feld 'Textausgabe' der Kategorie 'Variablen' als String dargestellt. Sie können auch eine Formatangabe verwenden, die der der Funktion sprintf aus der Standard-C-Bibliothek entspricht:


    Zeichen
    Argument / Ausgabe als

    d,i
    Dezimale Zahl

    o
    Oktale Zahl ohne Vorzeichen (ohne führende Null)

    x
    Hexadezimale Zahl ohne Vorzeichen (ohne führendes 0x)

    u
    Dezimale Zahl ohne Vorzeichen

    c
    Einzelnes Zeichen

    s
    Zeichenkette

    f
    REAL-Werte [-]m.dddddd, wobei die Genauigkeit die Anzahl der d festlegt (Voreinstellung ist 6).



    Der Variablenwert wird im Online Modus entsprechend dargestellt werden. Als Eingabe sind alle IEC-konformen Formatierungen erlaubt, die zum jeweiligen Typ der Variable passen.

  9. Folgender Benutzer sagt Danke zu L.T. für den nützlichen Beitrag:

    Erdberquark (25.01.2017)

  10. #8
    Registriert seit
    26.11.2012
    Ort
    Gummersbach
    Beiträge
    502
    Danke
    18
    Erhielt 71 Danke für 69 Beiträge

    Standard

    Du musst bei Text "%s" eintragen um den Wert der Variable zu sehen.
    Ich würde allerdings "%s °C" nehmen, ich finde das sieht ordentlicher aus. (Natürlich ohne die ")

    Ok, je nachdem was Du für eine Variable deklariert hast gehen auch die anderen z.B. d wenn Dein Wert rein dezimal ist (also z.B. INT)
    Geändert von Morymmus (25.01.2017 um 16:10 Uhr)
    Ganz kurz ganz hell
    ganz lange ganz dunkel....

  11. Folgender Benutzer sagt Danke zu Morymmus für den nützlichen Beitrag:

    Erdberquark (25.01.2017)

  12. #9
    Registriert seit
    22.03.2016
    Beiträge
    22
    Danke
    18
    Erhielt 1 Danke für 1 Beitrag

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hatte da ein "%f °C" drin stehen.

    Daher konnte es nicht klappen.

    Danke für die schnelle Hilfe!!!!

Ähnliche Themen

  1. Wago 750-841 WebVisu sehr langsamm
    Von c-teg74 im Forum WAGO
    Antworten: 11
    Letzter Beitrag: 17.01.2014, 14:12
  2. Webvisu in WAGO
    Von jacky im Forum CODESYS und IEC61131
    Antworten: 1
    Letzter Beitrag: 08.04.2011, 20:57
  3. Webvisu Wago 750-841
    Von M_o_t im Forum CODESYS und IEC61131
    Antworten: 11
    Letzter Beitrag: 06.10.2010, 14:23
  4. Wago Webvisu, Texte 90° drehen?
    Von Lebenslang im Forum CODESYS und IEC61131
    Antworten: 1
    Letzter Beitrag: 21.03.2010, 21:13
  5. WAGO 750-841 WebVisu
    Von vladi im Forum CODESYS und IEC61131
    Antworten: 6
    Letzter Beitrag: 21.09.2008, 14:32

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •