Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 2 ErsteErste 12
Ergebnis 11 bis 17 von 17

Thema: Wie kann ich ein pt1000-Signal korriegieren?

  1. #11
    Registriert seit
    17.01.2010
    Beiträge
    197
    Danke
    81
    Erhielt 21 Danke für 20 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von CoDeSys123456 Beitrag anzeigen
    Das fälschlicherweise verwendete Kabel JS(Y)t ??? Installationskabel 2*2*0,8 der Sensor hat allerdings nur zwei Drähte (das dürfte jedoch nicht der ausschlaggebende Punkt sein.
    Dann könntest Du ja Vierleiter machen! Die paar mOhm bis zum Sensor fallen bei PT1000 (oder NI1000) nicht ins Gewicht.

  2. Folgender Benutzer sagt Danke zu bimbo für den nützlichen Beitrag:

    CoDeSys123456 (02.04.2010)

  3. #12
    Registriert seit
    08.08.2008
    Ort
    Köln
    Beiträge
    357
    Danke
    57
    Erhielt 88 Danke für 69 Beiträge

    Standard

    Benutze mal die Funktion AI_Temp und schreib mal was dort am Ausgang rauskommt.

  4. Folgender Benutzer sagt Danke zu Lebenslang für den nützlichen Beitrag:

    CoDeSys123456 (02.04.2010)

  5. #13
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.732
    Danke
    314
    Erhielt 1.520 Danke für 1.282 Beiträge

    Standard

    @Lebenslang
    Die Funktion ist zwar aus der Wago-Bib,
    aber diese Funktion wandelt den Wert in ein REAL und dividiert dasselbige durch 10.

    Also vollkommen unspektakulär...

    @Bimbo
    Wie üblich würde 4-Leiter auch eine entsprechende Eingangsklemme bedingen,
    ist hier aber nicht der Fall.

    Mfg
    Manuel
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

  6. Folgender Benutzer sagt Danke zu MSB für den nützlichen Beitrag:

    CoDeSys123456 (02.04.2010)

  7. #14
    Registriert seit
    01.03.2008
    Beiträge
    487
    Danke
    3
    Erhielt 43 Danke für 39 Beiträge

    Standard

    Hallo,
    ich geb auch mal meinen Senf dazu....

    Ich hatte auch mal so ein Problem. Es war auf die Masse zurückzuschreiben !

    Evtl. nutzt du ja eine andere Masse als dein Controller.

    Kannst den Wert ja mit nem OHM-Meter messen.

    Also mehr als 2-3 1/10 K sollte der Wert nicht differenzieren.

    Fehlersuche sollte somit schnell möglich sein.

    MfG CAS
    www.cas-solution.de

    Alles geregelt...


    Weltraumflug in den USA zu gewinnen!
    Kratze hier ▒▒▒▒▒▒▒▒▒▒▒▒ mit einer Münze,
    und finde heraus, ob Du der Gewinner bist!

  8. Folgender Benutzer sagt Danke zu cas für den nützlichen Beitrag:

    CoDeSys123456 (02.04.2010)

  9. #15
    Registriert seit
    19.02.2010
    Beiträge
    35
    Danke
    19
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo nochmals,

    entschuldigt bitte, dass ich nicht sofort geantwortet habe.

    Das Phänomen ist verschwnden. Der Fühler arbeitet jetzt einwandfrei, ohne irgendwelche Veränderungen.

    Ich weiß nicht warum. Der Fühler musste sich wohl zwei drei Tage einleben????. Vergleichmessungen stimmen jetzt auf ca. +/-0.1-0.2°C.
    Hoffentlich bleibt der Fuhler jetzt ""geeeicht""

    Dennoch vielen Dank für Eure Mühe und vielen Ratschläge..

    Nun habe ich ein weiteres Problem mit der Kommaverschiebung.
    Möchte in Fup das Komma von INT von drei Ziffern xxx auf xx.x bekommen
    (muss exakt sein)
    Habe es bereits probiert %2.1f bekomme das aber irgendwie mit Codesys nicht hin. Da man ja den WERT (immernoch INT???) auf REAL setzten muss.
    Wie macht man das mit FUP (real variable = funktioniert nicht).

    Bitte um Ratschläge

    P.S. Schöne Ostern Euch allen.

  10. #16
    Registriert seit
    07.03.2004
    Beiträge
    4.369
    Danke
    946
    Erhielt 1.158 Danke für 831 Beiträge

    Standard

    Um aus einem INT Wert einen Realwert zu machen, verwendet man die Typwandlung INT_TO_REAL (auch in FUP).
    If you open your Mind too much, your Brain will fall out.

  11. Folgender Benutzer sagt Danke zu zotos für den nützlichen Beitrag:

    CoDeSys123456 (02.04.2010)

  12. #17
    Registriert seit
    19.02.2010
    Beiträge
    35
    Danke
    19
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zotos,

    vielen Dank.
    So einfach.

    Grüße CoDeSys123456789

Ähnliche Themen

  1. PT1000 an KL3228 ohn KL9187
    Von pezi179 im Forum CODESYS und IEC61131
    Antworten: 5
    Letzter Beitrag: 27.10.2011, 20:10
  2. PT1000 an welche Analogbaugruppe?
    Von bernd67 im Forum Simatic
    Antworten: 7
    Letzter Beitrag: 04.10.2009, 22:22
  3. Pt1000?
    Von marcelmoonwalker im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 17.02.2009, 14:42
  4. SAIA HLK / Pt1000
    Von F411 im Forum Sonstige Steuerungen
    Antworten: 6
    Letzter Beitrag: 04.11.2008, 16:27
  5. Beckhoff KL3204 auf PT1000
    Von dabastler im Forum CODESYS und IEC61131
    Antworten: 2
    Letzter Beitrag: 16.06.2008, 09:37

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •