Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 3 von 3

Thema: ADS sehr langsam

  1. #1
    Registriert seit
    26.02.2010
    Beiträge
    6
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen,

    ich habe ein Programm geschrieben, mit dem ich Eingänge auf einem BC9050 anzeigen kann und Ausgänge über eine Checkbox setzten. Wenn ich einen Ausgang setze, so dauert das unter umständen zwischen 2 und 5 Sekunden.

    Hat jemand auch diese Erharung gemacht??

    Ich möchte nähmlich über den Rechner Steuerungsaufgaben machen. Dazu muss die Verbindung aber deutlich Schneller sein.

    grüße mike
    Zitieren Zitieren ADS sehr langsam  

  2. #2
    Registriert seit
    19.10.2009
    Beiträge
    194
    Danke
    8
    Erhielt 50 Danke für 44 Beiträge

    Standard

    Du könntest versuchen, das SPS-Projekt so anzupassen, dass du es auf deinem lokalen Laufzeitsystem starten kannst - auf dem selben PC auf dem auch dein Bedienprogramm läuft. Wenn die SPS lokal läuft, die Echtzeitauslastung relativ klein ist und der Router nicht durch irgendwas zugeballert wird, dann sollten
    ADS-Abfragen sehr schnell im Bereich von Millisekunden abgearbeitet werden.
    Wenn das Bedienprogramm auch mit der lokalen SPS so träge kommuniziert, dann liegt es an deinem Programm. Im anderen Fall liegt es am Netzwerk oder am BC9050 bzw. dem SPS-Projekt.
    Nützlich ist in solchen Fällen auch der AdsMonitor

    Gruß,
    witkatz

  3. #3
    mikep ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    26.02.2010
    Beiträge
    6
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    hat etwas länger gedauert...
    ich habe die Software und die SPS auf meinem Rechner zu gleich laufen lassen und es hat perfekt funktioniert.
    Nachdem ich den Ads Monitor installiert habe, funktioniert es jetzt auch, wenn ich die Bediensoftware am Rechner laufen habe und auf den BC9050 zugreife ohne Verzögerung. Zufall??

    Ich habe mir jetzt gedacht, dass es an der Version der dll's liegt. Aber daran scheint es auch nicht zu liegen.

    Wenn ich die Bediensoftware nämlich vom Laptop (Windows 7) starte habe ich immer noch die Verzögerung. Starte ich die Identische Software vom Rechner (XP) funktioniert es einwandfrei.

Ähnliche Themen

  1. iFIX 5.0 - Workspace sehr langsam
    Von Arco im Forum HMI
    Antworten: 3
    Letzter Beitrag: 14.04.2011, 10:21
  2. Libnodave auf S5 sehr langsam...
    Von StefanK im Forum Hochsprachen - OPC
    Antworten: 8
    Letzter Beitrag: 24.11.2009, 12:56
  3. MPI Kommunikation sehr langsam
    Von eYe im Forum Simatic
    Antworten: 0
    Letzter Beitrag: 06.11.2007, 11:33
  4. TP177A sehr langsam am Profibus
    Von bernd67 im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 15.02.2007, 12:04
  5. OP 17 sehr langsam
    Von Progri im Forum HMI
    Antworten: 3
    Letzter Beitrag: 26.01.2005, 18:38

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •