Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 17

Thema: Hilfe bei serieller Kommunikation

  1. #1
    Registriert seit
    24.01.2011
    Beiträge
    7
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen,

    ich hoffe ihr könnt mir helfen.

    Problem:
    Ich möchte gern einen Kugelhahn mit Mikroprozessor über eine serielle Schnittstelle ansteuern. Befehle können mit CR oder LF terminiert werden.
    Der Kugelhahn kann Befehle im ASCII Code verarbeiten, möglich wären hier !<Pos> oder V (für die Ausgabe der Versionsnummer) + weitere Befehle.

    TwinCat Software ist vorhanden (ja auch die ComLib), Hardware die vorhanden ist wären BK 1120 + KL6031 oder alternativ EK1100 + EL6001

    Ich kann bisher den Ausgang der Klemme mit Daten belegen, im System Manager auch zu sehen bzw. am Kugelhahn kommt am Tx auch eine Spannung an.

    Allerdings tut sich am Eingang der Klemme nichts, wenn ich eine Positionsvorgabe sende passiert auch nichts.

    Habe das ganze mit dem Beckhoffbeispiel zum senden eines strings probiert. Ohne Erfolg, bzw. mit dem genannten Resultat.

    Ich habe keine Ahnung wo der Fehler liegt, muss die Klemme noch konfiguriert werden? Wie muss der string richtig aussehen? Passt die Hardware einfach nicht?

    Habe mittlerweile so viele Ansätze ausprobiert, nichts funktioniert. Beckhoff support kann mir auch nicht helfen, Kugelhahn Hersteller meint ich solle den Hahn mit ner seriellen Schnittstelle vom PC aus mit Hyperterm oder so ansprechen (also per SUB-D kabel und entsprechendem Adapter) aber das hilft mir nicht, da ich neben dem Kugelhahn auch noch 2 weitere Hähne und noch n paar andere Teile steuern möchte (und zwar ohne dass ich jedesmal mein kabel in jedes Teil reinstecke)

    Falls ihr mehr Infos braucht sagt Bescheid. Zur Lösung reicht mir ja vlt. auch nur ein andere Denkansatz oder irgend ein Stichwort dass zur Lösung führt...google kann ich dann auch noch allein benutzen...aber ich habe jetzt echt so gar keine Ahnung was mir weiter hilft.

    also ideen, fragen, lösungen,....her damit ich bin für jeden geistreichen kommentar dankbar
    Zitieren Zitieren Hilfe bei serieller Kommunikation  

  2. #2
    Registriert seit
    25.05.2009
    Ort
    Raum Zürich CH
    Beiträge
    85
    Danke
    15
    Erhielt 15 Danke für 15 Beiträge

    Standard

    Zitat Zitat von sps_noob Beitrag anzeigen
    Hallo zusammen,

    .... zu sehen bzw. am Kugelhahn kommt am Tx auch eine Spannung an.
    Was heisst am Tx kommt eine Spannung an? Nach meinem Verständnis ist hier Tx der Sendeausgang der Kugelhahn-Schnittstelle.

    Oder anders gesagt:
    - Der Tx-Anschluss der Beckhoff-Klemme muss mit dem Rx-Anschluss des Kugelhahns verbunden sein
    - Der Rx-Anschluss der Beckhoff-Klemme muss mit dem Tx-Anschluss des Kugelhahns verbunden sein
    - Auf beiden Seiten müsste jetzt noch ein GND-Anschluss sein, der dann noch miteinander verbunden wird.

    So sieht meiner Meinung nach eine RS232-Verbindung aus.

    Gruss SW-Mech

  3. #3
    sps_noob ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    24.01.2011
    Beiträge
    7
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Oh da hab ich gar nicht dran gedacht das zu erwähnen...nein, also gemeint ist natürlich der Tx Eingang am Hahn, es ist tatsächlich der Dateneingang gemeint, so stehts zumindest auch in der Anleitung....ausprobiert hab ich es im übrigen auch schon...

    Die Verbindung sieht natürlich so aus wie du sie beschrieben hast...Ich hab mich da nur unklar ausgedrückt, also das Kabel welches mit dem Tx(Klemme) verbunden ist und am Rx(Hahn) angeschlossen ist, da kann ich eine Spannung messen...

    Am Tx(Hahn) kann ich auch eine Spannung messen, dieses Kabel ist mit Rx(Klemme) verbunden...nur ich sehe keine Daten im System Manager...

    Also elektrisch scheint schon alles richtig verbunden, ja auch gnd.


    aber danke trotzdem
    Geändert von sps_noob (25.01.2011 um 15:37 Uhr)

  4. #4
    Registriert seit
    28.10.2005
    Ort
    Ottweiler, Saar
    Beiträge
    940
    Danke
    259
    Erhielt 124 Danke für 109 Beiträge

    Standard

    Spannungen messen im Ruhezustand.
    Auf RxD und TxD sollten immer von Null verschiedene Pegel vorhanden sein.
    Kenne den Beckhoff-Kram nicht, aber wenn es sich um RS232 handelt,
    so muss es gegenüber GND eine negative Spannung sein.

    Verflixt nochmal, vor etwa 30 Jahren habe ich mittels Kopfhörer probiert ob
    sich auf Sende- und Empfangsleitung etwas bewegt. Da ging es allerdings nur um maximal 9600 Baud.

    Also die Verkabelung stimmt? Sicher?

    Sind ja nur drei Drähte, und es fließen nur Milli...

  5. #5
    sps_noob ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    24.01.2011
    Beiträge
    7
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    also am Rx(Hahn) habe ich ca. -10,5V am Tx(Hahn) -8,3V gnd ist nahezu 0

    wie sw-mech die verdrahtung beschrieben hat, so ist sie in der anleitung und so ist sie auch schon immer von mir umgesetzt... ich denk der fehler liegt irgendwo in der software, also entweder muss ich im system manager noch etwas machen oder im plc muss das programm irgendwie anders aussehen...evtl. die klemme konfigurieren, wobei laut kugelhahn anleitung die standard settings der kl6031 identisch sind mit der der kugelhahn schnittstelle...

    aktuell sieht das programm so aus wie das beispiel von beckhoff zu sendstring...kann den code hier nicht einfügen, da anderer rechner, aber ich habs auch schonmal hier im forum gesehen...if timer.q or send.busy then .... send (.............) usw.

    für das was ich da aufbauen will benutzen wir nen CP6211 - irgendwas und der hängt weder am netz noch hat der sonst irgend ne datenübertragungsmöglichkeit zu meinem laptop. (bzw. wir wollen das auch gar nicht)

  6. #6
    Registriert seit
    27.11.2009
    Ort
    BW - Ecke Ulm
    Beiträge
    438
    Danke
    135
    Erhielt 36 Danke für 33 Beiträge

    Standard

    Hi,

    hast du die Komponenten schon öfter eingesetzt oder ist es das erste mal?
    Auch wenn der Tip schon genannt wurde würde ich ggf. die Komponenten erst mal einzeln testen / kennenlernen.

    Also wie der Hahnhersteller schon sagt mit nem PC den Hahn über eine serielle Verbindung (Hypertherminal unter Windows) mal ansprechen.
    Wäre ja gut möglich das der Hahn nen Hau weg hat.
    Wenn das tut weißt das der Hahn schon mal nicht schuld ist.

    Dann kannst du auf die selbe Methode die Ausgaben deiner Seriell-Karte prüfen.

    Sollte bis hierhin alles iO sein hört mein Latein auf.

    Eine Frage noch. Du schreibst den oben genannten Test möchtest oder kannst du nicht machen, weil du mehrere Hähne anzusteuern hast. Sind das zufällig RS485 Komponenten? Denn RS232 ist soweit ich weiß eine reine Punkt zu Punkt Verbindung.

    Hoffe das hilft.

    Gruß ohm200x
    --
    ohm200x

  7. #7
    Registriert seit
    12.04.2010
    Beiträge
    300
    Danke
    22
    Erhielt 54 Danke für 52 Beiträge

    Standard

    Hallo,
    unter der Annahme dass es eine RS232 ist (und keine RS485/RS422)

    Grundsätzlicher Test ob von der SPS was rauskommt: Du zapfst die Tx Leitung der SPS an und führst sie mit dem Ground auf die serielle Rx des PC (auch USB Serial Konverter möglich).

    Dann lässt du irgend so ein Programm mitlaufen wie z.B.
    http://www.serial-port-monitor.com/index.html

    Wenns rein ASCII ist, kannst du auch Hyperterm verwenden.

    Dann siehst du schon mal genau, was aus der SPS rauskommt.

    Das gleiche kannst du auch beim Kugelhahn versuchen.

    Das müsste dir dann doch schon etwas aufzeigen.

    bg
    bb
    Geändert von bits'bytes (25.01.2011 um 21:12 Uhr) Grund: Rx/Tx vertauscht :-)

  8. #8
    Registriert seit
    23.06.2008
    Ort
    Friesoythe
    Beiträge
    116
    Danke
    9
    Erhielt 17 Danke für 16 Beiträge

    Standard

    Hallo,

    hatte vor zwei wochen mal nen änlichen Fall, hatte aber mit Modbus RTU zutun.
    Aber vieleicht bringt es dich ja weiter.

    Ich hatte nen BC9020 und ne KL6001. Damit wollte ich ein LCD Display über RS232 Modbus RTU ansteuern. Bei der Inbetriebnahme bzw. testen, wurden nur Daten von der Klemme hinaus gesendet. Es kam aber absolut nichts an Daten/Antworten vom LCD wieder. Hatte dann gedacht das irgendetwas im Programm nicht in Ordnung war. Zum überprüfen des Programmes hab ich das LCD über den COM Port am Laptop betrieben. Funktioniert!
    Hab dann anstatt den BC9020 ein BC9100 eingesetzt. Problem bestand immer noch. Durch zufall hab ich gesehen, dass ich noch ein BC9100 mit anderer Firmware hab. Eingesetzt, und es funktionierte, zum Teil! Daten senden und empfange funktionierte. Um eine sicher Verbindung zu gewährleisten musste ich die Taskzeit von 10ms auf 5ms runtersetzten. Und seit dem läuft es!!

    BC9020 -> FW: B4; Lief nicht
    BC9100 -> FW: B1; Lief nicht
    BC9100 -> FW: B0; funktioniert


    Vieleicht gibt es ja auch probleme mit der Firmware auf dem BK, oder vieleicht die Taskzeit zu hoch?

    MFG
    Christoph

  9. #9
    Registriert seit
    06.08.2009
    Beiträge
    14
    Danke
    1
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Hast du jetzt schon mal versucht über Hyperterminal den Kugelhahn zu steuern?
    Die Klemmen an sich sind vorkonfiguriert. Je nachdem welchen Typ du benutzt.
    Bei uns sind immer 9600/8/n/1 in der Klemme als standard. Über KS2000 kannst du die Klemme umkonfigurieren.

    Ich hab dir mal ein Beispiel für nen scanner der via serieller Kommunikation arbeitet angehängt.
    Angehängte Dateien Angehängte Dateien

  10. #10
    sps_noob ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    24.01.2011
    Beiträge
    7
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Aaaalso,

    ich fang mal hinten an.

    KS2000 hab ich nicht, habe "nur" TwinCat.

    Den Verusch mit Hyperterminal habe ich bereits gemacht (schon lange bevor ich versucht habe das ganze mit Beckhoff) zu machen...es geht alles.

    Aber ich möchte ja meine Anlage automatisieren und nicht mit dem Stecker von Teil zu Teil rennen. Wenn ich so an die 10 serielle Schnittstellen am Laptop hätte würde sich das Problem natürlich nicht ergeben. Deshalb ja TwinCat + Klemmen, da kann ich mir ja soviele Schnittstellen basteln wie ich brauche.

    Was ich demnächst noch versuchen werde (falls niemand ne bessere Idee hat) ist das was bitsbytes geschrieben hat...also mal loggen was da rauskommt.
    ...
    Im System Manager sehe ich den Klemmenausgang 22 Datenbyte...ich sende jetzt den string "V$N" an den Kugelhahn, der Hahn sollte eigentlich dann mit der Versionsnummer antworten...Der Ausgang der Klemme sieht dann so in etwa aus Byte 0: 86 Byte1: 0D die anderen Bytes 00 ... Stausbyte am Eingang (Klemme) switched immer zwischen 0000 und 0001 aber die Datenbytes bleiben bei 00
    Das sollte eigentlich NUR bei nem nicht bekannten Befehl passieren...Ist mein String falsch? Terminierung?

    Das ist jetzt gerade der aktuelle Stand, den String hab ich schon mehrfach verändert...in allen Variationen...habe irgendwo in der infosys gelesen die strings sind Nullterminiert...ist das von Belang? In der Hahn-Anleitung steht als Terminierungszeichen CR oder LF bin jetzt confused wegen dieser Nullterminierung...

    Möglicherweise ist ja genau das der Fehler...wenn ich mit Hyperterm Daten an den Hahn sende brauch ich mir darüber keine Gedanken machen...da hab ich nichts von ner Nullterminierung gehört bisher.

    schonmal Danke für eure Mühen und Ideen...

    ach ja...die Firmwareaktualisierung...guck ich mal ob und wie das geht und dann obs hilft
    Geändert von sps_noob (27.01.2011 um 12:59 Uhr)

Ähnliche Themen

  1. Kommunikation mit TouchPanel 477C (Hilfe! :V)
    Von wabese im Forum Simatic
    Antworten: 11
    Letzter Beitrag: 11.01.2011, 23:46
  2. Beckhoff CX, Probleme mit serieller Schnittstelle
    Von thensel im Forum CODESYS und IEC61131
    Antworten: 7
    Letzter Beitrag: 24.03.2008, 13:47
  3. Antworten: 4
    Letzter Beitrag: 02.03.2007, 18:20
  4. [Info] Artikel zu CANbus und serieller Kommunikation (RSxxx)
    Von Kurt im Forum Werbung und Produktneuheiten
    Antworten: 1
    Letzter Beitrag: 27.09.2005, 06:21
  5. Serieller Datenaustausch
    Von MFe im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 29.04.2004, 17:49

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •