Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 18

Thema: TwinSAFE Com ERR

  1. #1
    Registriert seit
    28.07.2007
    Beiträge
    71
    Danke
    9
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    ich habe das Problem das ich meine TwinSAFE Gruppe nicht in den RUN-Modus bekomme, da ich den Com ERR nicht resetet bekomme. Woran kann das liegen, und wie kann ich das beheben?

    Mein Aufbau besteht aus BK1120, KL1904 und KL6904.

    Gruß
    Borsti
    Zitieren Zitieren TwinSAFE Com ERR  

  2. #2
    Registriert seit
    11.08.2009
    Ort
    Bei Hamburg
    Beiträge
    100
    Danke
    19
    Erhielt 30 Danke für 18 Beiträge

    Standard

    Ich denke doch das Du die Beckhoff-Doku zur Hand hast?

    http://download.beckhoff.com/downloa...L6904-FBde.pdf

    Bei dem COM_ERR handelt es sich um einen Fehler einer der angelegten TwinSafe-Gruppen (Edit: genauer einer TwinSAFE-Connection), welche das ist und welcher Fehler dort ansteht kann Online ermittelt werden.
    Geändert von NochEinProgrammierer (30.01.2011 um 12:27 Uhr) Grund: Ergänzt

  3. #3
    Registriert seit
    25.11.2010
    Ort
    OWL
    Beiträge
    745
    Danke
    27
    Erhielt 164 Danke für 142 Beiträge

    Standard

    Bei dem Aufbau gibt es ja nur eine TwinSafe-Connection, zwischen der 6904 und der 1904. Kann also eigentlich nur an der EtherCat-Verbindung zwischen der Steuerung und dem BK1120 liegen. Ist der BK1120 denn im Status "OP"?

  4. #4
    Registriert seit
    28.07.2007
    Beiträge
    71
    Danke
    9
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Zitat Zitat von StructuredTrash Beitrag anzeigen
    Bei dem Aufbau gibt es ja nur eine TwinSafe-Connection, zwischen der 6904 und der 1904. Kann also eigentlich nur an der EtherCat-Verbindung zwischen der Steuerung und dem BK1120 liegen. Ist der BK1120 denn im Status "OP"?
    Ja der BK ist im OP Modus.

    Auszug aus der Connection List:

    # | Typ | Status | Diagnose
    1 | TwinSAFE Master | undefiniert | 1000 0101

  5. #5
    Registriert seit
    11.08.2009
    Ort
    Bei Hamburg
    Beiträge
    100
    Danke
    19
    Erhielt 30 Danke für 18 Beiträge

    Standard

    Zitat Zitat von borsti87 Beitrag anzeigen
    Ja der BK ist im OP Modus.

    Auszug aus der Connection List:

    # | Typ | Status | Diagnose
    1 | TwinSAFE Master | undefiniert | 1000 0101
    Diagnosebits xxxx 0101 = Watchdog abgelaufen
    Diagnosebits 1000 xxxx = FSoE Master meldet Failsafe Value aktiv

    Wie ist die Watchdog-Zeit eingestellt, wie ist der externe Aufbau (Leitungslänge?), wie sind die Eingänge der KL1904 Konfiguriert?

  6. #6
    Registriert seit
    28.07.2007
    Beiträge
    71
    Danke
    9
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Es handelt sich um einen Testaufbau mit nur einem Schütz maximale Leitungslänge beträgt 20-30cm. Die Schützspule ist an Kanal 1 der KL6904 angeschlossen und ein Schließer an den Kanal 1 der KL1904.

    Parameter der KL1904:

    S-Address: 1
    Kanal 1: aktiv
    Kanal 2: nicht aktiv
    Kanal 3: nicht aktiv
    Kanal 2: nicht aktiv
    Sensortest Kanal 1: aktiv
    Sensortest Kanal 2: nicht aktiv
    Sensortest Kanal 3: nicht aktiv
    Sensortest Kanal 2: nicht aktiv

    einkanalige Auswertung der Kanäle
    Ambivalenz für alle Kanäle nicht aktiv

    FSoE Watchdog: 100

  7. #7
    Registriert seit
    11.08.2009
    Ort
    Bei Hamburg
    Beiträge
    100
    Danke
    19
    Erhielt 30 Danke für 18 Beiträge

    Standard

    An Kanal 1 bitte mal den Sensortest deaktivieren.

    Da hier ein Schliesser aufgelegt ist kann meldet der Sonsortest einen Fehler auf diesem Kanal.
    Vereinfachte Wirkungsweise des Sensortests:
    Der Sensortest gibt ein Signal auf die Leitung dessen Rückmeldung vom TwinSafe-System ausgewertet wird, bleibt das Signalrückmeldung auf dem System aus wird der EM-Stop ausgelöst.

  8. #8
    Registriert seit
    28.07.2007
    Beiträge
    71
    Danke
    9
    Erhielt 0 Danke für 0 Beiträge

    Standard

    OK habe ich geändert doch bleibt der Com ERR

  9. #9
    Registriert seit
    11.08.2009
    Ort
    Bei Hamburg
    Beiträge
    100
    Danke
    19
    Erhielt 30 Danke für 18 Beiträge

    Standard

    Dann stelle bitte den Watchdog auf z.B. 500ms....

    Wie sehen die DIAG Anzeigen der Klemmen aus?

  10. #10
    Registriert seit
    28.07.2007
    Beiträge
    71
    Danke
    9
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    KL1904:
    Diag 1: ein, mit kurzen Unterbrechungen und etweigen kurzem flackern
    Diag 2: aus
    Diag 3: aus
    Diag 4: aus

    KL6904:
    Diag 1: flackern, 1 Blink-Impuls
    Diag 2: aus
    Diag 3: aus
    Diag 4: aus

Ähnliche Themen

  1. TwinSAFE COM ERR
    Von HK09 im Forum CODESYS und IEC61131
    Antworten: 4
    Letzter Beitrag: 24.05.2012, 21:21
  2. TwinSAFE Problem
    Von HK09 im Forum CODESYS und IEC61131
    Antworten: 1
    Letzter Beitrag: 23.09.2011, 14:36
  3. TwinSAFE Kommunikationsfehler (COM ERR)
    Von HK09 im Forum CODESYS und IEC61131
    Antworten: 1
    Letzter Beitrag: 04.02.2011, 17:58
  4. TwinSAFE Kommunikationsfehler
    Von HK09 im Forum CODESYS und IEC61131
    Antworten: 1
    Letzter Beitrag: 20.09.2010, 09:43
  5. Beckhoff TwinSAFE
    Von Fliegertiger im Forum Sonstige Steuerungen
    Antworten: 1
    Letzter Beitrag: 23.04.2006, 20:41

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •