Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 4 von 6 ErsteErste ... 23456 LetzteLetzte
Ergebnis 31 bis 40 von 55

Thema: Konfiguration einer Beckhoff CX1010

  1. #31
    Registriert seit
    19.11.2006
    Beiträge
    1.346
    Danke
    6
    Erhielt 254 Danke für 231 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von bleri Beitrag anzeigen
    Ist die Konfiguration denn immer in der CX oder muss ich jedes mal nach Rechner-Neustart die Konfiguration in der CX einspielen?
    Ist die Konfig erstellt und aktiviert, wird sie beim Neustart immer wieder geladen.
    Beim PLC-Programm nur, wenn ein "Boot Projekt" erstellt wurde. Sonst muss man es jedes mal neu laden und starten.

    (zu Beginn/Inbetriebnahme sollte man kein Bootprojekt erstellen. Denn falls man mal Mist programmiert hat und die PLC abschmiert, ist nach dem Neustart alles wieder weg. Deswegen erst wenn alles einwandfrei funktioniert das Bootprojekt laden!)

  2. Folgender Benutzer sagt Danke zu trinitaucher für den nützlichen Beitrag:

    bleri (10.02.2011)

  3. #32
    bleri ist offline Benutzer
    Themenstarter
    Registriert seit
    06.01.2011
    Beiträge
    42
    Danke
    6
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Zitat Zitat von trinitaucher Beitrag anzeigen
    Ist die Konfig erstellt und aktiviert, wird sie beim Neustart immer wieder geladen.
    Beim PLC-Programm nur, wenn ein "Boot Projekt" erstellt wurde. Sonst muss man es jedes mal neu laden und starten.

    (zu Beginn/Inbetriebnahme sollte man kein Bootprojekt erstellen. Denn falls man mal Mist programmiert hat und die PLC abschmiert, ist nach dem Neustart alles wieder weg. Deswegen erst wenn alles einwandfrei funktioniert das Bootprojekt laden!)
    Super die Anleitung von CAS ist klasse, ich hatte immer vergessen "Bootprojekt laden" zu klicken. Ich werde das noch testen und euch bescheid geben. Bis dahin möchte ich mich nochmal ganz herzlich für eure Hilfe bedanken.

  4. #33
    bleri ist offline Benutzer
    Themenstarter
    Registriert seit
    06.01.2011
    Beiträge
    42
    Danke
    6
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Zitat Zitat von cas Beitrag anzeigen
    Also hier noch mal für die Neulinge:

    Programm schreiben mir dem PLC-Server
    Dabei die Variablen deklarieren
    Hardware-Ein/Ausgänge mit dem berühmten AT% definieren.
    Programm übersetzten und speichern (damit die Konfig-Datei erstellt wird.)

    dann

    Den Systemmanager aufrufen
    Verbindung zur SPS aufbauen (Routing usw)
    Klemmen im Konfigmodus suchen lassen und ggf. nochmal nachprüfen.

    dann

    Das SPS-Programm im Systemmanager einfügen
    dann die Hardware mit den Variablen des Programmes verknüpfen

    dann

    im Systemmanager den Check ausführen usw.
    dann die Einstellung speichern und aktivieren
    SPS "Starten"

    dann

    im PLC-Server eine Verbindung zur SPS aufnehmen und das Programm downloaden

    dann wenn fertig ein Boot-Projekt erzeugen (damit das Programm autom. startet nach Spannungsausfall)
    dann speichern drücken.

    dann

    Läuft die SPS. Nie wieder anfassen, außer bei Programmänderungen

    dann

    Per ADS oder OPC oder MODBus usw auf die Variablen zugreifen.
    Keine weitere Einstellung notwendig.
    Im schlimmsten Falls die Symboltabelle erstellen (unter Menue/Option).

    Das wars.

    MfG CAS
    Also ich habe alle Schritte von dir befolgt und es funktioniert auch soweit, die Variablen sind in der CX.

    ABER:
    Ich muss wenn ich die CX resete immer erst eine Verbindung über den System Manager erstellen um über OPC Client auf die Variablen zugreifen zu können.

    Und warum steht bei mir immer MAIN vor den Variablen, kann ich das nicht entfernen?

  5. #34
    Registriert seit
    19.11.2006
    Beiträge
    1.346
    Danke
    6
    Erhielt 254 Danke für 231 Beiträge

    Standard

    Zitat Zitat von bleri Beitrag anzeigen
    Ich muss wenn ich die CX resete immer erst eine Verbindung über den System Manager erstellen um über OPC Client auf die Variablen zugreifen zu können.
    Was meinst du mit "Verbindung erstellen"?
    Was hat OPC mit dem System Manager zu tun?
    Zitat Zitat von bleri Beitrag anzeigen
    Und warum steht bei mir immer MAIN vor den Variablen, kann ich das nicht entfernen?
    Dein PLC-Programm heißt MAIN. Die Variable wird anhand Ihrer Deklaration dargestellt:
    Programm.FB.FB.Variable oder .GlobaleVariable (ohne Programm, da global).

  6. #35
    bleri ist offline Benutzer
    Themenstarter
    Registriert seit
    06.01.2011
    Beiträge
    42
    Danke
    6
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Ja ich finde es auch komisch aber ich muss jedesmal eine Verbindung mit Gerat herstellen erst dann kann ich auf die Variablen zugreifen. Also das Fenster wo man das Zielsystem auswählt.

    Ja, dass das mein Programm ist ist klar nur geht das den nur mit Globalen Variablen?

  7. #36
    Registriert seit
    01.03.2008
    Beiträge
    487
    Danke
    3
    Erhielt 43 Danke für 39 Beiträge

    Standard

    Hallo,

    Wo läuft der OPC-Server ?

    Sind die Routen 100%ig auf den Rechner drauf ?

    ... Routen auch da, wo sich der OPC-Server befindet !!!

    Steht die CX auf Autorun oder auf Konfig ???


    MfG CAS
    Angehängte Grafiken Angehängte Grafiken
    Geändert von cas (10.02.2011 um 18:48 Uhr)
    www.cas-solution.de

    Alles geregelt...


    Weltraumflug in den USA zu gewinnen!
    Kratze hier ▒▒▒▒▒▒▒▒▒▒▒▒ mit einer Münze,
    und finde heraus, ob Du der Gewinner bist!

  8. #37
    bleri ist offline Benutzer
    Themenstarter
    Registriert seit
    06.01.2011
    Beiträge
    42
    Danke
    6
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Zitat Zitat von cas Beitrag anzeigen
    Hallo,

    Wo läuft der OPC-Server ?

    Sind die Routen 100%ig auf den Rechner drauf ?

    ... Routen auch da, wo sich der OPC-Server befindet !!!

    Steht die CX auf Autorun oder auf Konfig ???


    MfG CAS
    Also der OPC Server liegt auf der Festplatte. Den habe ich mit TwinCAT Opc Configurator erstellt.

    Was meinst du mit Routen?

    Also der CX steht auf Konfig.

  9. #38
    Registriert seit
    19.11.2006
    Beiträge
    1.346
    Danke
    6
    Erhielt 254 Danke für 231 Beiträge

    Standard

    Mensch, nicht immer so sparsam mit den Infos!!!
    Zitat Zitat von bleri Beitrag anzeigen
    Also der OPC Server liegt auf der Festplatte.
    Welche Festplatte
    Zitat Zitat von bleri Beitrag anzeigen
    Den habe ich mit TwinCAT Opc Configurator erstellt.
    Wo? Auf welchem Rechner läuft der OPC-Server?
    Zitat Zitat von bleri Beitrag anzeigen
    Was meinst du mit Routen?
    Zitat Zitat von bleri Beitrag anzeigen
    Also der CX steht auf Konfig.


    ... was schrieb ich vorhin doch gleich?
    Zitat Zitat von trinitaucher Beitrag anzeigen
    @bleri:
    Scheint so, als fehlten noch elementare Grundlagenkenntnisse über Beckhoff-Steuerungen (TwinCAT) und deren Konfiguration und Programmierung.
    und die Antwort:
    Zitat Zitat von bleri Beitrag anzeigen
    Also ich habe schon Kenntnisse in den Bereich. [...]

  10. #39
    Registriert seit
    01.03.2008
    Beiträge
    487
    Danke
    3
    Erhielt 43 Danke für 39 Beiträge

    Standard

    Hallo,

    ich hoffe, der OPC-Server liegt nicht auf der Festplatte sonder ist unter dem Betriebssysten xyz installiert. man weis ja nie...

    Routen sind suuuuuper wichtig.

    Jede Kommunikation, Rechner <--> SPS muß mittels Routen definiert sein, damit solche Kommunikation auch durch ADS geschieht. Der OPC-Server nutzt auch ADS.

    Man kann das auf der SPS erkennen, in dem man sich beim Systemmanger beim zugehörigen Projekt der SPS die Routen anzeigen läßt. Da muß dann der PC-Name oder ggf. die IP-Adresse vorhanden sein.
    Bei PC natürlich auch.
    Einfach auf dem PC das TC installieren und eine Verbindung mittels Broadcastsearch aufbauen und die Route speichern. Fertig...
    SPSn, die sich unterhalten wollten (Daten austauschen mittels ADS) brauchen auch so eine Route. Die Anzahl der Roten ist aber begrenzt. Ich glaub es sind 40 oder so.

    Es kann in deinem Fall sein, das die Route von deinem OPC-Server fehlt und nur Temporär erstellt wird wenn du mit dem Systemmanger drauf bist.
    Also die Rote anlegen !!!

    Damit deine SPS nach einem Neustart auch losläuft muß diese natürlich auf RUN stehen, nicht auf Konfig.
    Man kann gut erkennen wo die SPS steht. In deinem Fall wird diese wohl nach einem Neustart blaue LEDs haben.
    Nach einem Neustart sollten aber alle LEDs grün sein und ggf. ein bißchen flackern.

    So fertig...

    MfG CAS
    www.cas-solution.de

    Alles geregelt...


    Weltraumflug in den USA zu gewinnen!
    Kratze hier ▒▒▒▒▒▒▒▒▒▒▒▒ mit einer Münze,
    und finde heraus, ob Du der Gewinner bist!

  11. Folgender Benutzer sagt Danke zu cas für den nützlichen Beitrag:

    bleri (11.02.2011)

  12. #40
    bleri ist offline Benutzer
    Themenstarter
    Registriert seit
    06.01.2011
    Beiträge
    42
    Danke
    6
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Morgen,

    mein OPC-Server liegt als XML-File auf der Festplatte, in den TwinCAT Ordner.

    Ich füge die Route immer per Broadcastsearch ein aber nach jedem neustart der SPS, kann ich keine Verbindung zu Route herstellen sondern muss immer erst die Route wieder neu einfügen über Broadcastsearch.

    Das komische, die LED´s sind immer auf Grün nach dem neustart aber trotzdem wird keine Verbindung hergestellt.

Ähnliche Themen

  1. Beckhoff CX1010 Kommunikation über Ethernet
    Von Eisbaer_vw im Forum CODESYS und IEC61131
    Antworten: 5
    Letzter Beitrag: 22.09.2011, 17:32
  2. Suche: Beckhoff CX1010 + NT
    Von madmaxx126 im Forum Suche - Biete
    Antworten: 2
    Letzter Beitrag: 15.07.2011, 21:05
  3. Konfiguration einer Master-Slave Konfiguration
    Von Aeppel713 im Forum Simatic
    Antworten: 11
    Letzter Beitrag: 29.03.2011, 09:00
  4. Beckhoff CX1010 mit XP embedded - Visualisierung
    Von msfdgn im Forum CODESYS und IEC61131
    Antworten: 6
    Letzter Beitrag: 12.11.2009, 12:04
  5. Beckhoff CX1010 Parametersicherung bei Spannungsausfall
    Von Controllfreak im Forum CODESYS und IEC61131
    Antworten: 3
    Letzter Beitrag: 11.11.2008, 12:08

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •