Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 2 ErsteErste 12
Ergebnis 11 bis 17 von 17

Thema: Eingangskarte +-10V Sensor +-4V ?

  1. #11
    Registriert seit
    19.11.2006
    Beiträge
    1.346
    Danke
    6
    Erhielt 254 Danke für 231 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von Gluttony Beitrag anzeigen
    Ich nehm an, dass ich die Probleme mit dem Auslesen daher rühren, dass das 12.Bit für die Vorzeichenbestimmung benutzt wird. Da ich den Sensor jedoch über ein WORD auslese 16Bit , wird das mit dem Vorzeichen jedoch nicht mehr berücksichtigt und deswegen ergeben sich die großen Werte.
    Ähmmm ... der Datentyp der Eingangsprozessdaten ist "INT", also mit Vorzeichen. Dein WORD ist grundsätzlich vorzeichenlos. Wieso nimmst du nicht den Datentyp, der vorgeben wird?
    Und es sind bei Beckhoff grundsätzlich 16 Bit für analoge Eingangsdaten (außer Sonderklemmen). Wenn die Klemme 12 Bit hat, wird intern interpoliert auf 16 Bit. Das Ergebnis ist dann einfach nur "grober".

    Es gibt von Beckhoff übrigens auch Klemmen mit 16 Bit Auflösung und höherer Genauigkeit.

    edit: Rechtschreibung verbessert
    Geändert von trinitaucher (14.03.2011 um 12:59 Uhr)

  2. #12
    Registriert seit
    22.03.2007
    Ort
    Detmold (im Lipperland)
    Beiträge
    11.726
    Danke
    398
    Erhielt 2.401 Danke für 2.001 Beiträge

    Standard

    Zitat Zitat von Neals Beitrag anzeigen
    Wenn du eine Analoge +/- 10V Klemme nimmst, musst du den Wert doch umrechnen:
    Du bekommst ein WORD von der Klemme. (Wertebereich: 0 - 65535)
    Der Messbereicht ist von -10V bis +10V.

    Dann würde der Eingangswert von 0 einem Messwert von -10V entsprechen.
    Der Eingangswert 65535 ist dann ein Messwert von +10V.
    ... möchtest du dir das nicht vielleicht lieber noch einmal überlegen ?
    Wie schon gesagt bin ich kein Beckhoff-Programmierer - der Aufbau WORD / INT ist aber bei Beckhoff auch nicht anders wie bei allen anderen auf der Welt.

    zur Erinnerung :
    Dez. 1 = Hex 0001
    Dez. -1 = Hex FFFF
    ... ansonsten siehe Beitrag von Trinitaucher ...

  3. #13
    Gluttony ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    04.03.2011
    Beiträge
    13
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Super, sobald ich wieder am Sensor bin, probier ich das mit INT gleich mal aus, schon jetzt danke für die schnelle Hilfe.
    Ich dachte einfach WORD wäre in diesem Fall das richtige.

    Das mit dem Array hört sich sehr sinnvoll an, werde gleich mal im Forum die Suchfunktions darauf ansetzten, da ich noch nicht mit Arrays gearbeitet habe.

    Gruß Gluttony
    Geändert von Gluttony (14.03.2011 um 13:15 Uhr) Grund: INT und WORD

  4. #14
    Registriert seit
    24.04.2008
    Ort
    Lübeck
    Beiträge
    324
    Danke
    8
    Erhielt 63 Danke für 62 Beiträge

    Standard

    Zitat Zitat von Larry Laffer Beitrag anzeigen
    ... möchtest du dir das nicht vielleicht lieber noch einmal überlegen ?
    Wie schon gesagt bin ich kein Beckhoff-Programmierer - der Aufbau WORD / INT ist aber bei Beckhoff auch nicht anders wie bei allen anderen auf der Welt.

    Zitat:
    zur Erinnerung :
    Dez. 1 = Hex 0001
    Dez. -1 = Hex FFFF
    ... ansonsten siehe Beitrag von Trinitaucher ...
    WORD: 0 bis 65535; 16 Bit und entspricht einem UINT.
    INT: -32768 bis +32767; 16 Bit und damit nicht unsigned.

  5. #15
    Gluttony ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    04.03.2011
    Beiträge
    13
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Guten Morgen,

    ich war gestern noch am Beschleunigungssensor und das Umstellen auf INT hat funktioniert. Jetzt bekomme ich positive und negative Werte heraus.

    Mir ist jetzt nur noch nicht klar, welche Einheit die Werte haben, meine Vermutung ist:

    INT: +32767 bis -32768 entsprechen der möglichen Ausgangsspannung von +10 bis -10V

    Mein Sensor hat einen Messbereich von +-4V demnach liegen die INT-Zahlen in
    einem Bereich von +13.107 bis -13.107 (32.767 / 10V * 4V)?

    Würde diese Annahme stimmen so entspricht
    1V = 3.276,7
    0,01V = 32,767
    0,04V = 131,068 (müsste auch die Empfindlichkeit des Sensors von 40 mV pro g entsprechen)

    Also ist ein Messwert den ich mit meiner Faust auf Tisch (Sensor in der Faust) mit INT = +5000 erziehlt habe gleich einer Spannung von 1,526V oder?

    Wow dann hätte ich ja 38g erziehlt? Nicht ein bisschen viel?

    Gruß Gluttony
    Geändert von Gluttony (15.03.2011 um 08:42 Uhr) Grund: Fehlerkorrektur

  6. #16
    Registriert seit
    22.03.2007
    Ort
    Detmold (im Lipperland)
    Beiträge
    11.726
    Danke
    398
    Erhielt 2.401 Danke für 2.001 Beiträge

    Standard

    @TE:
    Ich denke, du hast den dreisatz korrekt umgesetzt ...

    @Neals:
    probier es einfach mal aus ...

    Gruß
    Larry

  7. #17
    Gluttony ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    04.03.2011
    Beiträge
    13
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ich war wieder an meinem Beschleunigungssensor und habe es ausprobiert...

    .. es funktioniert, besten Dank!

    Gruß Gluttony

Ähnliche Themen

  1. 315 2DP Problem mit Eingangskarte
    Von Dany_the_kid im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 26.05.2010, 16:17
  2. Komisches Verhalten Analoge Eingangskarte.
    Von vollmi im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 11.05.2010, 20:11
  3. PT100 an Analog Eingangskarte
    Von Ray_k1 im Forum Simatic
    Antworten: 7
    Letzter Beitrag: 10.11.2009, 04:49
  4. Gleichstrom 0-10A messen und auf 0-10V Eingangskarte ?
    Von Betriebselektriker28 im Forum Elektronik
    Antworten: 4
    Letzter Beitrag: 29.01.2009, 12:06
  5. Fehler S7-300 Analog Eingangskarte SM 331
    Von Anonymous im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 13.10.2005, 20:55

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •