Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 6 von 6

Thema: Frage zur Variablendeklaration bei r_trig

  1. #1
    Registriert seit
    22.06.2010
    Beiträge
    31
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Gemeinde,

    ich habe gerade ein schwerwiegendes Problem mit meiner Deklaration eines r_trig-Bausteins...

    wenn ich den Baustein reinziehe, belege ich CLK und Q mit meinen Variablen, mit denen es vorher schon funktioniert hat.
    Doch irgendwie bin ich zu blöd, den Hilfsmerker richtig zu deklarieren

    laut http://infosys.beckhoff.com/index.ph...g.htm&id=11620
    ist der Hilfsmerker wie folgt zu deklarieren:
    VAR M : BOOL; END_VAR

    meine Deklaration lautet jetzt: Flanke_Test: BOOL;

    diese Variable verwende ich für den r_trig Baustein.

    beim Kompilieren erhalte ich jedoch die Fehlermeldung 4052, die sagt:
    'Flanke_Test' muß eine deklarierte Instanz des Funktionsblocks 'R_TRIG' sein.

    Irgendwie steh ich komplett am Schlauch

    kann mir bitte wer weiterhelfen? Danke!

    greetz
    Chris
    Zitieren Zitieren Frage zur Variablendeklaration bei r_trig  

  2. #2
    Registriert seit
    01.09.2010
    Beiträge
    35
    Danke
    6
    Erhielt 9 Danke für 9 Beiträge

    Standard

    denke du kommst aus der Siemens Welt
    R_TRIG ist ein FB und braucht seine Instanz
    siehe Screenshot
    Angehängte Grafiken Angehängte Grafiken

  3. #3
    blubbi ist offline Benutzer
    Themenstarter
    Registriert seit
    22.06.2010
    Beiträge
    31
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    hehe, ja komme aus der Siemens Welt

    Vielen Dank hat gleich funktioniert. obwohl ich mir ja einbilde, dasselbe schon mal probiert zu haben... aber ich hab schonsoviel probiert....

    greetz
    Christian

  4. #4
    Registriert seit
    01.09.2010
    Beiträge
    35
    Danke
    6
    Erhielt 9 Danke für 9 Beiträge

    Standard

    dafür ist ja das Forum da, Frage rein und jemand kennt die Antwort, oft schneller als eine Hotline, das mit dem Siemens war nur Lebenserfahrung arbeite ja auch mit Step7 und kenne so auf jeder Seite die Stolpersteine

  5. #5
    Registriert seit
    09.11.2010
    Beiträge
    53
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo,

    ich habe das Problem, dass Codesys R_TRIG nicht als Typ kennt.



    Gruß

  6. #6
    Registriert seit
    21.02.2011
    Ort
    Deutschland, Baden-Würtemberg
    Beiträge
    992
    Danke
    115
    Erhielt 125 Danke für 100 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von msbes Beitrag anzeigen
    Hallo,

    ich habe das Problem, dass Codesys R_TRIG nicht als Typ kennt.



    Gruß
    Die Standard.lib muss installiert / eingebunden sein!
    Grüße

Ähnliche Themen

  1. Frage zu Eltako Funktion mit R_Trig
    Von berti74 im Forum CODESYS und IEC61131
    Antworten: 4
    Letzter Beitrag: 24.07.2011, 12:27
  2. Variablendeklaration in den Bausteinen
    Von Simon_ im Forum CODESYS und IEC61131
    Antworten: 11
    Letzter Beitrag: 07.09.2010, 09:59
  3. CoDeSys Variablendeklaration
    Von shiznit im Forum CODESYS und IEC61131
    Antworten: 3
    Letzter Beitrag: 02.08.2010, 14:59
  4. Step 7 V5.4 F_Trig / R_Trig
    Von chefren_new im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 02.11.2009, 22:24
  5. R_Trig in SCL
    Von c.glas im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 20.06.2006, 13:39

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •