Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 2 von 2

Thema: Ein und Ausgangsadressierung

  1. #1
    Registriert seit
    09.09.2011
    Beiträge
    38
    Danke
    4
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,
    ich habe jetzt mein erstes Projekt in CoDeSys zum laufen bekommen doch wird dort noch nichts sinvolles geschaltet!
    Das heißt es werden noch keine Ein und Ausgänge abgefragt.
    Dieses wollte ich nun noch nachholen und wollte mir nun das WAGO Starterkit mit der 750-842 Bestellen, und jetzt geht es Los???
    Wie Adressiere ich in CoDeSys V3 eigendlich die Ein bzw Augänge???
    Eine HW Config habe ich ja doch nicht oder???
    Kann ich das vieleicht auch ersmal Simmulieren???

    Thomas
    Zitieren Zitieren Ein und Ausgangsadressierung  

  2. #2
    Registriert seit
    23.06.2008
    Ort
    Friesoythe
    Beiträge
    116
    Danke
    9
    Erhielt 17 Danke für 16 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hi,
    Digitale Eingänge werden z.B. so adressiert:
    Code:
    Eingang1   AT %IX0.0 :BOOL;
    Eingang2   AT %IX0.1 :BOOL;
    Digitale Eingänge werden z.B. so adressiert:
    Code:
    Ausgang1  AT %QX0.0 :BOOL;
    Ausgang2  AT %QX0.1 :BOOL;
    Analoge Eingänge werden z.B. so adressiert:
    Code:
    Analogeingang1  AT %IB0 :INT;
    In der Beckhoff Doku ist es schon gut erklärt. Siehe hier.
    Es muss halt noch drauf geachtet werden, welche Klemmen man hat, ob analog und/oder digital, und dann die Bits und Bytes richtig zuordnen. Dies kann man gut aus der HW Conig herauslesen. Es ist mit Sicherheit auch bei CoDeSys beschrieben. Weiß halt nicht wo.

    Mfg
    Christoph

  3. Folgender Benutzer sagt Danke zu Commander_Titte für den nützlichen Beitrag:

    thomas223 (22.11.2011)

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •