Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 3 von 3

Thema: Dali Konstantlicht mit Wago

  1. #1
    Registriert seit
    24.11.2011
    Beiträge
    21
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hi,

    Ich versuche grade eine Konstantlichtregelung mit Wago und Dali zum laufen zu bringen aber irgendwie scheint es nicht richtig zu gehen, einige Räume scheinen zu klappen (Lampe geht an, aber zu schnell wieder aus) und in anderen geht gar nichts.
    Deswegen die Frage, ist mein Code, siehe Bild, Prinzipiell richtig?
    Ich hab noch nicht rausgefunden, wo genau das Problem liegt, evtl. ists auch in KNX.
    Angehängte Grafiken Angehängte Grafiken
    Zitieren Zitieren Dali Konstantlicht mit Wago  

  2. #2
    Registriert seit
    01.03.2008
    Beiträge
    487
    Danke
    3
    Erhielt 43 Danke für 39 Beiträge

    Standard

    Also grundsätzlich würde ich sagen dass dies dort gar keine Regelung ist.
    Das Minimum was du hier brauchtst ist wohl ein PI-Regler, evtl. sogar PID.

    Du Fährst scheinbar die Lichtleistung parallel zur gemessenen Heligkeit als Wippe auf und ab.
    Das ist MIST. (tschuldigung)

    Nimm einen PI-Regler mit Sollwert und Istwert und es wird klappen.
    Sehr einfache Lösung wäre auch:
    SW=Sollwert Licht
    IW= Istwert Licht
    Y="Leistung" der Lampe

    If SW>IW then and y>0 then Y=y-1;endif
    If SW<IW then and y<32767 then Y=y+1;endif

    So wird es sich sicherlich irgendwann einpendeln.

    MfG CAS
    www.cas-solution.de

    Alles geregelt...


    Weltraumflug in den USA zu gewinnen!
    Kratze hier ▒▒▒▒▒▒▒▒▒▒▒▒ mit einer Münze,
    und finde heraus, ob Du der Gewinner bist!

  3. #3
    nmap ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    24.11.2011
    Beiträge
    21
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Danke für die Antwort, aber der Baustein ist ein Regelbaustein und sollte auch so Funktionieren.
    Aber das Problem lag woanders. Das Programm was ich hatte wurde von wem anders geschrieben, und der hat da bissl Mist verzapft. Da wurde der Luxwert ausgelesen, der kommt aber nur alle Minute mal übern Bus. Ich musste das völlig anders lösen. Der Dimmwert den der Präsenzmelder ausgibt gebe ich auf einen Dimmbaustein, der dann das Dali regelt. Leider etwas Stufig, da nur alle 2 Sekunden der Dimmwert kommt, aber ich befürchte, wenn ich das Senden im Sekundentakt mache, daß dann die Buslast zu Hoch wird. Der KNX Bus ist schon ziemlich gut voll.

Ähnliche Themen

  1. Wago 750-641 Dali Master überlappende Gruppenzuordnung
    Von Tati im Forum CODESYS und IEC61131
    Antworten: 0
    Letzter Beitrag: 21.11.2011, 12:03
  2. Wago 750-841 DALI Fb_DALI_SwitchValue
    Von Michael68 im Forum Programmierstrategien
    Antworten: 3
    Letzter Beitrag: 25.05.2011, 08:41
  3. Wago 750-841 DALI EVG Dimmt nicht sauber
    Von Michael68 im Forum Programmierstrategien
    Antworten: 1
    Letzter Beitrag: 17.05.2011, 16:07
  4. Hilfe bei der Planung, KNX, WAGO, DALI
    Von sid112 im Forum Sonstige Steuerungen
    Antworten: 22
    Letzter Beitrag: 04.01.2010, 07:34
  5. DALI Programmierung mit WAGO 750-841
    Von wolfi3300 im Forum Sonstige Steuerungen
    Antworten: 2
    Letzter Beitrag: 26.05.2008, 10:44

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •