Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 9 von 9

Thema: Fehlermeldung DeviceNet (sync Master)

  1. #1
    Registriert seit
    24.01.2012
    Beiträge
    5
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    wir haben eine KRC3 Steuerung mit einer Beckhoff EL6752 0010 DeviceNet Slavebusklemme verbunden. Der EL 6752 0010 haben wir MAC ID 5 und eine Baudrate von 500k eingestellt.

    Wir bekommen bei der Aktivierung der SPS einen Fehler
    -->Gerät 'Gerät1 (EL6752-0010)' benötigt Sync Master (mindestens eine Verknüpfung mit einer Task nötig) .
    Im Run Modus leuchtet die Run LED grün und die zweite LED blinkt grün auf.

    Was bedeutet dieser Fehler und müssen wir in der Steuerung noch weitere Einstellungen vornehmen oder liegt der Fehler in den Einstellungen der Robotersteuerung?

    mfg.
    Zitieren Zitieren Fehlermeldung DeviceNet (sync Master)  

  2. #2
    Registriert seit
    17.03.2011
    Ort
    im Wald
    Beiträge
    284
    Danke
    11
    Erhielt 36 Danke für 35 Beiträge

    Standard

    Hallo

    bischen mehr Infos wären gut. Ich denke mit aktivieren der SPS meinst du, Konfiguration im System-Manager aktivieren. Hast du in dem PLC-Programm die Klemme nicht programmiert. Ist deine Fehlermeldung, meines erachtens normal und nicht schlimm. Welche Run LED und welche zweite meinst du ???

    Gruß, Voxe

  3. #3
    Registriert seit
    24.10.2010
    Beiträge
    133
    Danke
    2
    Erhielt 23 Danke für 23 Beiträge

    Standard

    Hi,
    ich hatte diese Klemme noch nie im Einsatz. Kenne diese Fehlermeldung vom EtherCat. Dort kommt die Meldung immer, wenn die Variablenverknüpfung im System Manager zur PLC fehlt. Es muss mindestens 1 Variable Verknüpft werden. Vielleicht hilft dir das weiter.
    Gruß
    Erfahrung ist nicht das, was einem zustößt. Erfahrung ist, was du aus dem machst, was dir zustößt.
    Aldous Huxley

  4. #4
    Registriert seit
    17.03.2011
    Ort
    im Wald
    Beiträge
    284
    Danke
    11
    Erhielt 36 Danke für 35 Beiträge

    Standard

    Hallo Ghosty,

    ich habe ein Projekt mit CanOpen (was eigentlich oder fast DeviceNet ist) gemacht, da kam diese Fehlermeldung immer, sobald etwas an der Konfiguraration geändert wurde, also im System-Manager. Obwohl Variablen verknüpft waren. Mir war die Meldung endlich egal, da alles nach quittieren lief. Da, der TE nicht mehr geantwortet hat, ist dies wohl auch der Fall. Also, ein kleiner BB (Beckhoff-Bug) mit dem wir alle leben.

    Gruß, Voxe

  5. Folgender Benutzer sagt Danke zu Voxe für den nützlichen Beitrag:

    Ghosty (03.02.2012)

  6. #5
    hille ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    24.01.2012
    Beiträge
    5
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Ja, der Fehler kommt in TwinCat.
    Das Problem ist, dass wir nicht wissen, wo diese Verknüpfung zwischen Koppler und den Eingängen gemacht werden muss.

    Wir haben ein simples Programm (über KRC3) geschrieben:
    - der Robi fährt eine bestimme Position an
    - hier wartet er, bis wir ihm ein Signal geben (einfaches Drücken einer Taste über Eingang (Adresse 78.0))

    Zusätzlich haben wir ein Test-Programm mit TwinCat erstellt, um unserer SPS-Configs zu testen.
    Hier ist soweit alles ok.

    Die Eingänge der SPS haben folgende Adressen: 77.0-77.7 und 78.0-78-7.

    Laut Beckhoff besteht eine Kommunikationsstörung mit dem Master.
    Müssen die Einstellungen in der iosys.ini geändert werden?

    http://infosys.beckhoff.com/index.ph...rmdiag.htm&id=

    dnsc_1co.ini

    MAC_ID=1
    BAURATE=500

    dnsc_1sl.ini

    [1]
    MAC_ID=5
    VENDOR_ID=418
    PRODUCT_TYP=12
    PRODUCT_CODE=14
    POLL_RESPL=8
    POLL_CMDL=8

    iosys.ini

    [DRIVERS]
    ...
    DNSC1=12,dnsc1Init,dnsc1drv.o
    DNSC2=13,dnsc2Init,dnsc2drv.o
    ...

    [DNSC1]

    INB0=5, 0, x1 ;$IN[1-8]
    INB1=5, 1, x1 ;$IN[9-12]
    OUTB0=5, 0, x1 ;$OUT[1-8]
    OUTB1=5, 0, x1 ;$OUT[9-12]

    SPS-Configs
    twincat system manager config.jpg
    Geändert von hille (04.02.2012 um 12:45 Uhr)

  7. #6
    Registriert seit
    17.03.2011
    Ort
    im Wald
    Beiträge
    284
    Danke
    11
    Erhielt 36 Danke für 35 Beiträge

    Standard

    Hallo hille,

    in deinem Bild erkenne ich nicht, das deine Hardware mit dem PLC-Projekt verknüpft ist. Du musst deine Variablen des PLC-Projektes (SPS-Programm) mit der Hardware verknüpfen. Dies geschieht mit dem System-Manager durch zusammen clickern. Wie man das auch mit einfachen Ein- und Ausgängen macht.

    Gruß, Voxe

  8. #7
    hille ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    24.01.2012
    Beiträge
    5
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo Voxe,
    ja, das haben wir gemacht!
    Siehst du links oben im Bild (zwei Eingänge und einen Ausgang).


    Wenn wir die Ein/-Ausgänge vom Koppler "anklickern", stehen uns keine Variablen zur Verfügung.
    config ohne.JPGconfig.JPG

  9. #8
    Registriert seit
    17.03.2011
    Ort
    im Wald
    Beiträge
    284
    Danke
    11
    Erhielt 36 Danke für 35 Beiträge

    Standard

    Hallo,

    ihr müsst in der PLC schon Variablen angelegt haben um diese mit der Hardware verknüpfen zu können.

    Gruß, Voxe

  10. #9
    hille ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    24.01.2012
    Beiträge
    5
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Moin,
    wir bekommen die Variablenverbindung im TwinCat Manager und PLC zwischen den I/Os derBusklemme, den I/Os der SPS Klemmen und der I/O Parametrierung des Roboters immernoch nicht hin .

    Wie müssen wir die Variablen Verknüpfung vornehmen und was müssen wir dabei beachten?Für Beispiele oder Unterlagen zu Thema TwinCat/Variablenverknüpfung/... wären wir dankbar!!!


    Der Roboter hat nach den vorgenommenen Einstellungen keine Fehlermeldung und erkennt diedigitalen I/Os des DeviceNet- Kopplers im Telnet.Außerdem ist die Hardware korrekt angeschlossen (die RUN LED und die MSN LED leuchten durchgehend grün "Zustand der EtherCAT State Machine: OP = normaler Betriebszustand; Mailbox- und Prozessdatenkommunikation ist möglich" bzw "Master ist online und kommuniziert mit den konfigurierten Slaves")

    vorgenommene Roboter Einstellungen
    (MacID 0, 500kBaud)
    [DEVNET]
    INB0=5, 0, x1 ;$IN[1-8]
    INB1=5, 1, x1 ;$IN[9-12]
    OUTB0=5, 0, x1 ;$OUT[1-8]
    OUTB1=5, 1, x1 ;$OUT[9-12]

    Telnet Info des Roboters:
    DN2DRV Version: 1.21.0.0
    Scanner enable: running
    Scanner State: ok
    CAN Errors: 0
    CAN OverFlow: 0
    SystemTime: 842211
    Baudrate: 500 KBaud
    [00] RKC State 00 Master none
    Vendor 0000 ProdType 0000 ProdCode 0000
    Revision 0000 Produce 0000 Consume 0000
    SerNum 00000000 ProdName
    I:
    O:
    [05] Warn 4 State 00 30:30:00 running online
    Vendor 0108 ProdType 0012 ProdCode 6752
    Revision 0302 Produce 0008 Consume 0008
    SerNum 00000000 ProdName BECKHOFF EL6752-0010
    I: 00 00 00 00 00 00 00 00
    O: 00 00 00 00 00 00 00 00
    value = 1 = 0x1



    Beckhoff EL 6752- 0010
    (MacID 5, 500kBaud)
    EtherCat Koppler EK 1100
    1. Eingangskarte EL 1014 77.0-77.3
    2. Eingangskarte EL 1014 77.4-77.7
    3. Eingangskarte EL 1014 78.0-78.3
    1. Ausgangskarte EL 2004 63.0-63.3
    2. Ausgangskarte EL 2004 63.4-63.7
    3. Ausgangskarte EL 2004 64.0-64.3

    gruß
    Geändert von hille (15.02.2012 um 09:52 Uhr)

Ähnliche Themen

  1. Sync.-Nachricht in TwinCAT
    Von Dave86 im Forum CODESYS und IEC61131
    Antworten: 1
    Letzter Beitrag: 03.04.2011, 16:47
  2. DeviceNet Master eds File
    Von Tapio Bearking im Forum Feldbusse
    Antworten: 2
    Letzter Beitrag: 07.07.2008, 09:05
  3. 12pol. DC IN/SYNC - Buchse
    Von IBN_Christian im Forum Elektronik
    Antworten: 0
    Letzter Beitrag: 21.05.2007, 08:23
  4. MP370 Active Sync...
    Von Jochen Kühner im Forum HMI
    Antworten: 5
    Letzter Beitrag: 06.10.2004, 10:47

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •