Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 9 von 9

Thema: Einschaltverzögerung mit TON

  1. #1
    Registriert seit
    03.02.2012
    Beiträge
    10
    Danke
    5
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,
    möchte eine einfache Einschaltverzögerung mit dem Baustein "TON" realisieren.
    Vll kann mir jemand einen Tipp gben was ich falsch mache?

    An "IN" und "Q" liegen boolsche Variablen. Wenn ich das ganze nun starte (z.B. Simulation) zählt "ET" nicht hoch.
    Das sollte es doch oder?
    Wenn ich das richtig verstanden habe wird der Ausgang "Q" auf "TRUE" gesetzt wenn "IN" "True" ist und die Zeit "ET" = "PT" ist.
    Bei mir tut sich da aber nichts. Bin eingeloggt und das Programm läuft.

    timer.JPG
    Zitieren Zitieren Einschaltverzögerung mit TON  

  2. #2
    Registriert seit
    14.08.2004
    Beiträge
    824
    Danke
    45
    Erhielt 73 Danke für 66 Beiträge

    Standard

    Q wird um 1s zeitverzögert True, wenn der Eingang von False auf True geht. Bedingung dafür ist, dass der FB auch regelmässig ausgeführt wird.

  3. Folgender Benutzer sagt Danke zu drfunfrock für den nützlichen Beitrag:

    miller007 (20.02.2012)

  4. #3
    Registriert seit
    12.05.2010
    Ort
    Dortmund
    Beiträge
    889
    Danke
    57
    Erhielt 121 Danke für 89 Beiträge

    Standard

    ist die PLC in RUN (steht unten rechts)?
    wird das Programm durchlaufen/bearbeitet?
    Weil Denken die schwerste Arbeit ist, die es gibt, beschäftigen sich auch nur wenige damit.

  5. #4
    miller007 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    03.02.2012
    Beiträge
    10
    Danke
    5
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Jetzt klappt es! Danke für den Hinweis...
    Der Eingang muss somit negiert sein, damit es funktioniert.

  6. #5
    miller007 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    03.02.2012
    Beiträge
    10
    Danke
    5
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Moment...
    Etwas zu früh gefreut

    Mit der Negation am Eingang zählt "ET" jetzt wunderschön hoch, aber warum klappt es nicht wenn ich den Eingang händisch auf "TRUE" setzte?

    @rheumakay: ja, die PLC ist im RUN und Nein, das Programm wird nicht durchlaufen.

    Will zunächst nur die Funktionen kennenlernen und experimentieren...

  7. #6
    Registriert seit
    12.05.2010
    Ort
    Dortmund
    Beiträge
    889
    Danke
    57
    Erhielt 121 Danke für 89 Beiträge

    Standard

    vielleicht habe ich micht nicht richtig ausgedrückt..
    der Baustein indem dein Timer sich befindet...wird der zyklisch bearbeitet (befindet der sich im PLC_PRG oder wird der Baustein entsprechend aufgerufen)?
    zum kennen lernen des Bausteins: auf den Baustein klicken und F1 drücken...
    Weil Denken die schwerste Arbeit ist, die es gibt, beschäftigen sich auch nur wenige damit.

  8. #7
    Registriert seit
    12.05.2010
    Ort
    Dortmund
    Beiträge
    889
    Danke
    57
    Erhielt 121 Danke für 89 Beiträge

    Standard

    im übrigen ist die Variable auf deinem Screenshot nicht geforct..noch mal F7 drücken...
    Weil Denken die schwerste Arbeit ist, die es gibt, beschäftigen sich auch nur wenige damit.

  9. #8
    miller007 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    03.02.2012
    Beiträge
    10
    Danke
    5
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Der TON-Baustein befindet sich nicht in der PLC_PRG, sondern wird hier nur aufgerufen. Ich habe unter "Bausteine" ein weiteres Objekt eingefügt.

  10. #9
    Registriert seit
    12.05.2010
    Ort
    Dortmund
    Beiträge
    889
    Danke
    57
    Erhielt 121 Danke für 89 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    na dann mußt du den neuen Baustein im PLC_PRG aufrufen, sonst wird der doch nicht zyklisch bearbeitet!!!
    Weil Denken die schwerste Arbeit ist, die es gibt, beschäftigen sich auch nur wenige damit.

  11. Folgender Benutzer sagt Danke zu rheumakay für den nützlichen Beitrag:

    miller007 (20.02.2012)

Ähnliche Themen

  1. Einschaltverzögerung mit FPWIN GR
    Von sachse im Forum Sonstige Steuerungen
    Antworten: 1
    Letzter Beitrag: 18.12.2010, 13:30
  2. Antworten: 16
    Letzter Beitrag: 03.09.2010, 22:00
  3. Einschaltverzögerung TON
    Von plischke im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 13.07.2010, 22:02
  4. Warnlampe starten mit Einschaltverzögerung?
    Von siemens-s7 im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 27.03.2010, 23:07
  5. Antworten: 9
    Letzter Beitrag: 28.06.2007, 15:17

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •