Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 10 von 10

Thema: Fliegende Säge Beckhoff - zu geringe Dynamik

  1. #1
    Registriert seit
    24.02.2012
    Beiträge
    12
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Leute

    Ich bin dabei eine Fliegende Säge mit Beckhoff (AX5000) zu realisieren. Dabei soll ein Greifer (Slave) Werkstücke von einem Band (Master) abnehmen, die Synchronisierung erfolgt über die FB GearInPos.
    Dabei tritt aber folgendes Problem auf: Ist der Weg zwischen Greifer und Synchronpos kurz genug, funktionit es tadellos, wird der Weg jedoch länger und die Achse müsst stärker beschleunigen und eine höhere Geschw. fahren, wird Aufgrund eines Schleppfehlers abgebrochen. Die Beschleunigung und Geschwindigkeit liegen aber weit unterhalb dem, was die Achse verfahren könnte (mit MoveAbsolute kann ich die Beschl. und Geschw. deutlich steigern). Ich habe auch schon versucht im SyncMode die Begrenzungen zu aktivieren bzw. die OpMask zu ändern - leider ohne Erfolg.

    mfg Edwin
    Zitieren Zitieren Fliegende Säge Beckhoff - zu geringe Dynamik  

  2. #2
    Registriert seit
    14.08.2004
    Beiträge
    824
    Danke
    45
    Erhielt 73 Danke für 66 Beiträge

    Standard

    Versuchst du eine zu hohe Masse zu stark zu beschleunigen?

  3. #3
    Edwin1966 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    24.02.2012
    Beiträge
    12
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo

    An zu hoher Masse liegt es sicher nicht, ich kann mit dem MoveAbsolut Befehlt 2,1m/s mit 6m/s² Beschleunigung fahren. Beim Synchronisieren schafft er aber grade mal 0.1m/s und die Beschleunigung merkt man fast nicht, so gering wie diese ist.

    mfg

  4. #4
    Registriert seit
    19.11.2006
    Beiträge
    1.346
    Danke
    6
    Erhielt 254 Danke für 231 Beiträge

    Standard

    Schau mal nach ob dir die Beschleunigungsrampe im AX5000 (Geschwindkeitsregler) vielleicht nen Strich durch die Rechnung macht. Wenn du die Dynamik eh durch die NC begrenzt, kannste diese Rampen ("Ramp+ / Ramp-", glaube ich) auch auf Maximalwerte setzen.

    Nimm mal nen Scope auf und schau in welcher Phase der Bewegung der Schleppfehler auftritt. Vielleicht liegt's auch an einer zu gering parametrierten Maximalgeschwindigkeit.

  5. #5
    Edwin1966 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    24.02.2012
    Beiträge
    12
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hy

    Danke für die Antwort, die Rampen muss ich erst überprüfen, aber hätten diese nicht auch Auswirkungen auf eine Bewegung mit MoveAbsolute?
    Die Geschwindigkeit ist mit 2105mm/s sicher groß genug gewählt. Der Schleppfehler tritt während der Synchronisierungsphase auf, die Achse versucht zu Beschleunigen, kann aber Aufgrund irgendeiner Begrenzung die geforderte Geschwindigkeit bzw. Beschleunigung nicht erreichen und es kommt zum Schleppfehler.

    mfg

  6. #6
    Registriert seit
    17.08.2010
    Ort
    Blaichach
    Beiträge
    84
    Danke
    1
    Erhielt 9 Danke für 9 Beiträge

    Standard

    Kommt der Schleppfehler evtl. von eine unstetigkeit beim Koppeln auf die Säge? -> Schau mal mit dem ScopeView in den NC Daten die Soll Pos, Velo, Acc an. (Geht auch mit Simulationsachsen - das freut den Machaniker... )

    Wenn Du da einen "sprung" hast liegt das Problem beim Koppeln.

    Bin mir ziemlich sicher das es in diese Richtung geht, weil mit MoveAbsolut geht der Antrieb ja...


    Gruß Bernd


    Viel Glück...
    Real programmers don’t comment their code. It was hard to write, it should be hard to understand.

  7. #7
    Edwin1966 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    24.02.2012
    Beiträge
    12
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hy

    Sprung sehe ich keinen, steigt alles schön langsam und kontinuierlich an. Der Schleppfehler steigt aber genauso langsam an und erreicht dann den max. Wert -> Schleppfehler.
    Ich glaube, der Schleppfehler ist nur eine Folgeerscheinung, da ich ja nur eine sehr geringe Beschleunigung habe, denke ich, das Problem liegt an irgendeiner Begrenzung.


    mfg

  8. #8
    Registriert seit
    17.08.2010
    Ort
    Blaichach
    Beiträge
    84
    Danke
    1
    Erhielt 9 Danke für 9 Beiträge

    Standard

    Hmm... Ist die Achse Enabled? - Hab jetzt kein System hier zum spicken - gibts da nen Override? (das hat mich bei NCI Anwendungen schon mal überlistet)

    Maximalweg (Softwareendlage) könntest auch noch schauen...

    Gruß Bernd
    Real programmers don’t comment their code. It was hard to write, it should be hard to understand.

  9. #9
    Edwin1966 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    24.02.2012
    Beiträge
    12
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hy

    Was genau meinst du mit Enabled? Die Achse ist bereit und fährt ja auch, nur Geschw. und Beschl. werden begrenzt.
    Softwareend ist in jede Richtung ca. 2000 mm entfernt, also genug weg.
    Override der Achse Slave steht bei 100% (im Systemmanager), oder sieht man das bei PTP-Achsen woanders (FB)?

    mfg

  10. #10
    Edwin1966 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    24.02.2012
    Beiträge
    12
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hy Leute

    Im Anhang sind zwei Scope-Bilder:
    saw: geringer Abstand - kein Fehler
    saw_fehler: zu großer Abstand - Schleppfehler
    Man sieht auch, dass die Beschleunigung sehr gering ist.

    mfg
    Angehängte Grafiken Angehängte Grafiken

Ähnliche Themen

  1. Antworten: 20
    Letzter Beitrag: 22.08.2010, 21:14
  2. TC NC PTP - universelle fliegende Säge
    Von Kurt im Forum CODESYS und IEC61131
    Antworten: 4
    Letzter Beitrag: 24.01.2010, 16:54
  3. Fliegende Säge mit Indramat Servo-Umrichter
    Von Joe im Forum Antriebstechnik
    Antworten: 4
    Letzter Beitrag: 14.02.2009, 21:08
  4. fliegende säge mit fm357-2 oder tcpu?
    Von Markus im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 03.12.2007, 10:23
  5. bandsynchronlauf + fliegende säge
    Von Markus im Forum Programmierstrategien
    Antworten: 8
    Letzter Beitrag: 13.01.2006, 22:25

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •