Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 3 von 3

Thema: CodySys Werte nicht angezeigt!

  1. #1
    Registriert seit
    31.10.2005
    Beiträge
    116
    Danke
    10
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo SPS'ler,

    versuche mit CodeSys Werte aus dem Energiezähler auszulesen mit Modbus Kommunikation.
    Es sind mehrer Eingänge vorhanden die die Werte liefern:

    WERT_1
    Register 000 Status (16 Bit INT)
    001 und 002 Messwert (32 Bit -Float HByte, LByte)

    WERT_2
    Register 003 Status
    004 und 005
    -----
    -----

    Verwende COM_MAST_ Baustein mit ARRAY [1..10] OF LWORD
    Beim WERT_1 lösche ich den Status mit SHL (um 32 Bit) dann
    LWORD_TO_DWORD
    und schreibe auf VAR_WERT_1.
    Leider habe ich dann den Wert 0 ?? was ist hier falsch!


    Fragende Grüße
    Ricko

    Zitieren Zitieren CodySys Werte nicht angezeigt!  

  2. #2
    Registriert seit
    01.03.2008
    Beiträge
    487
    Danke
    3
    Erhielt 43 Danke für 39 Beiträge

    Standard

    ????

    benutz du die mobus lib? Ließ man Zähler nicht mit der MBus aus (nicht MODBUS) ?

    Zeig am besten mal dein PRG...

    MfG CAS
    www.cas-solution.de

    Alles geregelt...


    Weltraumflug in den USA zu gewinnen!
    Kratze hier ▒▒▒▒▒▒▒▒▒▒▒▒ mit einer Münze,
    und finde heraus, ob Du der Gewinner bist!

  3. #3
    Ricko ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    31.10.2005
    Beiträge
    116
    Danke
    10
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo CAS,

    VAR_DEF_Online.JPGPRG_Offline.JPGPRG_Online.JPGVAR_DEF_Offline.JPGanbei das Programm (PRG) online/offline




    Die Skalierung ist nicht richtig!

    WERT_1 0..20mA, Bereich 0..100% wurde gespeist mit ca.6mA!

    Grüße
    Ricko

Ähnliche Themen

  1. PG/PC Schnittstelle wird nicht angezeigt
    Von Gruber im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 07.01.2012, 09:18
  2. CPU wird nicht angezeigt
    Von Erdferkel im Forum Simatic
    Antworten: 12
    Letzter Beitrag: 25.05.2009, 15:27
  3. Querverweise nicht angezeigt
    Von ASrip85 im Forum Simatic
    Antworten: 7
    Letzter Beitrag: 05.09.2008, 19:39
  4. DB-Aktualwert wird nicht angezeigt
    Von spitfire im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 26.09.2007, 09:45
  5. Eingänge werden in NW nicht angezeigt
    Von fr4nk im Forum Simatic
    Antworten: 25
    Letzter Beitrag: 05.04.2006, 14:51

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •