Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 3 von 3

Thema: seltsames Verhalten von Programmteilen (TwinCAT)

  1. #1
    Registriert seit
    09.01.2008
    Beiträge
    85
    Danke
    5
    Erhielt 13 Danke für 12 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Leute,

    ich hab da ein Problem mit einem Programm. Es handelt sich um ein recht umfangreiches Programm mit bis zu 12 Bearbeitungsstationen inkl Displays und Transfersystem.Das Programm läuft seit ca. 2 Jahren problemlos und hier und da werden Änderungen vorgenommen. Nun habe ich das Verhalten, dass wenn ich einem Baustein eine simple Programmzeile (z.B. 'OR TRUE') lösche, ein anderer Programmbaustein nicht mehr funktioniert. Eine Schrittkette blieb z.B. vor einer Transition in der 'TRUE' stand einfach stehen. In einem anderen Baustein funktionierte plötzlich die kommunikation mit einem Gerät nicht mehr, obwohl das damit nichts im geringsten zu tun hatte.
    Auch die Funktion "Alles übersetzen" brachte keine Abhilfe, erst mit "Alles bereinigen" mit anschließenden Übersetzen brachte den Erfolg, dass das Programm wieder ordnungsgemäß lief. Als ich dann erneut wieder eine kleine Änderung des Programms vorgenommen hatte, trat der gleiche Effekt wieder auf. Was ist das? Was bewirkt eigentlich "Alles bereinigen" Überlappende Speicherbereiche gibt es auch nicht und das Mapping wurde ebenfalls nicht verändert. CheckBounds sind ebenfalls eingebunden.

    hat jemand von Euch eine Idee?

    Gruß Scrat
    Zitieren Zitieren seltsames Verhalten von Programmteilen (TwinCAT)  

  2. #2
    Registriert seit
    11.07.2004
    Beiträge
    1.597
    Danke
    10
    Erhielt 213 Danke für 183 Beiträge

    Standard

    Ein Online-Change in Verbindung mit Ablaufsteuerung ist meiner Meinung nach Glücksache bei Codesys.

  3. #3
    Registriert seit
    17.03.2011
    Ort
    im Wald
    Beiträge
    284
    Danke
    11
    Erhielt 36 Danke für 35 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    das riecht nach einer doppelten Namensvergabe der Variablen. Bzw. ein Variablenname (irgendwo) hat den Namen einer Transition deiner AS-Ketten. Das ist dumm und schwer zu finden. Das System, kann das nicht unterscheiden.

    Da, hast du eine grosse Suche vor dir.

    Gruß, Voxe

Ähnliche Themen

  1. Hilfe: seltsames Verhalten einer 1200er...
    Von monaco86 im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 10.03.2012, 14:46
  2. S5 seltsames Verhalten in Kopierschleife
    Von Lars Weiß im Forum Simatic
    Antworten: 12
    Letzter Beitrag: 04.04.2011, 08:26
  3. Seltsames Verhalten von Kübler Drehgeber
    Von ssound1de im Forum Elektronik
    Antworten: 4
    Letzter Beitrag: 26.07.2010, 12:52
  4. S5 Set Reset seltsames Verhalten.
    Von Aksels im Forum Simatic
    Antworten: 28
    Letzter Beitrag: 17.11.2008, 07:09
  5. Antworten: 1
    Letzter Beitrag: 03.05.2006, 13:37

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •