Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 7 von 7

Thema: Beckhoff Analogklemme

  1. #1
    Registriert seit
    06.05.2013
    Beiträge
    2
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Guten Tag,
    mit einem Buskoppler 9050 (Ethernet) verwende ich eine Analogklemme Kl 3404.
    Diese ist spezifiziert mit +-10V / 12 bit und 0,3% Genauigkeit.
    Wenn ich einen Eingang dieser Klemme mit einer Konstantspannung (Batterie) belege,
    dann springt mit jeder Messung der Messwert in etwa +- 30 mV.
    Schließe ich einen externen Messwertgeber an, dann springt dieser Wert im Bereich von
    etwa 40 mV. Mir ist schon klar das man systembedingt keinen "ruhigen" Messwert erwarten kann.
    Die nachfolgende Glättung erfolgt mit dem Algorithmus MW := ((MW * Zeit) + Wert neu)/ Zeit + 1,
    Hat wer einen Tip zu der Baugruppe und kann mir sagen, ob das Verhalten normal ist?
    Für einen Tip dankbar.

    Gruß Peter
    Zitieren Zitieren Beckhoff Analogklemme  

  2. #2
    Registriert seit
    19.06.2003
    Beiträge
    2.200
    Danke
    85
    Erhielt 259 Danke für 175 Beiträge

    Standard

    Dass der Wert sich von Wandlung zu Wandlung ändert ist erstmal nicht ungewöhnlich, aber die Größenordnung sollte 20V/(2^11) =10mV sein. Oder anders gesagt, deine 30mV sind schon 3 Bit. Sind in der Nähe hochfrequente Störquellen? Probiere:
    1) Kurze Leitungen von der Batterie zur Klemme, verdrillt oder abgeschirmt. 2) Einen (Keramik-)Kondensator direkt parallel zum Eingang. 3) Einen (Keramik-)Kondensator vom Eingang zur Betriebserde. 4) Eine andere Klemme

  3. #3
    Registriert seit
    24.02.2009
    Beiträge
    1.242
    Danke
    23
    Erhielt 276 Danke für 235 Beiträge

    Standard

    +- 30mV sind bei dieser Klemme der Messfehler (+-0,3% vom Messbereichsendwert).

  4. #4
    Registriert seit
    19.06.2003
    Beiträge
    2.200
    Danke
    85
    Erhielt 259 Danke für 175 Beiträge

    Standard

    Die 0.3% Genauigkeit würde ich so verstehen, dass die 10V Endwert auch 9,97 oder 10,03 sein können. Auch jeder Wert dazwischen kann mit diesem Fehler behaftet sein, aber immer gleich, nicht von Wandlung zu Wandlung schwankend.

  5. #5
    Registriert seit
    09.08.2006
    Beiträge
    3.629
    Danke
    912
    Erhielt 656 Danke für 542 Beiträge

    Standard

    Zitat Zitat von Zottel Beitrag anzeigen
    Dass der Wert sich von Wandlung zu Wandlung ändert ist erstmal nicht ungewöhnlich, aber die Größenordnung sollte 20V/(2^11) =10mV sein. Oder anders gesagt, deine 30mV sind schon 3 Bit.
    Irgendwann gabs doch hier schonmal ne Diskussion über die Wertigkeit der Bits... Ich kann mich zwar nicht mit Beckhoff aus... aber evtl. gibt's noch nen Übersteuerungsbereich bzw. sonstiges was den Bereich des AD-Wandlers bestimmt... bzw. wie der genau funktioniert ist ja eher Spekulation.

    trotzdem hätte ich auch auf ein Toggeln des AD-Wandlers um +/- ein Wandlungsinkrement getippt...

    Gruß.

  6. #6
    Registriert seit
    19.06.2003
    Beiträge
    2.200
    Danke
    85
    Erhielt 259 Danke für 175 Beiträge

    Standard

    Erstmal muß ich meine eigene Rechnung korrigieren, ich habe ja mit 11Bit für die 20V von -10V bis +10V gerechnet, es sind aber 12. Es muß also heißen: 20V/4096=5mV.

    Zitat Zitat von ducati Beitrag anzeigen
    Ich kann mich zwar nicht mit Beckhoff aus... aber evtl. gibt's noch nen Übersteuerungsbereich
    Nein, gibt es nicht: -10V=-32768=0x8000, +10V=32767=0x7FFF

    Zitat Zitat von ducati Beitrag anzeigen
    trotzdem hätte ich auch auf ein Toggeln des AD-Wandlers um +/- ein Wandlungsinkrement getippt...
    Aber ein Inkrement wären halt nur 5mV...

  7. Folgender Benutzer sagt Danke zu Zottel für den nützlichen Beitrag:

    ducati (06.05.2013)

  8. #7
    peter76774 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    06.05.2013
    Beiträge
    2
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Also starke magnetische Felder sollte es hier nicht geben.
    Die Steuerung liegt bei mir daheim auf dem Schreibtisch und wird von einem Labornetzteil gespeist.

    Bei 1,5 V Batterie als Spannungsquelle habe ich die Messungen mal aufgezeichnet:
    1,58 1,54 1,61 1,57 1,59

    Zumindest bei einem Eingang werde ich wohl auf 16 bit Eingang wechseln müssen. Hier hängt ein analoger Weggeber mit 1m Verfahrweg dran.
    Vorgabewert 297 mm.
    gemessene Werte pro Abfragezyklus 29,700 29,670 29,730 29,670 29,780 29,790 29,800

    Gruß
    Peter

Ähnliche Themen

  1. Analogklemme Beckhoff KL3002 über CAN ansprechen
    Von Deutschland_Sued im Forum CODESYS und IEC61131
    Antworten: 1
    Letzter Beitrag: 01.07.2010, 19:05
  2. Beckhoff
    Von Ralf44 im Forum Suche - Biete
    Antworten: 0
    Letzter Beitrag: 03.04.2009, 15:05
  3. Beckhoff
    Von s.leuschke im Forum Stammtisch
    Antworten: 7
    Letzter Beitrag: 06.10.2008, 18:50
  4. beckhoff
    Von lister67 im Forum Sonstige Steuerungen
    Antworten: 16
    Letzter Beitrag: 17.03.2007, 15:37
  5. Beckhoff
    Von Wilhelm im Forum Sonstige Steuerungen
    Antworten: 0
    Letzter Beitrag: 06.09.2005, 00:17

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •