Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 10 von 10

Thema: CX1100 mit BC9000 verbinden

  1. #1
    Registriert seit
    28.05.2013
    Ort
    Oldenburg
    Beiträge
    5
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen,

    da ich mir einfach nicht mehr weiter helfen kann, muss ich es jetzt bei euch probieren. Ich hoffe das mir jemand weiter helfen kann.
    Und zwar habe ich im Haus eine CX1100 laufen, und in der Garage (über Ethernet angebundene) einen BC9000.

    Ich habe ein Projekt, wo die CX als Zielsystem läuft. Ein Programm läuft auch darauf. Soweit alles okay. Dann habe ich vor kurzem die BC hinzugefügt.

    RT-Ethernet->Box anfügen (BK9000.. BC soll ja auch funktionieren) -> IP eingetragen -> Klemmen scannen (funktioniert!)

    Ich dachte ich habe alles richtig gemacht, denn die Box wird ja gefunden und kann auch gescannt werden. Nun ist es so, wenn ich mir die Ein oder Ausgänge live schalte oder verfolge, dann passiert gar nichts.

    Wenn ich nun allerdings unter der Box -> Eingänge -> BoxState schaue, wird mir eine 0x0005 angezeigt. Was ja anscheinend auf "Keine Kommunikation" hinweist.

    Was mich auch wundert, dass auf der BC selber die LED für I/O Run gar nicht leuchtet. Die sollte doch an sein, oder?

    Da ich das Netzwerkkabel erst neu gezogen habe, aber er die Box findet, und ich sie auch anpingen kann, gehe ich davon aus, dass dies nicht die Fehlerquelle ist.

    Kann mir jemand helfen?

    Beste Grüße
    Kevin
    Zitieren Zitieren CX1100 mit BC9000 verbinden  

  2. #2
    Registriert seit
    28.05.2013
    Ort
    Oldenburg
    Beiträge
    5
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Okay, da noch keiner direkt geantwortet hat, frage ich mal andersrum.

    Wenn ich ein Gesamtprojekt (CX1100+BC9000) habe, und ich dann das Programm in den CX jage. Wird dann auch der BC als Buskoppler eingerichtet? Wenn ich mir das mit der LED I/O Run ansehe, scheint es fast so, als würde der immer noch so "dumm" wie vorher sein.

    Muss ich (außer die IP) noch etwas anderes beachten, damit der BC auch als BK läuft? Der muss doch sicher irgendwie auf diesen Modus programmiert werden.

  3. #3
    Registriert seit
    17.03.2013
    Beiträge
    2
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo,

    habe ein ähnliches Problem mit einem CX1100 und einem BC9120.
    Habe im System Manager den BC auch als Virtual Ethernet (als BK9100) eingefügt. Klemmen scannen hat funktioniert.
    Habe dann ein Projekt angelegt:

    PROGRAM MAIN
    VAR
    IN1 AT %I* : BOOL;
    OUT1 AT %Q* : BOOL;
    END_VAR

    Im Code dann OUT1 = IN1.

    Verknüpfe ich im System Manager Variablen des CX funktioniert es, nehme ich welche von BC geht es nicht mehr.

    BoxState ist OK.


    Ist das evtl das gleiche Problem? Ist diese Zusammenstellung so überhaupt möglich?

    Gruß
    Stefan
    Zitieren Zitieren CX1100 und BC9120  

  4. #4
    Registriert seit
    01.04.2009
    Beiträge
    143
    Danke
    0
    Erhielt 30 Danke für 29 Beiträge

    Standard

    Statt RT Ethernet nimm bitte die virtuelle Ethernet Schnittstelle, die BC9xxx unterstützen kein RT Ethernet, das wird es wohl sein...
    Gruß

  5. #5
    Registriert seit
    29.10.2012
    Beiträge
    5
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo Spoosie

    Ich kann es dir so erklären, wie ich es gemacht habe. Bei mir habe ich einen CX1010 im Haus mit dem ich 2 BC9000 per ADS anspreche. So weit ich weiss, kannst du den BC9000 nicht als BK9000 umfunktionieren. Den BK9000 kannst du im SM direkt einscannen und wie bei stevienull direkt mit dem SPS Projekt verknüpfen. Beim BC9000 kannst du nur über die SPS Variablen (Unter BOX1"BC9000") eine Verknüpfung zu dem SPS Projekt erstellen. Wenn es irgendwie möglich ist und du keine separate Logik in deiner Garage brauchst, nimm einen BK9000, diese sind von der Handhabung einiges einfacher. Wenn dies nicht möglich ist geht es auch mit dem BC9000, ist aber einfach etwas komplizierter. Da du das ganze im SM so ja nur auf einem PC einrichten kannst musst du folgendermassen vorgehen um zwischen BC und CX zu kommunizieren:


    Das ganze läuft über ADS. also musst du auf deinem CX erst einmal den Route hinzufügen.

    1. Über Cerhost auf den CX, dann mit dem Explorer auf Harddisk System dann RemoteMGR. Dort kannst du durch Route hinzufügen deinen BC9000 eintragen. Wichtig!! IP und ADS-Net ID sollen die selbe sein.
    2. Dann kannst du die Funktionen ADS READ WRITE Bausteine aufrufen. Im TC PLC sind diese glaube ich in den Untility Libarys (Ich muss nochmals nachschauen) Mit diesen Funktionsbausteinen dann bei READ und Write die AMS Net ID etc. eintragen. Wichtig! Verwende beim OFFSET den Merkerbereich 0x00004020. ¨
    3. Dann musst du noch bei deinem BC9000 die Merkerbereiche Deklarieren. Also AT %M*XY
    4. Die abwechselnden READ und Writebefehle kannst du in einem CASE aufrufen um so immer wieder die Daten zu lesen und schreiben.
    5. Bei einem Neustart des CX1100 sollte die Kommunikation dann automatisch starten.

    Ich hoffe ich habe dicht nicht zu überfordert .Wenn du willst, kann ich dir noch ein kleines Beispielprogramm senden.

    MFG MD 52

  6. #6
    Registriert seit
    28.05.2013
    Ort
    Oldenburg
    Beiträge
    5
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Moin,

    danke.. das war genau das Problem. Also erst einmal musste ich eine virtuelle Schnittstelle nehmen. Und dann musste ich die gescannten Klemmen (automatisch erkannt durch das "Boxen scannen"/ wo ein PLC Logo im Icon war) von Hand löschen, und nochmal die Klemmen scannen.. das PLC im Icon war weg, und erst DANN konnte ich darauf zugreifen.

    Ein Kollege hat mir geholfen, und darauf soll mal ein Newbie kommen. Üble Geschichte..

    Aber Danke nochmal für den Hinweis

  7. #7
    Registriert seit
    02.03.2015
    Beiträge
    2
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo zusammen,

    ich versuche einen BC9000 mit einer CX1010 zu verbinden. CX für die Hausautomation und der BC in die Garage. Ebenfalls über Lan angebunden.
    Ich habe versucht mich an dieser Anleitung entlang zu hangeln, aber ich habe auf meiner Karte den RemoteMGR nicht. Ich hab mal ein neues Image für den CX von der FTP-Seite von Beckhoff gezogen, aber da ist dieser RemoteMGR ebenfalls nicht drauf...
    Kann es sein, dass der CX das so nicht kennt? In der Config-Visu des CX ist unter dem Menüpunkt Twincat das einbinden von TwinCAT Routes möglich. Ist das evtl. das Gleiche??? Wenn nicht, wie kann ich es trotzdem irgendwie realisieren?

    Ich hoffe das das hier überhaut noch jemand liest, der Beitrag ist ja schon ein paar Tage alt...


    Grüße von der Mosel

    Christian
    Geändert von chris1075 (02.03.2015 um 12:52 Uhr) Grund: Info hizugefügt

  8. #8
    Registriert seit
    28.05.2013
    Ort
    Oldenburg
    Beiträge
    5
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hi Christian,

    ja, das ist genau das gleiche. Einfach die Route eintragen. Und weiter probieren.

    Gruß
    Kevin

  9. #9
    Registriert seit
    02.03.2015
    Beiträge
    2
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hi Spoosie,

    vielen Dank für die superschnelle Antwort!
    Ich versuchs dann weiter!
    Es scheint bei dir, so wie ich das interpretiere, so zu funktionieren, kann ich mich bei Problemen nochmal an die wenden? Du hast ja die gleiche Konstellation wie ich...

    Christian

  10. #10
    Registriert seit
    28.05.2013
    Ort
    Oldenburg
    Beiträge
    5
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Schreib mir ne Mail.. kevinheidrich at me punkt com

Ähnliche Themen

  1. Beckhoff BC9000 mit VB.net
    Von paul1010 im Forum CODESYS und IEC61131
    Antworten: 2
    Letzter Beitrag: 04.04.2015, 11:00
  2. cx1100 Slave / PC Master
    Von Hitschkock im Forum CODESYS und IEC61131
    Antworten: 4
    Letzter Beitrag: 09.12.2009, 08:59
  3. Emails versenden mit BC9000??
    Von TomCatShS im Forum CODESYS und IEC61131
    Antworten: 16
    Letzter Beitrag: 25.10.2009, 10:48
  4. ? Menüführung CX1000 Text Diplay CX1100-0002
    Von mbaum im Forum CODESYS und IEC61131
    Antworten: 0
    Letzter Beitrag: 19.08.2009, 11:14
  5. Abfrage ob CX1100-0002 gestartet hat???
    Von wolfi999 im Forum CODESYS und IEC61131
    Antworten: 9
    Letzter Beitrag: 05.02.2009, 15:22

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •