Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 3 von 3

Thema: SoE-Parameter zum Prozessabbild hinzufügen (Rexroth CS an TwinCAT 2)

  1. #1
    Registriert seit
    15.02.2011
    Ort
    Stromness, Scotland, UK
    Beiträge
    339
    Danke
    25
    Erhielt 34 Danke für 33 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen, ich brauche wieder einmal eure Hilfe. Und zwar möchte ich von einem Rexroth CS Umrichter einige Sercos-Parameter (Wie der P-0-0383 Motortemp oder S-0-106 Zustand STO/SBC) dem Prozessabbild hinzufügen. Der Umrichter selbst und die Anbindung an die NC funktionieren problemlos.

    Ich habe versucht, die zusätzlichen Werte im S-0-0016/24 auf dem Antrieb hinzuzufügen. Diese erscheinen dann auch über SoE-Online im Systemmanager. Sobald ich jedoch EtherCAT wieder auf OP stelle, sind die zusätzlichen Werte weg… Gleiches habe ich im Systemmanager versucht, auch hier verschwinden die Werte beim hochschalten.

    Ich habe dies vor einem Jahr auch schon hingebracht, und ich möchte nicht auf die FBs ausweichen, sondern die Werte im Systemmanager verlinken können!

    Vielen Dank für eure Hilfe, Gruess
    gloeru
    Zitieren Zitieren SoE-Parameter zum Prozessabbild hinzufügen (Rexroth CS an TwinCAT 2)  

  2. #2
    Registriert seit
    08.03.2013
    Beiträge
    5
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo,
    zunächst einmal erscheint mir dies als ein Problem von Beckhoff's System-Manager.

    Nichts desto trotz sollte Ihr Bosch Rexroth Vertrieb einen geeigneten Applikationsingenieur ausfindig machen.

    Ansonsten bietet sich der Drive-Support von Bosch Rexroth an: Drivesupport DC-IA/EDY2 (DC-IA/EDY2) drivesupport@boschrexroth.de
    Die Kollegen dort haben nicht nur Know-How im Umgang mit sercos, unserem Standardfeldbus für alles Antriebe, E/A, funktionale Sicherheit und alles was auf Standard-Ethernet basiert.
    Sie unterstützen auch bei EtherNet/IP, EtherCAT, Profinet und Profibus.

    Haben Sie sich schon mal überlegt komplett auf ein sercos-basiertes Automatisierungssystem zu schwenken?
    Hiier ist alles möglich von verschiedenen einfachen CoDeSys-basierten Systemen bis zur vollintegrierten Rexroth-Lösung mit IndraWorks.
    NC-Lösungen mit seros III sind verfügbar von Andron, Eckelmann, PrimaElectro, Rexroth, Schleicher s. http://www.sercos.de/steuerungen.

    Aber prüfen Sie erst mal den Service von Rexroth über die o.g. Wege. Sprechen Sie mich danach einfach nochmal an.

    Viele Grüße
    sercos-promoter

  3. #3
    Registriert seit
    19.11.2006
    Beiträge
    1.346
    Danke
    6
    Erhielt 254 Danke für 231 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von sercos-promoter Beitrag anzeigen
    Haben Sie sich schon mal überlegt komplett auf ein sercos-basiertes Automatisierungssystem zu schwenken?
    Hiier ist alles möglich von verschiedenen einfachen CoDeSys-basierten Systemen bis zur vollintegrierten Rexroth-Lösung mit IndraWorks.
    NC-Lösungen mit seros III sind verfügbar von Andron, Eckelmann, PrimaElectro, Rexroth, Schleicher s. http://www.sercos.de/steuerungen.
    ??? gloeru schreibt:
    Zitat Zitat von gloeru Beitrag anzeigen
    Der Umrichter selbst und die Anbindung an die NC funktionieren problemlos.
    Wieso sollte er dann auf Sercos umschwenken, wenn er TwinCAT mit EtherCAT am Start hat
    Btw. ist EtherCAT deutlich weiter verbreitet als Sercos ... aber das ist ne andere Sache.


    Zum Thema:
    Zitat Zitat von gloeru Beitrag anzeigen
    ... Und zwar möchte ich von einem Rexroth CS Umrichter einige Sercos-Parameter (Wie der P-0-0383 Motortemp oder S-0-106 Zustand STO/SBC) dem Prozessabbild hinzufügen. Der Umrichter selbst und die Anbindung an die NC funktionieren problemlos.

    Ich habe versucht, die zusätzlichen Werte im S-0-0016/24 auf dem Antrieb hinzuzufügen. Diese erscheinen dann auch über SoE-Online im Systemmanager. Sobald ich jedoch EtherCAT wieder auf OP stelle, sind die zusätzlichen Werte weg… Gleiches habe ich im Systemmanager versucht, auch hier verschwinden die Werte beim hochschalten.

    Ich habe dies vor einem Jahr auch schon hingebracht, und ich möchte nicht auf die FBs ausweichen, sondern die Werte im Systemmanager verlinken können!

    Vielen Dank für eure Hilfe, Gruess
    gloeru
    Zunächst sollte geprüft werden ob die zwei Parameter überhaupt im zyklischen Prozessabbild übertragen werden können. Das geht nicht mit allen, soweit ich weiß. ZB wenn es Werte sind die nur über die "Mailbox" des EtherCAT-Slaves abgefragt werden können.
    Siehst du denn eine Veränderung des S-0-0016 unter "Startup", wenn du per SoE-Online was änderst?
    Und wenn du über den Reiter "Prozessdaten" gehst? Passiert da was, bzw. kannst du da was an den Prozessdaten anpassen?
    Gibt's eine Fehlermeldung beim Aufstarten?

    Screenshots wären hilfreich.

Ähnliche Themen

  1. Prozessabbild
    Von toto45 im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 29.03.2013, 07:26
  2. TwinCat-Bibliothek zum Lesen eines Ethernet-Protokolls (sACN)
    Von Majestic_1987 im Forum CODESYS und IEC61131
    Antworten: 7
    Letzter Beitrag: 08.11.2012, 13:14
  3. Antworten: 15
    Letzter Beitrag: 11.09.2012, 14:59
  4. Eine Frage zum Prozessabbild
    Von anne im Forum Simatic
    Antworten: 12
    Letzter Beitrag: 12.11.2011, 12:58
  5. TwinCat-PLC-HMI Parameter speichern
    Von tisler im Forum CODESYS und IEC61131
    Antworten: 4
    Letzter Beitrag: 28.09.2009, 15:58

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •