Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 4 von 4

Thema: automatisch gestartet und das Projekt?

  1. #1
    Registriert seit
    03.06.2013
    Beiträge
    13
    Danke
    9
    Erhielt 0 Danke für 0 Beiträge

    Frage


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    Ich habe einen PC (Windows 7), auf dem eine TwinCAT PLC läuft mit Konfiguration auf einem CX9010-Arm-Basis.

    Die Probleme sind die folgenden: Ich mache das Protokoll in den SPS-Konfiguration, nach ... Ich beginne das Projekt, und:

    1. alles ist in Ordnung, außer manchmal habe ich einen Fehler an der PROFINET-Modul von OP-Modus, es ist auf SAFE OP-Modus gehen. Was kann diese Ursache sein?

    2. Wenn die TSM ist in Sicht, und PLC in Sicht, nachdem ich einen Neustart des Computers machen, wie kann automatisch gehen die SPS im RUN? Sollte ich etwas in Autostart? Was muss ich machen, um automatisch zu starten, ohne dies manuell ab, und setzen in neu beginnen?

    Vielen Dank,
    Geändert von pirattt85 (26.06.2013 um 12:57 Uhr)
    Zitieren Zitieren automatisch gestartet das Projekt?  

  2. #2
    Registriert seit
    10.08.2012
    Beiträge
    245
    Danke
    0
    Erhielt 70 Danke für 66 Beiträge

    Standard

    Ich verstehe es folgendermassen: Du hast eine Programmierumgebung mit Windows 7 und einen CX9010 als Runtime. Alles andere macht keinen Sinn da ein PC eine x86 Umgebung benötigt und der CX9010 wie du schreibst ein Arm basiertes System ist. Wenn dass nicht der Fall ist vergiss den Rest was ich schreibe.

    Prinzipiell gilt: Je mehr Informationen du bereitstellst desto einfach wird es für andere dir zu antworten.

    1) Was sagt das Meldungsfenster des SystemManagers?
    Schaue auch mal auf den Ethernet-Knoten, Online Reiter. Dort werden dir einige Grundsatzinformationene bezüglich CRC-Fehler, Lost Frames ... angezeigt.
    Der CX9010 mit der Profinet-Klemme (und damit verbundenen V2.11 Image) ist an der Grenze seiner Belastbarkeit. Das sauber hinzubekommen wird schwierig, eventuell auch unmöglich und ist (nach meiner Einschätzung deines TwinCAT Hintergrundwissens) nicht mal eben kurz erklärt.
    So eben mal in den Raum geworfen:
    a) setze die ProfiNet Klemme in eine eigene Sync-Unit und verkürze die Zykluszeit auf 2 msec mit Hilfe der externen Task von der du eine zyklische Variable lesend verknüpfst. Denk an den Autostart der externen Task.

    2) Im Knoten System kannst du das Verhalten des Systems nach einem Neustart konfigurieren. Um die SPS dann noch dazu zu bringen ebenfalls zu laufen musst du im SystemManager, auf dem SPS-Knoten die Nutzung eines Boot-Projektes anwählen. Im PLC Pro dann noch ein Boot Projekt erzeugen und fertig.

    Faulenzer

  3. #3
    pirattt85 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    03.06.2013
    Beiträge
    13
    Danke
    9
    Erhielt 0 Danke für 0 Beiträge

    Standard

    1. Die gesamte Maschine ist für die Bildverarbeitung. Der Computer muss ich für die Kommunikation zwischen der Anwendung zur Bildverarbeitung und der SPS. In diesem Fall war es ein Beckhoff ProfiNET Modul für die Kommunikation verwendet. Das Problem ist, wenn ich den Computer starten, ohne in SPS-Steuerung, um sich anzumelden und starten Sie die SPS, die Daten nicht zwischen ihnen ausgetauscht werden.
    Wie kann ich das Problem beheben, dass die SPS-Steuerung für den automatischen Start und autologin.
    Es ist möglich?

    2. (EL6631-0010):'SAFEOP to OP' failed! Error:'check device state for OP'. AL Status '0x0014' read and '0x0008' expected.
    Warum habe ich diesen Fehler? Um zu OP gehen, ich muss gehen, um Fehler zu löschen, und danach zu OP klicken.

    3. Was glauben Sie ist es die beste Konfiguration von Beckhoff, dass ich für ein Bildbearbeitungsprogramm, statt ProfiNET Modul 6631-0010 mit einer CX9010-Modul verwenden kann? Gibt es eine andere Konfiguration besser?


    Hinsichtlich der Tatsache, dass die Beckhoff-Programmierung, ich gebe zu, dass ich nicht zu viel wissen. Ich bin mehr vertraut mit einem anderen SPS-Programmierung. Ich bin ein Neuling hier.
    Geändert von pirattt85 (26.06.2013 um 08:52 Uhr)

  4. #4
    Registriert seit
    10.08.2012
    Beiträge
    245
    Danke
    0
    Erhielt 70 Danke für 66 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zu 2) AL Status 0x8 ist die Aufforderung dass der Slave in OP-Modus geht. Stattdessen gibt es 0x14 zurück was ECAT_AL_STATUS_CODE_NO_VALID_FIRMWARE heisst. Dass muesste im SystemManager aber auch neben der reinen Hex-Zahlen auch in einer Text-Form beschrieben sein. => Was für einen Firmwareestand hast du denn (im CoE-Online Reiter von deinem Tab -> siehe auch die Doku der Klemme.

    Guga

Ähnliche Themen

  1. Variablennamen automatisch im Projekt mit ändern
    Von Bensen83 im Forum CODESYS und IEC61131
    Antworten: 4
    Letzter Beitrag: 20.10.2012, 13:51
  2. Antworten: 4
    Letzter Beitrag: 24.09.2012, 12:41
  3. Antworten: 5
    Letzter Beitrag: 03.11.2011, 13:46
  4. Schulungstermine für das 2.Hj. 2011 und das 1.Hj. 2012
    Von ProFieldTec im Forum Werbung und Produktneuheiten
    Antworten: 0
    Letzter Beitrag: 07.06.2011, 20:03
  5. Antworten: 8
    Letzter Beitrag: 19.07.2007, 15:05

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •