Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 18 von 30 ErsteErste ... 8161718192028 ... LetzteLetzte
Ergebnis 171 bis 180 von 300

Thema: CODESYS auf dem Raspberry PI -jetzt verfügbar

  1. #171
    Registriert seit
    21.10.2010
    Beiträge
    474
    Danke
    53
    Erhielt 36 Danke für 35 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hi
    SPI ist jetzt grün
    so als Schnellschuss arbeitet der MCP4912 noch nicht richtig aber immerhin mal Grün. (SPI war auf dem Raspi noch nicht freigegeben)

  2. #172
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    12.016
    Danke
    511
    Erhielt 2.648 Danke für 1.910 Beiträge

    Standard

    Mal eine Zwischenfrage zum Rasperry mit Codesys.

    Funktioniert bei euch Wolfram und Mathematica noch?

    Wolfram startet und geht sofort wieder aus. Kann ja sein, dass das Absicht ist, um die Performance von Codesys nicht zu sehr runterzuholen. Wäre nicht wirklich schlimm.
    Codesys läuft auf jeden Fall sehr gut, toll was 3S da auf die Beine gestellt hat. Als nächstes werde ich mal Profinet-Geräte testen, da bin ich durchaus gespannt.
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

  3. #173
    HausSPSler ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    24.07.2013
    Beiträge
    370
    Danke
    1
    Erhielt 116 Danke für 97 Beiträge

    Standard

    Hallo Ralle,

    nein das ist keine Absicht das es nicht geht, müsste schon gehen.
    Welches Image Version verwendest du? Das aktuelle aus dem Store?
    Du kannst jederzeit das original Image von RaspberryPi.org verwenden und nur die CODESYS Runtime
    nach installieren über
    sudo dpkg -i codesyscontrol_arm_raspberry_V3.5.6.0.deb
    (zuerst mußt du natürlich dieses Debian Paket welches auch im Storedownload enthalten ist auf den Pi kopieren)
    By the way wir werden vermutlich nach Ostern ein 3.5.6.20 Version der Pi runtime releasen da es ein paar Probleme gibt wenn man Trend machen will.... +
    OPCUA Server ist dann als offizielles Release enthalten nicht mehr als BETA Version.
    Grüße
    Geändert von HausSPSler (01.04.2015 um 20:56 Uhr)
    Edwin Schwellinger
    3S-Smart Software Solutions GmbH

  4. Folgender Benutzer sagt Danke zu HausSPSler für den nützlichen Beitrag:

    Ralle (01.04.2015)

  5. #174
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    12.016
    Danke
    511
    Erhielt 2.648 Danke für 1.910 Beiträge

    Standard

    Ich habe das Image von 3S genommen, aufgespielt und expandiert. Dazu noch ein Paket für Remote-Zugriff mittel Microsoft Remote Desktop installiert.
    Ist ein Raspberry PI Model 2.
    So läuft es prima, wenn ich unbedingt die anderen Geschichten testen will, kann ich das Originalimage nehmen, das hab ich noch auf einer 2. SD-Karte.
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

  6. #175
    Registriert seit
    21.10.2010
    Beiträge
    474
    Danke
    53
    Erhielt 36 Danke für 35 Beiträge

    Standard

    Hi

    Ich hatte diese Woche auch mal wieder Zeit.
    Mittlerweile kann ich via Codesys Funksteckdosen schalten, Internetradio laufen lassen etc. etc.
    Allerdings fällt mir was komisches auf.
    Wen ich z.B. ein TON abarbeiten will, läuft dieser auch wie geschmiert, allerdings ist er Rot unterstrichen und Codesys meldet "Bezeichner TON nicht definiert" das gleiche mit CONCAT oder Flankenerkennung R_TRIG. Aber es läuft alles!

    Meine WebVisu sollte auf dem Laptop und dem Mobilphone gehen. Geht auch, allerdings ist die Tastatur/Numpad dort soooooo klein, dass es sehr schwierig ist, eine Zahl zu treffen. Kann man die Tastatur auch grösser machen?

    Dann habe ich immer noch das Thema mit dem SPI Daten zu verschicken, allerding muss ich dort nochmals nachforschen.....

    Gruss blimaa
    Fehler_ST1.JPG

  7. #176
    HausSPSler ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    24.07.2013
    Beiträge
    370
    Danke
    1
    Erhielt 116 Danke für 97 Beiträge

    Standard

    Hi blimaa,

    ist komisch, hast du die aktuelle compilerversion eingestellt?
    'Ton' kommt aus der Standard.library dieser "precompile" Fehler sollte nicht kommen.
    Welche CODESYS Version hast du genau am Start 3.5.6.10?
    Prüfe bitte:
    1. SPS Gerät aktuell?
    2. Compilerversion Einstellung auf aktuelle
    3. Visuprofil aktuell

    Abschalten kann man das "Unterstreichen im Editor" über -> Tools-Optionen->Intelligentes Codieren -> Fehler im Editor Unterstreichen
    (Bei mir kommt das nicht ... mit TON)

    ZU den Visu Dialogen... da gibt's einen Eintrag in der Improvement/Bug Tracking Datenbank, sehe aber keinen Termin.
    Wenn es zu arg nervt /bzw nicht geht könntest du die Dialoge selber "pimpen" die Bibliothek ist ja offen bei jeder CODESYS Installation dabei:

    Hier:
    "c:\Program Files (x86)\3S CODESYS\CODESYS\Projects\Visu\Dialogs\VisuDialogs.library"

    Grüße
    Edwin
    Edwin Schwellinger
    3S-Smart Software Solutions GmbH

  8. #177
    Registriert seit
    21.10.2010
    Beiträge
    474
    Danke
    53
    Erhielt 36 Danke für 35 Beiträge

    Standard

    Hi - Compilerversion 3.5.6.0 - Visuprofil 3.5 SP6 -SPS ist der Raspi in aktuellster Version Gruss blimaa

  9. #178
    Registriert seit
    07.08.2009
    Beiträge
    2
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo,
    ich wollte auf den Raspberry mit den Befehl sudo dpkg -i codesyscontrol_arm_raspberry_V3.5.6.0.deb aktualisieren. Ich habe die .deb Datei
    vorher auf den Rasp kopiert. Anschließend mit Putty sudo dpkg -i codesyscontrol_arm_raspberry_V3.5.6.0.deb eingegeben.
    Ich bekomme immer die Meldung dpkg: Fehler: Eine Aktions-Option wird benötigt. Was mache ich falsch? Kannst Du mir helfen?
    Danke im Voraus.
    Gerd

  10. #179
    HausSPSler ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    24.07.2013
    Beiträge
    370
    Danke
    1
    Erhielt 116 Danke für 97 Beiträge

    Standard

    Hallo Gerd,

    hab ich noch nie gesehen musst mal nach:
    "Fehler: Eine Aktions-Option wird benötigt"
    googlen... dann kommst du nach http://forum.ubuntuusers.de/topic/ak...-unvollst-tpf/
    das würde ich mal so ausprobieren...
    Grüße
    Geändert von HausSPSler (03.04.2015 um 13:22 Uhr)
    Edwin Schwellinger
    3S-Smart Software Solutions GmbH

  11. #180
    Registriert seit
    05.10.2005
    Beiträge
    2.345
    Danke
    319
    Erhielt 295 Danke für 265 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    ...so, hab jetzt das ganze mit einem Profinet ET200s und einem EtherCAT EK1100 mit jeweils ein paar IO auf einem Pi2 am laufen. Gelegentlich steigt die ET200s für ca. 10s mit Busfehler aus und kommt dann selbständig wieder. Leider hab ich keine genaueren Diagnosedaten gefunden. Liegt es daran, das ich beides parallel am laufen habe und das Ethernet überfordere oder sollte ich an den Hardwarekomponenten weiter den Fehler suchen?

Ähnliche Themen

  1. LibNoDave kompilieren auf raspberry pi?
    Von scrolllkock im Forum Hochsprachen - OPC
    Antworten: 75
    Letzter Beitrag: 08.01.2017, 02:13
  2. ACCONtrol jetzt als Version 1.2.2 verfügbar
    Von Gerhard Bäurle im Forum Werbung und Produktneuheiten
    Antworten: 17
    Letzter Beitrag: 04.07.2007, 22:39
  3. IBH S7-CX317 Starterkit jetzt verfügbar
    Von IBHsoftec GmbH im Forum Werbung und Produktneuheiten
    Antworten: 0
    Letzter Beitrag: 03.04.2007, 16:33
  4. IBH Link S7 Plus ab jetzt verfügbar
    Von Axel Hulsch im Forum Werbung und Produktneuheiten
    Antworten: 4
    Letzter Beitrag: 19.12.2005, 15:34
  5. S5/S7-Doctor V2.01 ist jetzt verfügbar
    Von Axel Hulsch im Forum Werbung und Produktneuheiten
    Antworten: 0
    Letzter Beitrag: 08.09.2005, 12:41

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •