Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 2 von 2

Thema: Serial_Interface_01.lib Probleme mit Receive_Buffer

  1. #1
    Registriert seit
    13.04.2014
    Beiträge
    1
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen,

    Ich will mit der Hilfe einer Bibliothek von Wago "Serial_Interface_01.lib" einen Barcode einlesen. Es klappt auch einmal wunderbar, doch habe ich beim zweitenmal Probleme, dass ich den Receive_Buffer nicht zurücksetzten kann. In diesem Buffer stehen immer noch die Daten des vorherigen Vorgangs. Kann ich diese irgendwie löschen.

    Vielen Dank für eure Hilfe
    Zitieren Zitieren Serial_Interface_01.lib Probleme mit Receive_Buffer  

  2. #2
    Registriert seit
    30.01.2004
    Ort
    Erfurt
    Beiträge
    961
    Danke
    42
    Erhielt 109 Danke für 87 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von SPS_Techniker Beitrag anzeigen
    Hallo zusammen,

    Ich will mit der Hilfe einer Bibliothek von Wago "Serial_Interface_01.lib" einen Barcode einlesen. Es klappt auch einmal wunderbar, doch habe ich beim zweitenmal Probleme, dass ich den Receive_Buffer nicht zurücksetzten kann. In diesem Buffer stehen immer noch die Daten des vorherigen Vorgangs. Kann ich diese irgendwie löschen.

    Vielen Dank für eure Hilfe
    Dir ist bewusst das dies hier ein Ringpuffer ist (?) weshalb du den aktuellen Index beachten musst. Jedes neu eingehende Zeichen wird auf die Position Index geschrieben und anschliessend wird dieser inkrementiert - d.h. nach Empfang eines Telegramms von 10 Zeichen steht der Index 10 Zeichen weiter und das Telegramm steht beginnt bei Index-10.
    Nach dem Lesen einfach Index auf den Startwert setzen und alles wird gut?
    __
    Mit freundlichem Gruß Peter

    ...Wir sind Alle Zeitreisende. Die überwiegende Mehrzahl schafft allerdings täglich nur einen Tag.... (Jasper Fforde: "In einem andern Buch")

Ähnliche Themen

  1. Wago Probleme mit LIB VISU Scheduler 3
    Von c-teg74 im Forum WAGO
    Antworten: 15
    Letzter Beitrag: 16.01.2017, 13:02
  2. Problem mit externer Lib
    Von demon2000 im Forum CODESYS und IEC61131
    Antworten: 6
    Letzter Beitrag: 20.05.2011, 07:28
  3. EL6001 mit COMlibV2.lib?
    Von hs_soft im Forum CODESYS und IEC61131
    Antworten: 11
    Letzter Beitrag: 16.03.2010, 08:36
  4. Probleme mit der FB_SMTPBC.lib
    Von TomCatShS im Forum CODESYS und IEC61131
    Antworten: 3
    Letzter Beitrag: 11.10.2009, 15:57
  5. Problem mit WagoLibMail_02.lib
    Von dietere im Forum Sonstige Steuerungen
    Antworten: 0
    Letzter Beitrag: 15.11.2007, 23:00

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •