Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 10 von 10

Thema: Datenverlust an CX5020

  1. #1
    Registriert seit
    19.05.2008
    Beiträge
    651
    Danke
    118
    Erhielt 136 Danke für 105 Beiträge

    Frage


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo allerseits,

    in letzter Zeit hatte ich an 2 unterschiedlichen Maschinen einen Verlust der Persistenten Daten. Leider habe ich keine Information unter welchen Umständen es zu diesem Problem gekommen ist. Laut Kunden (zwei unterschiedliche) waren die Daten nach dem Einschalten am Morgen einfach weg!

    Das Baujahr ist 2010 und 2011. Das Betriebssystem jeweils WinCE mit NC-PtP.
    Seit dem eingeben der verlorenen Einstellungen vor ~6 Wochen, ist bisher wieder alles OK.

    Natürlich verunsichert das unser Kunden und mich natürlich auch.
    Folgender Forumsbeitrag macht sie Sache auch nicht besser:
    Beckhoff CX-5020 Persistente Daten

    Wenn der Fehler "nur" alle 3-4 Jahre auftaucht, ist das natürlich fast unmöglich vernünftig zu untersuchen!

    Wer von euch hat ähnliche Probleme?
    Gibt es dazu auch Erkenntnisse an was das liegen kann?
    Könnte es an einer fehlerhaft TcSUPS.lib Version liegen?

    Gruß
    Chräshe
    Zitieren Zitieren Datenverlust an CX5020  

  2. #2
    Registriert seit
    25.11.2010
    Ort
    OWL
    Beiträge
    752
    Danke
    27
    Erhielt 165 Danke für 143 Beiträge

    Standard

    Hatte ich neulich auch ein paar mal, und zwar in einer Situation, in der ich auch kein Bootprojekt mehr erzeugen konnte, weil die CF-Karte voll war. Möglich, dass das auch das Speichern der persistenten Daten verhindert hat.

  3. #3
    Avatar von Chräshe
    Chräshe ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    19.05.2008
    Beiträge
    651
    Danke
    118
    Erhielt 136 Danke für 105 Beiträge

    Standard

    Zitat Zitat von StructuredTrash Beitrag anzeigen
    Hatte ich neulich auch ein paar mal, und zwar in einer Situation, in der ich auch kein Bootprojekt mehr erzeugen konnte, weil die CF-Karte voll war. Möglich, dass das auch das Speichern der persistenten Daten verhindert hat.
    Hallo StructuredTrash,

    eine volle CF- Karte kann ich ausschließen, sofern Beckhoff intern nicht ständig etwas protokolliert.
    Protokollierungen lagere ich immer auf einen USB- Stick aus.
    Bei den betroffenen Steuerungen gibt es zudem überhaupt keine Protokolle...

    Gruß
    Chräshe

  4. #4
    Registriert seit
    28.09.2012
    Beiträge
    13
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Möglicherweise ist der USB stick das Problem? Ich hatte ein ähnliches Problem mit dem gleichen CX winXP und einem angeschlossenen USB funk-maus-Tastatur Set. Bei meinen Recherchen habe ich festgestellt, das die 1sek usv in der standardkonfiguration auch die USB Geräte versorgt. Dadurch ist sie wenn viele Daten geschrieben sollen schnell an ihrer Grenze. Diese Einstellung kann im BIOS geändert werden. Die stromaufnahme eines USB Sticks ist sicher geringer, aber vielleicht hilft's ja

  5. #5
    Registriert seit
    15.02.2011
    Ort
    Stromness, Scotland, UK
    Beiträge
    339
    Danke
    25
    Erhielt 34 Danke für 33 Beiträge

    Standard

    Wie schaltest du die CX ab? Einfach Strom weg und dann über die USV herunterfahren?
    Wenn ja, kann es passieren dass wenn Windows gerade mit sich selber beschäftigt ist (oder was auch immer), der asynchrone Schreibprozess auf die Speicherkarte nicht beendet werden konnte, bevor der CX der Saft ausging.

    Die Speicherzugriffszeiten variieren zum Teil extrem!
    Als Abhilfe hatte ich früher mal den FB_SUPS (oder so) auseinandergebaut und auf den Abschluss der Speicherung überwacht.

    Am Besten ist immer noch der Steuerung mit zu teilen, dass Sie nun heruntergefahren wird. Die 1s USV ist für grössere Datenmengen einfach zu klein.

  6. #6
    Avatar von Chräshe
    Chräshe ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    19.05.2008
    Beiträge
    651
    Danke
    118
    Erhielt 136 Danke für 105 Beiträge

    Standard

    Zitat Zitat von gloeru Beitrag anzeigen
    Wie schaltest du die CX ab? Einfach Strom weg und dann über die USV herunterfahren?
    Wenn ja, kann es passieren dass wenn Windows gerade mit sich selber beschäftigt ist (oder was auch immer), der asynchrone Schreibprozess auf die Speicherkarte nicht beendet werden konnte, bevor der CX der Saft ausging.
    Natürlich - JA. Für was sollte die 1s USV gut sein, wenn das Abschalten per Hauptschalter nur meistens gut geht?

    Zitat Zitat von gloeru Beitrag anzeigen
    Die Speicherzugriffszeiten variieren zum Teil extrem!
    Als Abhilfe hatte ich früher mal den FB_SUPS (oder so) auseinandergebaut und auf den Abschluss der Speicherung überwacht.
    Was soll es nützen, wenn ich die Speicherung überwache?
    Wenn die Daten weg sind sie weg. Dann ist es zu spät. Dass sie weg sind, merkt man ohne Überwachung.

    Zitat Zitat von gloeru Beitrag anzeigen
    Am Besten ist immer noch der Steuerung mit zu teilen, dass Sie nun heruntergefahren wird. Die 1s USV ist für grössere Datenmengen einfach zu klein.
    Auszug aus dem Handbuch:
    Die CX50x0 Familie verfügt eine eingebaute kapazitive 1-Sekunden-USV. Sie sorgt für ein sicheres Abspeichern der persistenten Anwendungsdaten auf die Compact-Flash-Karte.
    Es können bis zu 1 MB Daten gesichert werden...
    Ich bin noch weit weg von 1 MB. Sofern die Unterlagen von Beckhoff stimmen, kann man die Steuerung wie eine rustikale SPS verwenden. Genau als solches wird sie auch eingesetzt.

    @Alle
    Hattet ihr auch schon unerklärliche Datenverluste an einem CX5xxx- Modell?
    Es wäre einfach mal interessant, über andere Fälle zu erfahren.
    Vielleicht hab ich ja nur eine Montags-Version erwischt...

  7. #7
    Registriert seit
    04.03.2011
    Beiträge
    77
    Danke
    15
    Erhielt 6 Danke für 6 Beiträge

    Standard

    Sind den alle persistenten Daten weg oder nur ein Teil ?
    Es kommt nicht darauf an, mit dem Kopf durch die Wand zu rennen, sondern mit den Augen die Tür zu finden.

  8. #8
    Registriert seit
    15.08.2011
    Beiträge
    383
    Danke
    2
    Erhielt 73 Danke für 71 Beiträge

    Standard

    Hallo zusammen!
    Habt ihr das mal mit dem Beckhoff Support besprochen?
    Bitte machen!

  9. #9
    Avatar von Chräshe
    Chräshe ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    19.05.2008
    Beiträge
    651
    Danke
    118
    Erhielt 136 Danke für 105 Beiträge

    Standard

    Zitat Zitat von Bl000b3r Beitrag anzeigen
    Sind den alle persistenten Daten weg oder nur ein Teil ?
    Kann ich nicht mit Sicherheit sagen, ab sehr wahrscheinlich waren es alle Daten. In einem Fall waren es 20, im anderen vielleicht 60 Werte. Das ist auch keine Tragödie, aber ich will den Tag nicht abwarten, an dem ich 1000 Einstellwerte nachtragen muss!

    Zitat Zitat von mac203 Beitrag anzeigen
    Hallo zusammen!
    Habt ihr das mal mit dem Beckhoff Support besprochen?
    Bitte machen!
    Das läuft gerade. Aktuell habe nur ich das Problem...

  10. #10
    Avatar von Chräshe
    Chräshe ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    19.05.2008
    Beiträge
    651
    Danke
    118
    Erhielt 136 Danke für 105 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo allerseits,

    Allem Anschein nach, war ich doch nicht der einigste, den dieses Problem mit dem Datenverlust ereilt hat!

    Zusätzlich zu dem Aufruf vom USV- Baustein, wird von offizieller Stelle empfohlen, die Programmabarbeitung zu unterbrechen, wenn eine Spannungsausfall detektiert wird.
    -> Siehe Beckhoff Beispielprojekt Sample_S_UPS.pro.

    Gruß
    Chräshe

Ähnliche Themen

  1. (Teil-) Datenverlust in einem DB
    Von Bär1971 im Forum Simatic
    Antworten: 10
    Letzter Beitrag: 12.02.2013, 11:40
  2. Datenverlust Siemens S7-300
    Von KNEFI im Forum Simatic
    Antworten: 9
    Letzter Beitrag: 15.01.2013, 18:26
  3. Ethernet - Datenverlust
    Von Ninja2602 im Forum Simatic
    Antworten: 13
    Letzter Beitrag: 10.04.2012, 14:27
  4. Datenverlust an VIPA S7?
    Von Chräshe im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 18.06.2010, 14:09
  5. Datenverlust?????
    Von Full Flavor im Forum PC- und Netzwerktechnik
    Antworten: 9
    Letzter Beitrag: 20.11.2008, 18:45

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •