Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 5 von 5

Thema: CX9000 und C#: Timeout

  1. #1
    Registriert seit
    18.02.2013
    Beiträge
    23
    Danke
    1
    Erhielt 3 Danke für 3 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Nach längerer Zeit beschäftige ich mich mal wieder mit Beckhoff. Aktuell habe ich folgendes Problem:
    Ich habe eine CX9000 und einen PC der über ein selbst geschriebenes Programm Daten von der CX erhalten soll. Das habe ich schon mal mit einem BC9100 gemacht und es funktionierte. Jetzt jedoch will es einfach nicht klappen.
    Der Reihe nach. Als erstes versuchte ich auf dem PC Twincat 2 Engineering zu installieren. Resultat: Bluescreen kurz nach dem Start (tcrtime.sys). Twincat wieder runtergeschmissen, SPS-Programm mit dem Laptop geschrieben, auf dem Twincat problemlos läuft. Nun muss mein C# Programm aber leider unbedingt auf dem PC laufen. Also die Communication Library installiert und die AMS-ID der CX hinzugefügt.
    Mit dem TcAdsTest.exe funktioniert die Verbindung einwandfrei, in meinem C#-Programm nicht! Es kommt grundsätzlich Fehler 745: Timeout. Ich habe es auch mit Beispielprogrammen aus dem Infosys versucht. Immer Fehler 745. Lasse ich dasselbe Programm auf dem Entwicker-Laptop laufen, funktioniert es!
    Da auf dem PC die Testroutine funktioniert, gehe ich von einem Dll-Problem aus. Kann es an Überresten der Twincat-Installation liegen? Ich weiß echt nicht mehr weiter...
    Zitieren Zitieren CX9000 und C#: Timeout  

  2. #2
    Registriert seit
    07.10.2013
    Beiträge
    96
    Danke
    7
    Erhielt 11 Danke für 10 Beiträge

    Standard

    Treiber Netzwerkarte Leppi und PC verglichen? Irek

  3. #3
    CaptainKirk ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    18.02.2013
    Beiträge
    23
    Danke
    1
    Erhielt 3 Danke für 3 Beiträge

    Standard

    Was soll ich denn da finden? Die vom PC ist von Realtek, die vom Lappi von Intel. Aber ich habe ja geschrieben, das Testprogramm funzt vom PC aus, also wird es wohl nicht am NIC liegen.

  4. #4
    Registriert seit
    07.10.2013
    Beiträge
    96
    Danke
    7
    Erhielt 11 Danke für 10 Beiträge

    Standard

    das TwinCat Intermediate Driver soll bei Dir aktiviert sein. (Ich benutze noch eine eine zweite Netzwerkkarte vom Intel).

    Irek
    Angehängte Grafiken Angehängte Grafiken

  5. #5
    CaptainKirk ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    18.02.2013
    Beiträge
    23
    Danke
    1
    Erhielt 3 Danke für 3 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ich benutze kein EtherCat. Ich konnte das Problem mittlerweile anders lösen: Ich habe Windows neuinstalliert, dann die aktuellste TwinCat-Version und nun läuft es Trotzdem Danke für die Tipps.

Ähnliche Themen

  1. Windows CE (CX9000) und Netzlaufwerk/-zugriff
    Von wisi im Forum CODESYS und IEC61131
    Antworten: 7
    Letzter Beitrag: 14.05.2013, 08:13
  2. Beckhoff CX9000 SMS senden und Empfangen
    Von b_lisa im Forum CODESYS und IEC61131
    Antworten: 2
    Letzter Beitrag: 27.08.2011, 10:14
  3. CX9000 - Daten nach Neustart behalten! RETAIN und PERSISTENT?
    Von Codesys_123 im Forum CODESYS und IEC61131
    Antworten: 2
    Letzter Beitrag: 04.09.2010, 11:33
  4. libnodave und Timeout
    Von HeizDuese im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 06.01.2009, 15:06
  5. Libnodave Timeout
    Von Lazarus™ im Forum Hochsprachen - OPC
    Antworten: 7
    Letzter Beitrag: 16.10.2005, 00:41

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •