Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 9 von 9

Thema: EL7201 persistente Resolverposition

  1. #1
    Registriert seit
    02.10.2006
    Ort
    Tirol
    Beiträge
    159
    Danke
    17
    Erhielt 5 Danke für 5 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    ich habe mir ein paar EL7201 Klemmen eingebaut und wollte mir Anfangs die Resolverpositoin peristent speichern.
    Hab in der NC-Config auch bei den jeweiligen Achsen "Daten peristenz" aktiviert und auch die NC-Task auf "Speichern/Laden" gesetzt.

    Mit diesen beiden Optionen wurde die Position aber nicht persistent gespeichert, also hab ich mit diversen Schreibversuchen (z.B. SoeWrite) den Wert über das PLC-Prgramm zu speichern.
    Mit einem Aufruf hat das dann geklappt und seit dem hab ich immer bei Spannungsausfall diese gespeicherten Werte in der Resolverposition stehen.

    Das ganze ist schon einige Zeit her und jetzt kann ich das nicht mehr nachvollziehen wie ich diesen Werte auf die EL7201 schreiben konnte.
    Diese gespeicherte Resolverposition würde ich gerne wieder löschen - nur weiß ich nicht wie ?

    Hab die Karte schon auf Werkseinstellung zurückgesetzt (gibt bei dieser Karte 2 Varianten - hab alle beide probiert)
    Hab das komplette Programm vom CX gelöscht - inkl. Retain und NC Daten

    Weiß jemand wo dieser Wert gespeichert wird bzw. wie man den wieder auf 0 setzen kann ?
    T H X T O M A T E
    Zitieren Zitieren EL7201 persistente Resolverposition  

  2. #2
    Registriert seit
    21.02.2014
    Ort
    Sachsen-Anhalt
    Beiträge
    1.576
    Danke
    285
    Erhielt 261 Danke für 235 Beiträge

    Standard

    Hast Du die NovRam-Verknüfung benutzt? Schau mal im Sysmanager nach, ob Du ein NOVRAM-Device hast und dort evtl. die Variablen zur wiederherstellung verknüpft sind.

  3. #3
    Avatar von tomatensaft
    tomatensaft ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    02.10.2006
    Ort
    Tirol
    Beiträge
    159
    Danke
    17
    Erhielt 5 Danke für 5 Beiträge

    Standard

    Hallo,

    hab einen Cx5020 - der hat keinen Novram. Files hab ich direkt aufm cx gelöscht.
    T H X T O M A T E

  4. #4
    Registriert seit
    10.08.2012
    Beiträge
    258
    Danke
    0
    Erhielt 74 Danke für 70 Beiträge

    Standard

    Schuss ins BLAUE, ich glaube da mal was gesehen zu haben vor langer Zeit.
    Schau mal in das Boot-Verzeichnis ob da eine Datei liegt die vom Namen irgendwie zur NC zuzuordnen ist. Dort könnten die Daten gespeichert sein.
    Wenn du die Möglichketi hast wäre es natürlich auch möglich das Boot-Verzeichnis komplett zu löschen...

  5. #5
    Avatar von tomatensaft
    tomatensaft ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    02.10.2006
    Ort
    Tirol
    Beiträge
    159
    Danke
    17
    Erhielt 5 Danke für 5 Beiträge

    Standard

    Hallo,

    danke - hab ich schon gelöscht und auch einmal den kompletten CX ausgetauscht. hat auch nix gebracht - irgendwo in der Klemme muss da ein Wert hinterlegt sein.
    T H X T O M A T E

  6. #6
    Registriert seit
    21.02.2014
    Ort
    Sachsen-Anhalt
    Beiträge
    1.576
    Danke
    285
    Erhielt 261 Danke für 235 Beiträge

    Standard

    Systemmanager --> Achse x --> Parameter --> weitere Einstellungen --> Daten persistenz

    könnte zu Deinem Problem passen.

    HTH

  7. #7
    Avatar von tomatensaft
    tomatensaft ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    02.10.2006
    Ort
    Tirol
    Beiträge
    159
    Danke
    17
    Erhielt 5 Danke für 5 Beiträge

    Standard

    Hallo,

    hab ich auch schon probert - in Kombination mit den Retain Daten der NC-Task.
    Wenn mann in der Klemme die Daten Peristenz aktivert, dann muss doch irgendwo der Resolverwert eingetragen werden - nur wo ?
    T H X T O M A T E

  8. #8
    Registriert seit
    21.02.2014
    Ort
    Sachsen-Anhalt
    Beiträge
    1.576
    Danke
    285
    Erhielt 261 Danke für 235 Beiträge

    Standard

    blöde frage: hast Du nach den Änderungen mal die Konfig neu übertragen und aktiviert?

    Irgendwo wird der Wert sschon gespeichert werden. Vermutlich auf der Speicherkarte des CX.
    Entspricht der gespeicherte Wert der aktuellen Position oder ist es noch eine Leiche aus Deinen älteren Versuchen?
    Mir war so, als ob irgendwo für den Resolver noch der Betriebsmodus zwischen incremental und absolut umgestellt werden kann.

    Hast Du die Klemme auf Werkseinstellungen zurückgesetzt (restore-object)? Ist noch eine Programmleiche aktiv (Zombie), die munter weiter speichert?

  9. #9
    Avatar von tomatensaft
    tomatensaft ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    02.10.2006
    Ort
    Tirol
    Beiträge
    159
    Danke
    17
    Erhielt 5 Danke für 5 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Jop, alles aktiviert, übertragen - sogar nach CX-Tausch

    Hab die Klemme mehrer male auch Werkseinstellung zurückgesetzt - nix gebracht - alle Werte der Klemme waren dann default - nur nicht mein Positionswert
    T H X T O M A T E

Ähnliche Themen

  1. EL7201 mit externem Gebersignal
    Von OPP im Forum CODESYS und IEC61131
    Antworten: 9
    Letzter Beitrag: 09.05.2014, 13:06
  2. EL7201 + AM3112 im Drehmoment Modus
    Von TwinCatUser im Forum Antriebstechnik
    Antworten: 4
    Letzter Beitrag: 22.04.2014, 10:23
  3. Fehler bei EL7201
    Von Fei im Forum CODESYS und IEC61131
    Antworten: 2
    Letzter Beitrag: 09.11.2012, 13:19
  4. Beckhoff EL7201 Servomotorklemme
    Von Robofreak im Forum CODESYS und IEC61131
    Antworten: 0
    Letzter Beitrag: 31.05.2012, 15:26
  5. PERSISTENTe Variablen
    Von gamble im Forum CODESYS und IEC61131
    Antworten: 9
    Letzter Beitrag: 26.04.2011, 08:50

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •