Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 6 von 6

Thema: Kalibrierung Blind_Control_S deaktivieren

  1. #1
    Registriert seit
    07.07.2014
    Beiträge
    18
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen,

    in unserer Rollosteuerung verwende ich den Blind_Control_S-Baustein und alles funktioniert soweit wunderbar. Allerdings möchte ich nun die automatische Kalibrierfahrt nach Stromausfall unterbinden. In der Beschreibung zu dem Baustein heißt, das die beiden Eingänge UP und Down auf FALSE liegen müssen. Irgendwie verstehe ich das aber nicht, denn beide Eingänge liegen doch immer auf FALSE, solange kein Taster gedrückt wird.
    Wie habt ihr das denn umgesetzt?

    Danke und Gruß,
    Jürgen
    Zitieren Zitieren Kalibrierung Blind_Control_S deaktivieren  

  2. #2
    Juergen_Newbie ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    07.07.2014
    Beiträge
    18
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo zusammen,

    habe die Lösung gefunden. Einfach die Default-Einstellung der Ausgänge des vorgeschalteten Blind_Input-Baustein auf False gesetzt.

    Gruß,
    Jürgen

  3. #3
    Registriert seit
    02.10.2015
    Beiträge
    5
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo.

    Ich habe das gleiche Problem und weiß gerade nicht wie welche default Einstellungen für den Blind_Input umgestellt werden müssen. Kannst du mir da einen Tipp geben? Ausserdem habe ich auch das Problem das meine Bausteine nicht auf einen Tastendruck reagieren. Hat jemand da ähnliche Probleme mit der Konfiguration der Blind Bausteine aus der OSCAT Bibliothek? Aus der Beschreibung werde ich nicht so richtig schlau.

    Gruß Marc

  4. #4
    Juergen_Newbie ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    07.07.2014
    Beiträge
    18
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo Marc,

    um die Defaulteinstellungen zu ändern, musst du den Baustein direkt in der .lib-Datei öffnen. Dort kannst du dann die Default-Belegung umschreiben.

    Was meinst du mit "Tastendruck"? Automatisch komplett schließen oder nur solange der Taster gedrückt wird? Vielleicht kannst mal ein Bild posten, wie du deine Schaltung aufgebaut hast.

    Gruß,
    Jürgen

  5. #5
    Registriert seit
    02.10.2015
    Beiträge
    5
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo Jürgen,
    vielen Dank für den Hinweis. Also ich meine mit Tastendruck, einen Druck auf meine Jalousietaster.
    Ich gehe im Programm in folgender Weise vor. Ich werte alle Schalter mit dem Baustein Click_Mode aus und habe die jeweiligen Ausgangsfunktionen in eine globale Variable übergeben. Also 1-fach, 2-fach und Dauerklick.
    Für das Rollo habe ich einen FB erstellt in dem die Bausteine Blind_Input und Blind_control_S miteinander verschaltet sind. Diesen eigenen Rollo Baustein rufe ich dann für jede Jalousie neu auf.
    Die Tastervariablen kommen dann auf den Eingang des Rollo Bausteines und am Ausgang wird das Relais der Jalousie angesteuert.
    Mein Problem war jetzt folgendes. Ich habe das Programm auf die Steuerung geladen und danach wurde die Kalibrierungsfahrt durchgeführt und danach konnte ich mit meinen Tastern die Jalousien nicht mehr fahren. Es waren beide Ausgänge des Blind Input auf High und der Baustein reagierte auf keine weitere Eingabe. Ich werde heute abend ein paar Bilder mit anfügen. Aber schon mal vielen Dank für eine so schnelle Antwort.

    Gruß Marc

  6. #6
    Registriert seit
    02.10.2015
    Beiträge
    5
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Jürgen,
    Hallo alle anderen,
    entschuldigt das es so lange gedauert hat bis ich mal wieder melde. Ich konnte mein Problem inzwischen lösen. Dank deiner Hilfe und die der Beitrage im OSCAT Forum. Aber ich fand den Lösungsansatz die Vorgaben in der Bibliothek zu ändern, irgendwie unbefriedigend, da sie ja schon einen Sinn im Zusammenspiel mit weiteren Blind Bausteinen haben. Um die Kalibrierfahrt zu unterbinden brauchst du ja nur im Baustein Blind_Input, den Eingang In auf False legen und schon bist du dauerhaft im Handbetrieb. Sofern ich das alles richtig verstanden habe, inzwischen.
    Mein eigentliches Problem war aber, das die Bausteine überhaubt nicht auf meine Tasterflanken reagiert habe. Und da habe ich feststellen müssen das meine Bausteine nur nicht richtig konfiguriert waren. Ich hatte vergessen die Variable Click_En auf True zu setzen und schon lief mein Handbetrieb. Jetzt wo das erst mal läuft, werde ich mich mal dran setzen und Stück für Stück die Funktionen Shade und Security in die Rollo Steuerung integrieren.

    Gruß Marc

Ähnliche Themen

  1. Hand-Auge-Kalibrierung
    Von stajank im Forum Sensorik
    Antworten: 4
    Letzter Beitrag: 18.03.2014, 18:27
  2. Pt100 Kalibrierung
    Von Magni im Forum Simatic
    Antworten: 10
    Letzter Beitrag: 18.04.2011, 10:50
  3. Probleme kalibrierung TP270
    Von bernd81 im Forum HMI
    Antworten: 2
    Letzter Beitrag: 04.02.2011, 09:02
  4. Antworten: 9
    Letzter Beitrag: 22.07.2010, 16:37
  5. Kalibrierung
    Von SebastianLicht im Forum Simatic
    Antworten: 10
    Letzter Beitrag: 03.04.2009, 21:37

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •