Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 8 von 8

Thema: Fragen zu Blind_Control_S

  1. #1
    Registriert seit
    07.07.2014
    Beiträge
    18
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen,

    mittlerweile ist meine Rollosteuerung soweit gewachsen, dass ich mittels Tasterauswertung durch den Click_Mode-Baustein, das komplette Haus mit verschiedenen Tastern komplett schliessen und öffnen, sowie die einzelnen Geschosse steuern kann. Allerdings sind mir zwei Sachen aufgefallen, die ich bislang nicht lösen konnte:

    1. Der verwendete Baustein, ignoriert die eingegebenen Zeiten für UP und Down, sondern steuert jeweils 60 Sek. die Motoren an.

    2. Wenn ein Rollo aus irgendeinem Grund bereits in einer Endposition ist und ich steuere dann alles z.B. auf, dann wird auch der Ausgang aktiviert, dess Rollo bereits in der Endposition war. Beispiel: Aufgrund Sonneneinstrahlung sind die Rollo's der Südseite bereits geschlossen. Wenn ich nun mittels Doppelklick die Funktion "Alle Rollo schliessen" auslöse, werden auch die Rollo's auf der Südseite angesteuert, obwohl diese ja bereits geschlossen sind. Ich hätte erwartet, dass nur noch die Ausgänge angesteuert werden, die noch offen sind.

    Im Anhag mein verwendeter FB und als Beispiel eine Beschaltung.

    Beschaltung_Bsp.PNGRolladenbaustein.PNG


    Ich hoffe, es kann mir jemand helfen.

    Vielen Dank schon mal und schöne Grüße,
    Jürgen
    Zitieren Zitieren Fragen zu Blind_Control_S  

  2. #2
    Registriert seit
    26.10.2011
    Beiträge
    32
    Danke
    8
    Erhielt 3 Danke für 3 Beiträge

    Standard

    Hallo Jürgen,

    1.) Was hast du bei der Config-Variable T_EXT eingegeben? Bzw. Beobachte mal die POS-Variable, wenn sie auf 0 steht und du dann nach oben fahren lässt. Diese sollte genau deine konfigurierten 17s brauchen bis sie bei 255 ist.
    2.) Ich verstehe das Problem gerade nicht.
    Die Jalousiemotoren haben doch mechanische Endschalter. Dann passiert doch da gar nichts.
    Der Blind_Control ist definitiv so programmiert, dass wenn man erneut drückt er nochmals die vorgegebene Zeit läuft. Ist bei mir nicht anders.

    Aber so nebenbei bemerkt:
    Die Frage gehört dann doch eher ins OSCAT-Forum

  3. #3
    Juergen_Newbie ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    07.07.2014
    Beiträge
    18
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo D-Platoon,

    erstmal danke für deine Rückmeldung.

    Zu 1.): Das werde ich mal testen. Allerdings bin ich gestern beim Suchen im Netz auf eine interessante Neuigkeit gestossen, die mir nicht klar war. Dort war die Aussage, dass die bei T_UP und T_DN eingegebene Zeit nur für die Kallibrierung notwendig ist. Die Motoren werden immer für die Dauer der Variablen des MAX_RUNTIME des Blind_Input-Bausteins angesteuert, Standardmäßig also 60 Sekunden. Das würde sich auch mit dem Verhalten meiner Steuerung decken. Verstanden hatte ich es aber so, dass die Motoren für die Zeit T_UP bzw. T_DN plus die Zeit T_EXT angesteuert werden. Da es ja keinen Sinn macht, einen Rollo, der z.B. nach 17 Sek. in oder oberen Endposition ist, 43 Sekunden länger zu bestromen.

    Zu 2.):Ja, meine Rolläden haben auch mechanische Endschalter und es passiert zum Glück nichts, außer das die Lebensdauer meiner Relais darunter leiden könnte. Vielleicht hatte ich dann hier eine falsche Erwartung. Ich dachte, bzw. hätte folgendes erwartet: Baustein Blind_Control kennt die Position der Rolläden, z.B. aktuelle Posititon 0 für Rollo ist unten. Wenn dann das Signal abfahren kommt, weiß doch der Baustein, Rollo ist schon unten, also keine Ansteuerung des Ausgangs.

    Die Frage steht so auch im Oscat-Forum, da kam bislang aber keine Antwort.

  4. #4
    Registriert seit
    21.02.2014
    Ort
    Sachsen-Anhalt
    Beiträge
    1.574
    Danke
    285
    Erhielt 260 Danke für 234 Beiträge

    Standard

    Da scheint sich mein erster Eindruck von Deinem Problem zu bestätigen.
    Die Lebensdauer Deiner Relais hängt in erster Linie von den Lastschaltvorgängen, also denen mit Strom ab.
    Ist das Rollo in Endlage und bekommt einen Fahrbefehl in diese Richtung, ist der Stromfluss durch den Endlagenschalter in dieser Richtung unterbrochen. Das Relais schaltet leer.
    Industrierelais sind idR für > 100000 Schaltzyklen ausgelegt. Da kannste mal Rechnen, wie lange Du in Deinem Haus wohnen mußt, bevor ein mechanischer Schaden auftritt. Häufiger, je nach Belastung sind verbrannte Kontakte, vor allem bei falscher Relaisauswahl.

    Ich sehe in Deinem Problem vor allem ein kosmetischen Problem, welches Du leicht lösen kannst, indem Du Dir den (geschätzen Status Deines Rollo's merkst und dementsprechend die Rollo's von der Ansteuerung ausnimmst, von denen Du die aktuelle Stellung zu kennen meinst.

    Merkst Du was im letzten Schachtelsatz? Genau: Du kennst mangels Rückmeldung die wirkliche Position nicht. Und von daher macht es schon Sinn beim Befehl alles auf auch alle Relais schalten zu lassen. Du kannst die Fahrzeiten zwar optimieren, wirst aber nach einigen Jahren feststellen, das durch Verschleiß nach und nach das Rollo langsamer wird. Dann musst Du die Fahrzeiten nachstellen.

    Edit: Kontere jetzt bitte nicht mit dem "Stromverbrauch" der Relais.

  5. #5
    Juergen_Newbie ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    07.07.2014
    Beiträge
    18
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo weißnix,

    das mit der Lebensdauer des Relais war auch ironisch gemeint. Der Smiley dahinter fehlt. Wobei man Relais-Kleber nicht unterschätzen darf. Und nein, als Elektrotechniker, keine Konter mit dem Stromverbrauch.

    Vielleicht habe ich hier einen Denkfehler, aber wieso kenn ich die Enpositionen nicht? Nach den 60 Sekunden Fahrzeit, die aktuell ablaufen, weiß ich doch, wo ich stehe, entweder Position 0 oder 255.

  6. #6
    Registriert seit
    21.02.2014
    Ort
    Sachsen-Anhalt
    Beiträge
    1.574
    Danke
    285
    Erhielt 260 Danke für 234 Beiträge

    Standard

    OK, nach Fahrzeit x+ Sicherheit kannst Du von "offen" oder "zu" ausgehen. Ich meine nur: Optimiere das nicht bis auf's letzte.

    Wenn der oneclick die bereits geschlossenen oder offenen Rollos ansteuert und Dich das stört, dann verriegele das doch.
    Ansonsten: es würde die OSCAT sicher bereichern, wenn Du die Funktion erweiterst.

    Das Neutriggern der Zeit ergibt nach einer Störung, bei der die Jalousie auf halb acht bleibt, durchaus einen Sinn.

  7. #7
    Registriert seit
    26.10.2011
    Beiträge
    32
    Danke
    8
    Erhielt 3 Danke für 3 Beiträge

    Standard

    Habe ich gerade gesehen, dass du es auch ins Oscat-Forum gestellt hast.
    In diesem Fall fände ich es gut, wenn du jeweils einen Link zum jeweils anderen Forum mit postest. Es muss sich ja nicht jemand die Mühe machen zu antworten, wenn das Thema anderswo schon durch ist.

    Ach stimmt, der Max_Runtime spuckt da auch noch mit rein - den hatte ich vergessen, da es auch ne Config-Variable ist.
    Da du die Blind-Bausteine (wie ich auch) zu einem "großen" Einzelbaustein zusammengefasst hast, würde ich die Max-Runtime von den Constant-Inputs zu den normalen Inputs verschieben, dann kannst du die direkt im Programm anparametrieren. Den brauchst du nämlich immer - genau so wie den T_UP und T_DN.

    Ansonsten kann ich mich weißnix_ nur anschließen.

  8. #8
    Juergen_Newbie ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    07.07.2014
    Beiträge
    18
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Wenn die Funktion so umgesetzt wurde, dann werd ich daran bestimmt nicht rumspielen. Bin in Sachen Codesys/Twincat ein richtiger Anfänger, hatte vor der Rollosteuerung noch überhaupt nichts damit zu tun. Deshalb hier auch mal mein Dank an alle, die da so fleißig gewesen sind.
    Ich dachte, ich habe einen Fehler in der Beschaltung der Bausteine o.ä. gemacht, aber das ist ja dann doch nicht der Fall.

    Danke an euch für eure Hilfe!

Ähnliche Themen

  1. Kalibrierung Blind_Control_S deaktivieren
    Von Juergen_Newbie im Forum CODESYS und IEC61131
    Antworten: 5
    Letzter Beitrag: 11.11.2015, 17:07
  2. TwinCat HMI Fragen über Fragen
    Von Bambam im Forum CODESYS und IEC61131
    Antworten: 11
    Letzter Beitrag: 10.11.2010, 17:36
  3. Step 5 Fragen
    Von Saibotccd im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 24.03.2009, 15:33
  4. Fragen zu OP 17
    Von swm im Forum Simatic
    Antworten: 9
    Letzter Beitrag: 28.07.2008, 17:51
  5. Siemens Fu Fragen über Fragen
    Von lorenz2512 im Forum Schaltschrankbau
    Antworten: 0
    Letzter Beitrag: 28.10.2005, 17:58

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •