Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 12 12311 ... LetzteLetzte
Ergebnis 1 bis 10 von 114

Thema: Problemlösung bei SEL Baustein

  1. #1
    Registriert seit
    21.06.2015
    Beiträge
    60
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Zusammen !

    Ich habe hier ein paar kleine SEL Bausteine zusammengesetzt und brauche Eure Hilfe, denn die Schaltung reagiert nicht mehr so wie sie soll.

    Ziel ist es, dass der obere SEL Baustein, beim Eingangssignals des AND Bausteins den Wert AOUT1 an rAOut0 weitergibt.

    Nachdem der Timer1 dann abgelaufen ist, soll er auf AIN1 zurückschalten.


    DANN fängt ein ähnliches Spiel mit dem unteren Baustein an. Sobald Timer1 aus, bekommt SEL unten signal und soll AOUT2 durchgeben an rAOut0.


    Mein Problem ist hier folgendes :

    Trotz das der obere SEL Baustein ein TRUE Signal vom AND Baustein bekommt, gibt er das Signal von AOUT1 nicht weiter.

    Der Sel unten, obwohl gleiche Aubauweise, reagiert aber genau so...



    hat jemand eine Idee warum.... ich sehe den Wald vor lauter Bäumen nicht....


    Danke schonmal für die Hilfe !!


    MFg.

    Nexer
    Angehängte Grafiken Angehängte Grafiken
    Zitieren Zitieren Problemlösung bei SEL Baustein  

  2. #2
    Registriert seit
    23.10.2009
    Beiträge
    399
    Danke
    59
    Erhielt 114 Danke für 88 Beiträge

    Standard

    Das erste Resultat wird im unteren Zweig überschrieben, und zwar immer, worüber wunderst Du Dich da?
    Statt Null solltest Du im unteren Zweig das Resultat des oberen Zweigs benutzen.
    Gruß
    Erich
    Geändert von LargoD (27.06.2015 um 08:53 Uhr)

  3. #3
    nexer ist offline Benutzer
    Themenstarter
    Registriert seit
    21.06.2015
    Beiträge
    60
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Das ist ja Sinn der Schaltung, mein Problem ist, das die Ausgabe des Ersten Zweigs gar nicht ausgegeben wird.

    Bspw. hat AOUT1 den Wert 10 und AOUT2 den wert 9.

    So wird im oberen Zweig dauerhaft AIN1 angezeigt, egal ob der AND Eingang TRUE oder FALSE ist.

    Im unteren Zweig, soll dies durch die Timerbausteine überschrieben werden.

    DER SEL Bauststein reagiert auch so wie er soll.

    Auch hatte ich statt AIN1 auch schon wie unten den Wert 0 stehen, reagiert aber identisch.....


    Klar, wo mein Problem liegt ?

  4. #4
    Registriert seit
    23.10.2009
    Beiträge
    399
    Danke
    59
    Erhielt 114 Danke für 88 Beiträge

    Standard

    Zitat Zitat von nexer Beitrag anzeigen
    Klar, wo mein Problem liegt ?
    Ja, Du hast noch nicht verstanden, dass eine SPS immer alle Verknüpfungen zyklisch bearbeitet.
    Probier mal meinen Tip von oben.
    Geändert von LargoD (27.06.2015 um 08:59 Uhr)

  5. #5
    nexer ist offline Benutzer
    Themenstarter
    Registriert seit
    21.06.2015
    Beiträge
    60
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Ja, dafür sind ja im unteren teil die timerbausteine, sodass, auch wenn alle schaltungen zyklisch nacheinander bzw. paralell bearbeitet werden, immer nur eine ausgabe steht. demnach bekommt der untere sel erst seine "freigabe" nachdem die zeit abgelaufen ist, die identisch ist mit der abschaltzeit des oberen sel´s....


    Oder habe ich da grade einen Denkfehler drin......

  6. #6
    Registriert seit
    23.10.2009
    Beiträge
    399
    Danke
    59
    Erhielt 114 Danke für 88 Beiträge

    Standard

    Das obere Resultat wird für eine sehr kurze Zeit ausgegeben (Mikrosekunde oder weniger) und dann das Resultat des untern Zweigs. Das ist nicht das, was Du willst, aber das, was Du programmiert hast.
    Null ist auch ein Wert.

  7. #7
    nexer ist offline Benutzer
    Themenstarter
    Registriert seit
    21.06.2015
    Beiträge
    60
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hättest du denn eine Idee wie ich die Schaltung anderweitig realisieren kann ?

  8. #8
    Registriert seit
    13.01.2013
    Beiträge
    633
    Danke
    26
    Erhielt 65 Danke für 60 Beiträge

    Standard

    Sollen die immer für die selbe Zeit verwendet werden ? Erstell dir einen Impuls Timer von bspw TON=10s TOFF=10s und setzte den vor dein AND. Einmal Impulstimer und einmal NOT Impulstimer. Das wäre jetzt denke ich der einfachste Weg. Wenn ich dich richtig verstanden habe.

  9. #9
    nexer ist offline Benutzer
    Themenstarter
    Registriert seit
    21.06.2015
    Beiträge
    60
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Also das soll genutzt werden um jeden Tag zur gleichen Zeit einen bestimmten Wert morgens vom 0-10v Ausgabe und nach ca. 13 Std. das gleiche Rückwärts, also vom 10-0V.

    Vielleicht kannst du mir die Schaltung die du meinst kurs ein Bild von machen, ich habe erst vor ein paar Tagen mit dem Schaltungsbau angefangen, mir ist das nicht sooo 100%ig klar....

    Danke Dir

  10. #10
    Registriert seit
    13.01.2013
    Beiträge
    633
    Danke
    26
    Erhielt 65 Danke für 60 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Wenn ich heute Nachmittag an den Rechner komme Machenschaften das gerne. Soll das immer zur selben Zeit passieren ? Also bspw 0..10V von 8.00-20.00uhr und von 20.00-08-00Uhr 10..0V ?

Ähnliche Themen

  1. Antworten: 0
    Letzter Beitrag: 05.09.2012, 13:58
  2. Baustein SEL (Binäre Selektion)
    Von HK09 im Forum CODESYS und IEC61131
    Antworten: 2
    Letzter Beitrag: 10.06.2010, 10:54
  3. Problemlösung WinCC Bedienstationen
    Von Bender25 im Forum HMI
    Antworten: 4
    Letzter Beitrag: 31.03.2010, 07:12
  4. Problemlösung mit NAIS FP0
    Von bORG im Forum Programmierstrategien
    Antworten: 8
    Letzter Beitrag: 13.10.2008, 00:29
  5. Antworten: 0
    Letzter Beitrag: 30.09.2007, 14:13

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •