Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 2 von 2

Thema: Verliere Wert bei Programmänderung

  1. #1
    Registriert seit
    31.08.2006
    Ort
    OH
    Beiträge
    275
    Danke
    70
    Erhielt 2 Danke für 2 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    ich nutze die Funktion FbOperatingHours_01 aus der Bibliothek Building_HVAC_03 um Betriebsstunden einer Pumpe zu zählen. Aber trotz dem, das ich die Variable für die Minuten als Retain Persistent deklariert habe, sind die Minuten immer wieder nach Programmänderung fort.

    Ich habe die Funktion auch dort als Ret.Pers. gespeichert.

    Was läuft da schief?
    Wahnsinn wohnt nur 1 Stockwerk unter dem Genie. Aber Genie ist nichts anderes, als kontrollierter Wahnsinn.
    Zitieren Zitieren Verliere Wert bei Programmänderung  

  2. #2
    Deep Blue ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    31.08.2006
    Ort
    OH
    Beiträge
    275
    Danke
    70
    Erhielt 2 Danke für 2 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hat sich erledigt...

    Vielleicht braucht ja mal jemand diese Info: Es lag daran, das ich Merkerbereiche Retain Persistent beschrieben habe. Und da sich bei Controller-Neustart diese immer wieder mit 0 Initialisieren konnte ich somit meine Daten nicht speichern. Speichere nun auf eine Variable und weise dieser danach einen Merkerbereich zu.
    Wahnsinn wohnt nur 1 Stockwerk unter dem Genie. Aber Genie ist nichts anderes, als kontrollierter Wahnsinn.

Ähnliche Themen

  1. Rampe bei digital wert?
    Von GSOhm im Forum Simatic
    Antworten: 7
    Letzter Beitrag: 30.10.2012, 11:15
  2. MTTFd Wert Anomalie bei Sistema????
    Von windemacher im Forum Maschinensicherheit - Normen und Richtlinien
    Antworten: 7
    Letzter Beitrag: 21.10.2012, 11:22
  3. Antworten: 12
    Letzter Beitrag: 17.05.2011, 08:58
  4. Bestimmten Wert bei Eingang X schreiben.
    Von Katrin1982 im Forum Simatic
    Antworten: 10
    Letzter Beitrag: 11.01.2011, 14:00
  5. Verliere Bilder im MP377 12"
    Von Pinguino im Forum HMI
    Antworten: 9
    Letzter Beitrag: 07.06.2010, 22:21

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •