Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 7 ErsteErste 1234 ... LetzteLetzte
Ergebnis 11 bis 20 von 70

Thema: EL3403 kWh Zählerstand bleibt unregelmäßig nach kurzer Zeit stehen

  1. #11
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.192
    Danke
    925
    Erhielt 3.292 Danke für 2.661 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Wenn Du feststellst, daß der Trend im WinCC nicht mehr ansteigt - hast Du da mal deutlich länger als die 10-fache bisherige "Stufenzeit" gewartet und nochmal nachgesehen? Also wenn man z.B. anfänglich alle 2 Minuten ein Ansteigen des Trend um 1 Einheit (Stufe, mWh ?) sehen kann, dann wird man wegen der begrenzten Auflösung von REAL-Zahlen auf ca. 7 Ziffern irgendwann nur noch alle 20 Minuten ein Ansteigen (Sprung) um ca. 10 Einheiten sehen und irgendwann nur noch alle 200 Minuten einen Sprung um ca. 100 Einheiten ...

    REAL-Zahlen haben eine begrenzte Auflösung und sind immer auf den nächsten darstellbaren Wert gerundet, was so ca. 7 signifikante Dezimalziffern sind. Dadurch werden vom DINT-Wert nur die höchsten 7 Ziffern im REAL-Wert vorkommen. Bei 1'234'567 sind das noch alle Ziffern, 12'345'67x wird aber nur noch als ungefähr 12345670 im REAL-Wert dargestellt, 123'456'7xx wird als ungefähr 123456700 dargestellt. Dadurch ändert sich die Trendkurve nur noch in größeren Sprüngen.

    Beobachte mal die DINT-Rohwerte der Zählerstände. Wenn Du für Anzeige oder Berechnungen alle Ziffern des Zählerstandes brauchst, dann darfst Du nicht in REAL wandeln sondern mußt in DINT bleiben - der Wert stellt dann vermutlich mWh dar. Nur für Anzeigezwecke kannst Du für die gewünschte Einheit ein Dezimalkomma einfügen (6 Stellen von hinten für kWh) oder in REAL wandeln und dann höchstens 6 Ziffern anzeigen (z.B. 1234.56 kWh).

    Für einfache Berechnungen sind REAL-Zahlen mit 7 Ziffern Auflösung meistens ausreichend, für Zähler und andere Ketten-Rechnungen sind REAL-Zahlen aber generell ungeeignet.

    Ein Zählerstand gibt die Anzahl gezählter ganzer Einheiten einer bestimmten Größe an und ist deshalb "natürlicherweise" eine Ganze Zahl. Rechnen mit Ganzen Zahlen ergibt keine Rundungsfehler und keine Auflösungsprobleme. Der darstellbare Größen-Bereich ist allerdings viel mehr begrenzt als bei REAL-Zahlen (welche dafür aber den Nachteil der begrenzten Auflösung/Genauigkeit haben).

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  2. #12
    Crack123 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    09.02.2012
    Beiträge
    302
    Danke
    16
    Erhielt 17 Danke für 17 Beiträge

    Standard

    Hallo!

    Kurze Informationen was so noch offen ist :

    der Aufbau ist 3 Stromwandler 50/1 also Current Transformator Wert 50 was Fix eingetragen ist

    Leds an der Klemme Normalzustand

    habe mal die Index bzw State Variable geforced, die Zählerstände in der Klemme stehen Aktuell still bzw. alle ka 5 Minuten springt die 4te Kommastelle um 5 weiter also so gut wie garnix obwohl ca 400-500 W anliegen momentan.

    zum Thema WinCC die Werte stehen ja in der PLC schon still bzw. extrem langsam, das man in der Visu nichts steigen sieht ist für mich schon klar

    Was mich Aktuell wundert, nach dem Forcen und Deforcen läuft der L1_DataEnergy bzw Negativ Zähler wieder normal weiter, L2 und 3 sind unverändert in Ihrem Wert.


    Zum Thema Zahlensystem muss ich erstmal nochmal alles genau Studieren.




    Zitat Zitat von borromeus Beitrag anzeigen
    Der Zähler zählt doch im Gerät. Wo setzt Du dann null?



    Bei 1-3kWh in 3 Tagen (bis der Zähler stehen bleibt) heisst, dass da zwischen 15 und 40 Watt draufhängen.
    Was ist denn das?

    Mir kommt das etwas seltsam vor......
    im Main Baustein gibt es eine Variable ResetEnergy dann sind die Zähler wieder auf 0 von dem FB3403
    das mit den 1-3 Tagen war etwas falsch ausgedrückt, so im Nachinein waren es teilweise nur 4h dann mal 12h, Minimalleistung sind dann so 85W bis 800W Peak




    Habe mal Testhalber Currenttransformer auf 5 und den Multi Faktor auf 0.00001 gesetzt, zusätzlich die DINT_TO_REAL umwandlung entfernt
    Geändert von Crack123 (10.02.2016 um 15:34 Uhr)

  3. #13
    Registriert seit
    21.02.2014
    Ort
    Sachsen-Anhalt
    Beiträge
    1.512
    Danke
    268
    Erhielt 250 Danke für 226 Beiträge

    Standard

    Hast Du im Systemmanager mal die Werte der Variablen direkt auf der Klemme beobachtet. Das würde zumindest Hinweise darauf liefern, ob jetzt die Klemme ein Problem hat oder das Programm.

  4. #14
    Crack123 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    09.02.2012
    Beiträge
    302
    Danke
    16
    Erhielt 17 Danke für 17 Beiträge

    Standard

    Meinst du bei den Klemmen*variablen* oder im COE ?

    >bei den Klemmen Variablen sieht man das sie ebenfalls stehen bzw. extrem langsam laufen, COE sehe ich das mit meinem Wissenstand jetzt nicht.

  5. #15
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.192
    Danke
    925
    Erhielt 3.292 Danke für 2.661 Beiträge

    Standard

    Zitat Zitat von Crack123 Beitrag anzeigen
    Habe mal Testhalber Currenttransformer auf 5 und den Multi Faktor auf 0.00001 gesetzt, zusätzlich die DINT_TO_REAL umwandlung entfernt
    Das Entfernen des DINT_TO_REAL nützt Dir gar nichts. Der ST-Compiler weiß, daß man einen DINT-Wert nicht mit 0.00001 multiplizieren darf und macht die Wandlung zu REAL dann eben "heimlich" an einer Stelle, wo er meint daß es da am besten ist.

    Besser wäre es wenn Du testhalber die DINT-Rohwerte beobachtest. (wie schon zwei- oder dreimal empfohlen wurde)

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  6. #16
    Crack123 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    09.02.2012
    Beiträge
    302
    Danke
    16
    Erhielt 17 Danke für 17 Beiträge

    Standard

    Ja der Rohwert bleibt eben auch stehen , hatte ich schon geschrieben
    zb. Rohwert ware 16300 * 0,000001 * 50 waren dann 8154500000 oder in meinem Fall 0,815 kWh wo er stehen blieb, und nach dem Forcen von State bzw Index und wieder entfernen lief dieser Wert wieder weiter Hoch.
    Geändert von Crack123 (10.02.2016 um 18:01 Uhr)

  7. #17
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.192
    Danke
    925
    Erhielt 3.292 Danke für 2.661 Beiträge

    Standard

    Zitat Zitat von Crack123 Beitrag anzeigen
    zb. Rohwert ware 16300 * 0,000001 * 50 waren dann 13284500000 oder in meinem Fall 1,328 kWh
    Hmm, bei der Rechnung sollte aber 0.815 kWh rauskommen

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  8. #18
    Crack123 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    09.02.2012
    Beiträge
    302
    Danke
    16
    Erhielt 17 Danke für 17 Beiträge

    Standard

    Ah Verdammt, ja...das war der L1 Energy Wert mit den 16300 Roh , 1,328 war der Gesamte sorry !

    Zähler auf L1 ist jetzt bei 0,941 kWh nach den paar Änderungen nur so am Rande mal sehen.

  9. #19
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.192
    Danke
    925
    Erhielt 3.292 Danke für 2.661 Beiträge

    Standard

    Zitat Zitat von Crack123 Beitrag anzeigen
    zb. Rohwert ware 16300 * 0,000001 * 50 waren dann 8154500000 oder in meinem Fall 0,815 kWh
    Wo hast Du diesen riesigen Wert 8154500000 her? Kannst Du den irgendwo beobachten? In meiner Rechnung kommt der nirgendwo vor.
    Welchen Datentyp haben TotalEnergy, L1_Data.Energy_Wh, L2_Data.Energy_Wh, L3_Data.Energy_Wh?

    Dein L1 liefert offensichtlich den größten Anteil an TotalEnergy. Kann es sein, daß irgendwann ein "Groß"verbraucher an L1 einfach ausgeht und deswegen die Summe scheinbar einfriert?
    Oder ist eine Phase verkehrt herum angeschlossen? Ist ein Strom negativ oder zeigt einer der EnergyNegative einen Wert?

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  10. #20
    Crack123 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    09.02.2012
    Beiträge
    302
    Danke
    16
    Erhielt 17 Danke für 17 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Obwohl in der Doku steht das die Energie in Wh ausgegeben wird sehe ich bei Aktuell 1,463(55000...) also werden wohl mehr Stellen angezeigt, darum die große Zahl.
    Momentan läuft das ganze schon über den *normalen* Freeze Wert drüber ( Ok 1,4853kWh Zähler blieb einige Zeit stehen, danach lief er Tickweise weiter....dann wieder einige Zeit Stop, also auch direkt der Messwert aus der Karte)

    L1 ist quasi der Hauptteil, ist ja nur mal ein Testaufbau für später, Aktuell 1500VA USV diverse E-Gerät usw. L2 nur 1 Gerät, L3 is Quasi leer nur Spg. + Stromwandler angeklemmt ( Steht auf 0 Wh bzw 0 A )


    Datenwerte werden wohl DINT sein wenn da eine DINT_TO_REAL eingebaut ist/war.



    Kann das ein Problem mit der Zykluszeit sein bzw. sollte man speziell auf irgendwas achten bei solchen Messkarte auf der Beckhoff Seite, bin Prinzipiell nur auf Siemens S7 Baugruppen *Groß* geworden.
    Geändert von Crack123 (10.02.2016 um 19:07 Uhr)

Ähnliche Themen

  1. Antworten: 4
    Letzter Beitrag: 20.11.2012, 07:51
  2. Wago ist nach kurzer Zeit nicht mehr erreichbar
    Von erdbeerschaeler im Forum CODESYS und IEC61131
    Antworten: 2
    Letzter Beitrag: 08.08.2011, 15:37
  3. Maschine Aus -> Uhrzeit bleibt stehen
    Von EliteGurke im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 20.10.2010, 16:50
  4. TON bleibt stehen :(
    Von steinche im Forum Simatic
    Antworten: 14
    Letzter Beitrag: 21.11.2007, 08:07
  5. S5 Taktgenerator bleibt stehen
    Von Atlantik im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 13.10.2006, 21:38

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •