Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 7 von 7 ErsteErste ... 567
Ergebnis 61 bis 70 von 70

Thema: EL3403 kWh Zählerstand bleibt unregelmäßig nach kurzer Zeit stehen

  1. #61
    Registriert seit
    24.02.2009
    Beiträge
    1.242
    Danke
    23
    Erhielt 276 Danke für 235 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Wie PN/DP schon erwähnt, die Klemme speichert den Energierwert intern persistent ab. Im Systemmanger sollte man die Werte im CoE Reiter der Klemme (Index F801) beobachten können. Wenn die bei einer definierten Last auch nicht mehr weiterzählen, dann ist mit der Klemme wirklich was faul.

    Der Vorteil bei den Komplex-Klemmen ist ja, das sie einem schon den Großteil der Berechnungen abnehmen. Im Prinzip muss man im Programm dann nur noch die Werte auslesen.
    Sänd from mei Kombjudder mitse Dastadurr.

  2. Folgender Benutzer sagt Danke zu MasterOhh für den nützlichen Beitrag:

    weißnix_ (07.03.2016)

  3. #62
    Registriert seit
    21.02.2014
    Ort
    Sachsen-Anhalt
    Beiträge
    1.501
    Danke
    264
    Erhielt 247 Danke für 225 Beiträge

    Standard

    Ich hab keine Ahnung, woher Du die Klemme hast. Da Dir nur kostenpflichtige Optionen zur Auswahl stehen, vermute ich, das die Gewährleistungsfrist abgelaufen ist.
    That's life....shit happens

  4. #63
    Crack123 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    09.02.2012
    Beiträge
    302
    Danke
    16
    Erhielt 17 Danke für 17 Beiträge

    Standard

    Hallo !

    Zitat Zitat von Onkel Dagobert Beitrag anzeigen
    Du musst auch bedenken dass deine Messwerte mehr oder weniger fehlerbehaftet sind. Wenn du jede Millisekunde einen Messwert addierst, dann hast du den Messfehler innerhalb einer Sekunde bereits vertausendfacht! Ich würde den Wert mitteln oder einfach dämpfen und dann aufaddieren. Die genannten 5s sind erst einmal nicht verkehrt.
    Das Stimmt natürlich, wenn der Messfehler pro Tick kommt ist der natürlich umso höher bei mehr Zählticks



    Zitat Zitat von borromeus Beitrag anzeigen
    Was wird denn an dem Verteiler für eine wahrscheinliche Leistung gefahren werden, wenn mal in Betrieb?
    Nennstrom = ?
    Normaler Hausanschluss 3x400V 35A Vorsicherung ebend


    Zitat Zitat von weißnix_ Beitrag anzeigen
    Ich hab keine Ahnung, woher Du die Klemme hast. Da Dir nur kostenpflichtige Optionen zur Auswahl stehen, vermute ich, das die Gewährleistungsfrist abgelaufen ist.
    That's life....shit happens

    Die Klemme ist schon 6 Jahre alt da ist sowieso nix mehr mit Gewährleistung, wie du schreibst Shit happens!


    Zitat Zitat von MasterOhh Beitrag anzeigen
    Wie PN/DP schon erwähnt, die Klemme speichert den Energierwert intern persistent ab. Im Systemmanger sollte man die Werte im CoE Reiter der Klemme (Index F801) beobachten können. Wenn die bei einer definierten Last auch nicht mehr weiterzählen, dann ist mit der Klemme wirklich was faul.

    Der Vorteil bei den Komplex-Klemmen ist ja, das sie einem schon den Großteil der Berechnungen abnehmen. Im Prinzip muss man im Programm dann nur noch die Werte auslesen.
    EDIT : weil du es erwähnst, Index F801 dieser Wert bzw. Werte müssen aber Manuel per Programm in diesen Persistenten Speicher geschrieben werden, von Alleine sind diese Werte alle 3 Null sofern ich da nichts falsch interpretiert habe!

    Zitat Zitat von PN/DP Beitrag anzeigen
    Warum schickst Du die Klemme nicht zu Beckhoff oder tauschst sie mal aus?

    Die Klemme zählt (integriert) bereits intern die kWh, von außen wirst Du das nicht halb so genau hinkriegen. Und bei Differenzen zur Klemme weißt Du nicht, ob es an Deinem Verfahren oder der Klemme liegt. Warum dieser Aufwand - kapitulierst Du vor dem Problem?

    Am liebsten würde ich sagen, schicke mir mal Deine Klemme... doch ich habe kein Twincat zum testen.

    Ist das so schwer, die Klemme mal mit einer geschickt gewählten definierten Belastung ein paar Stunden zu testen um das Problem kontrolliert und reproduzierbar zu erzeugen? Dann die Wandler vertauschen und erneut testen. Um eindeutig zu sehen, das Problem ist ein Fehler der Klemme? Ist da keine Gewährleistung auf der Klemme? Willst Du keine einwandfrei funktionierende Klemme und einwandfrei funktionierende Gesamtlösung?

    Harald



    Ich kann es reproduzieren, bis 0,8xxx kWh läuft alles Normal ( da ist es egal welcher Stromwandler und welche Phase ) danach wird nur noch ab 450-500W Last weitergezählt, nach einem Zählerreset läuft das ganze bis 0,8xxxx wieder usw.
    Das hatte ich schon geschrieben, wie genau es zu diesem komischen Ablauf kommt keine Ahnung, da wird wahrscheinlich nur ein Beckhoff besuch der Klemme helfen können.
    Geändert von Crack123 (07.03.2016 um 17:29 Uhr)

  5. #64
    Crack123 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    09.02.2012
    Beiträge
    302
    Danke
    16
    Erhielt 17 Danke für 17 Beiträge

    Standard

    Hallo!

    Mal ein Nachtrag, meine Lösung sieht jetzt so aus :

    Der Energiezähler in der Klemme läuft bis 0,1 kWh rauf wird dann Reseted auf 0 und gleichzeitig addiere ich diesen Wert und speichere Ihn in eine Variable,
    Nebenbei läuft noch eine Addition wo man dann Laufend den gespeicherten Wert + den laufenden Zählerwert sehen kann ( also quasi Normaler Energiezähler )
    Interessant wäre für mich ob dieser Ablauf die Klemme endgültig zerstört in Punkto Speicher,
    ich speichere den EnergieWert NICHT in dem Remanenten Speicherbereich in der Klemme sondern nur Lokal in einer Variable.

  6. #65
    Crack123 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    09.02.2012
    Beiträge
    302
    Danke
    16
    Erhielt 17 Danke für 17 Beiträge

    Standard

    Also Ok so gehts auch nicht, nach 3 Tagen blieb der Zähler auch mit meinem Spezialreset stehen obwohl immer bei 100Wh auf 0 zurückgesetzt wurde.

    Ich gebe nun mit der Klemme auf, also back to the roots IR Leuchtdiode und Fotowiderstand in den Zählerkasten reinbauen und mir die Flanke selber zählen!

  7. #66
    Registriert seit
    21.02.2014
    Ort
    Sachsen-Anhalt
    Beiträge
    1.501
    Danke
    264
    Erhielt 247 Danke für 225 Beiträge

    Standard

    Hat Beckhoff möglicherweise eine (akzeptable) Reparaturpauschale für sowas? Möglicherweise lässt sich die Klemme ja für einen erträglichen Obulus wiederbeleben?
    Einschicken un erstmal kostenpflichtiges Angebot ist natürlich doof.

  8. #67
    Registriert seit
    26.01.2013
    Ort
    Hannover
    Beiträge
    100
    Danke
    2
    Erhielt 15 Danke für 10 Beiträge

    Standard

    Moin,
    du hattest am Anfang mal geschrieben, dass der eine Kanal rückwärts zählt. Wie hast du das korrigiert? Durch umklammen oder durch setzen des Flags?
    Ich habe seit ein paar Wochen eine KL3403 hier im Haus. Auf L1 ist bei uns die PV angeschlossen. Anfangs hatte ich auf L1 mehr Bezug als Leistung der PV. Da war alles i.O. Solange die Gesamtleistung noch positiv war, zählt die Klemme in beide Richtungen. Irgendwann war der Ertrag vom Dach so groß, dass die Gesamtleistung ins Negative ging. Da blieb dann P bei Null stehen, zählte aber irgendwas im Überlaufregister. Irgendwann bewegte sich garnichts mehr.
    Tausche doch noch mal die Anschlüsse am Stromwandler und schließe nur einen Kanal an. Vielleicht ist da doch irgendwo der Wurm drin.
    Gruß
    Holger

  9. #68
    Crack123 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    09.02.2012
    Beiträge
    302
    Danke
    16
    Erhielt 17 Danke für 17 Beiträge

    Standard

    Hallo!

    Also die Klemme hat ja 2 Zähler einer für nur Negativ und einer für Pos und Neg. ,
    hatte ja die Stromwandler verkehrt rum angeschlossen bzw. eingeschleift,
    darum zählte dann der normale Zähler Rückwärts.
    aus der Doku:
    Die Energiewerte können unter Zuhilfenahme des Command-Objekts (siehe Index 0xFB00 [} 100])
    gesichert werden. Der negative Energiewert ist der Wert, der durch eine negative Leistung erzeugt wird
    (generatorischer Betrieb). Der Energiewert in Subindex 01 bis 03 setzt sich aus generatorischer und
    verbrauchter Energie zusammen, d.h. im Generatorbetrieb wird dieser Wert kleiner. Um die positive Energie
    zu berechnen, müssen beide Werte zusammengefasst werden
    .



    Die Elektrische Verdrahtung ist jetzt auf jeden Fall richtig, alle Werte sind plausibel, warum aber die Klemme trotz des zurücksetzens auch wieder stehen blieb...keine Ahnung.

    Betreffs Beckhoffs, hatte nochmal eine Mail geschrieben mit ein paar Fragen in Bezug auf die Messgrößen,
    ob die Klemme denn überhaupt mit so kleinen Leistungen/Strömen zurecht kommt aber da kahm leider keine Antwort mehr zurück.

    Wenn ich die Klemme doch einschicken sollte bekomme ich sicher dann als Antwort alles Ok damit wette ich darauf
    Geändert von Crack123 (27.03.2016 um 19:17 Uhr)

  10. #69
    Registriert seit
    26.01.2013
    Ort
    Hannover
    Beiträge
    100
    Danke
    2
    Erhielt 15 Danke für 10 Beiträge

    Standard

    Was ist denn, wenn du die Skalierung der Klemme rauf setzt? Bei welchem Wert bleibt sie dann stehen?

  11. #70
    Crack123 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    09.02.2012
    Beiträge
    302
    Danke
    16
    Erhielt 17 Danke für 17 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Die Skalierung betrifft nur einzelne Werte V/A/W die Energie kommt als fertige Zahl aus der Klemme und wird dann nur mit dem Stromwandlerwert verrechnet damit die Zahl stimmt, da lässt sich nichts ändern.

Ähnliche Themen

  1. Antworten: 4
    Letzter Beitrag: 20.11.2012, 07:51
  2. Wago ist nach kurzer Zeit nicht mehr erreichbar
    Von erdbeerschaeler im Forum CODESYS und IEC61131
    Antworten: 2
    Letzter Beitrag: 08.08.2011, 15:37
  3. Maschine Aus -> Uhrzeit bleibt stehen
    Von EliteGurke im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 20.10.2010, 16:50
  4. TON bleibt stehen :(
    Von steinche im Forum Simatic
    Antworten: 14
    Letzter Beitrag: 21.11.2007, 08:07
  5. S5 Taktgenerator bleibt stehen
    Von Atlantik im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 13.10.2006, 21:38

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •