Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 4 von 4

Thema: [TC2] BC9100 über "virtuelle Ethernet Schnittstelle" nur bedingt auffindbar

  1. #1
    Registriert seit
    20.03.2015
    Beiträge
    18
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen,

    folgendes Problem hat sich ergeben, bei dem mir auch der Beckhoff Support nicht weiterhelfen konnte: Ich habe einen Testaufbau bestehend aus einem Laptop mit ZWEI Netzwerkkarten und einer BC9100 SPS. Die erste Netzwerkkarte des Notebooks hängt an unserem Firmennetz (DHCP) und die zweite Netzwerkkarte ist direkt mit dem BC9100 verbunden (feste IPs). Ich kann die BC9100 ohne Probleme im Systemmanager scannen, wenn nur die zweite Netzwerkverbindung aktiv ist. Sollten beim Starten des Laptops beide Netzwerkverbindungen aktiv sein, wird beim Scannen der virtuellen Ethernet Schnittstelle im Systemmanager anscheinend nur die erste Netzwerkverbindung gescannt. D.h. es werden nur Geräte gefunden, die über diese Verbindung erreichbar sind. Mein direkt angeschlossener BC9100 (Netzwerkverbindung 2) ist nicht auffindbar. Deaktiviere ich die erste Netzwerkverbindung und scanne erneut, so finde ich nur noch meine direkt angeschlossene BC9100 (wie zu erwarten). Aktivieren ich die erste Netzwerkverbindung wieder, wird beim Scannen wieder nur die direkt angeschlossene BC9100 gefunden. Es wird anscheinend immer nur über eine einzige Netzwerkschnittstelle gescannt und sobald diese fehlt (deaktiviert) wird über die andere gescannt.
    Mein Problem ist nun folgendes: Ich muss mich über Teamviewer auf einen PC mit zwei Netzwerkkarten aufschalten. Dieser ist genauso wie mein Notebook über zwei Netzwerkkarten einmal mit dem Firmennetz (Verbindung für Teamviewer) und einmal mit der SPS (BC9100) verbunden. Die BC9100 finde ich nun natürlich nicht beim Scannen, da der PC anscheinend auch nur über die erste Netzwerkschnittstelle scannt, die ich aber nicht deaktivieren kann, da sonst die Verbindung für Teamviewer abbricht. Ich muss dem Systemmanager also irgendwie sagen, dass über die andere Ethernet-Schnittstelle gescannt werden soll, aber wie? Die BC9100 kann ich auch nicht an das Firmennetz hängen, da sie eine feste IP Adresse in einem anderen IP Bereich besitzt. Und die IP Adresse der BC9100 kann ich nur ändern, wenn ich eine Verbindung hergestellt bekomme.

    Ich bin für jede Antwort dankbar.
    mfG. Andreas
    Zitieren Zitieren [TC2] BC9100 über "virtuelle Ethernet Schnittstelle" nur bedingt auffindbar  

  2. #2
    Registriert seit
    10.08.2012
    Beiträge
    245
    Danke
    0
    Erhielt 70 Danke für 66 Beiträge

    Standard

    ja- TC2 scannt nur über den ersten Netzwerkport. Die Reihenfolge kann man ändern (Windows).
    Alterantive wenn du die IP-Adresse kennst.
    Statt zu scannen (Broadcast search) nutze die Eingabe oben links in dem Dialog (keine Ahnung mehr wieder heisst) mit der bekannten IP-Adresse.
    Dann wird das Gerät auch erkannt wenn die Kommunikation nicht über den ersten Netzwerkport geht.

    Gruss
    Guga

  3. #3
    AnddnA ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    20.03.2015
    Beiträge
    18
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo Guga,

    leider kann ich BC9100 Steuerungen nicht über "Zielsystem wählen" suchen, sondern muss unter E/A Geräte eine virtuelle Ethernet Schnittstelle hinzufügen und diese sucht dann nach Boxen. Der zweite Port, an dem meine BC9100 hängt, ist von der Reihenfolge der Netzwerkadapter in Windows schon an erster Stelle. Trotzdem werden beim Scannen der Boxen immer nur die BC9XXX im Firmennetz gefunden und der direkt angeschlossene nicht. Sobald ich die erste Netzwerkverbindung deaktiviere, einmal nach Boxen scanne, finde ich die gesucht BC9100 und nur die.

  4. #4
    Registriert seit
    01.04.2009
    Beiträge
    143
    Danke
    0
    Erhielt 30 Danke für 29 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Wenn du beide Netzwerkports aktiviert hast mach doch bitte mal IPCONFIG und schick das mal was daraus kommt. Und bitte auch mal die Info welche IP Adresse der BC9100 hat, mal sehen ob ich dann helfen kann...

Ähnliche Themen

  1. Antworten: 20
    Letzter Beitrag: 02.03.2016, 11:46
  2. Antworten: 8
    Letzter Beitrag: 07.05.2015, 08:25
  3. Antworten: 2
    Letzter Beitrag: 29.08.2014, 12:30
  4. Antworten: 7
    Letzter Beitrag: 06.02.2014, 14:54
  5. Antworten: 4
    Letzter Beitrag: 01.09.2010, 14:08

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •