Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Results 1 to 6 of 6

Thread: TC3 - Activating config mode

  1. #1
    Join Date
    19.02.2019
    Location
    Augsburg
    Posts
    50
    Danke
    35
    Erhielt 0 Danke für 0 Beiträge

    Unglücklich


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hello experts,
    I am a complete beginer with the PLC's. I have a Beckhoff CX 5130 with TC3.1 and I tried to load a solution from a CX9020. Initially, I was able to login to the PLC after deleting all the I/O devices and adding new later with search devices option. Later, I have got a error with the TERM7 of the Ebus (not worried about it now), but the real problem is, my target system has an error and I cannot find anything in the broadcast search. The PLC is always in the run mode (green) even if I select the config mode, it stays in the run mode. I even tried to build a new solution, the problem exists still. PLease help me.
    Reply With Quote Reply With Quote TC3 - Activating config mode  

  2. #2
    Join Date
    11.09.2012
    Location
    obostenoderwestendaheimistesambesten
    Posts
    139
    Danke
    1
    Erhielt 18 Danke für 13 Beiträge

    Default

    How about removing the micro SD card and delete the Bootproject,
    it helped me with the CX9020 PLC.
    Sometimes the bootproject is corrupt, and after deleting the bootproject on the SD Card
    and rebooting the CX9020 it starts normal and runs into CONFIG Mode.

  3. Folgender Benutzer sagt Danke zu wollvieh für den nützlichen Beitrag:

    karthik.CH (12.03.2019)

  4. #3
    Join Date
    18.01.2019
    Posts
    161
    Danke
    72
    Erhielt 31 Danke für 30 Beiträge

    Default

    Mal so am Rande:
    Ein Projekt vom 9020 ist IMHO auf keinen Fall aus dem Stand kompatibel zum 5130.
    Als erstes wäre die Architektur ARM vs. x86 und als nächstes wäre zu prüfen obe das 9020 Projekt auch wirklich TC3 ist.

  5. Folgender Benutzer sagt Danke zu andy_ für den nützlichen Beitrag:

    karthik.CH (12.03.2019)

  6. #4
    Join Date
    10.08.2012
    Posts
    469
    Danke
    0
    Erhielt 130 Danke für 123 Beiträge

    Default

    Yes, deleting the boot project within the folder \Hard Disk\TwinCAT3\Boot\ will help.
    Root source is very likely not a corrupt project but a wrong configuration like defining the EthernetPort you use to communicate with your PLC as active EtherCAT Master or somthing like this.

    And no, by default the system here will start in run mode. Deleting the boot project does prevent that a project is loaded/running but once you activate a new project it will restart in RUN mode.
    Modification is done thorught the XAE (System node). The setting is not part of the project instead directly modifies a (registry) setting in the CX9020

    Guga

  7. Folgender Benutzer sagt Danke zu Guga für den nützlichen Beitrag:

    karthik.CH (12.03.2019)

  8. #5
    Join Date
    19.02.2019
    Location
    Augsburg
    Posts
    50
    Danke
    35
    Erhielt 0 Danke für 0 Beiträge

    Default

    Thanks all for your time and help. Another question: Now, when I try to connect to PLC using the ethernet port (x000) it gives an error (cores not available as mentione: I tried to isolate the cores but not working. The set on target option is not availabe and I cannot isolate the cores now ). The good thing is, when I change the etheret port to other (x001), the PLC connects and I can log in to it without a single problem. I can even change the run mode and config mode without ay trouble. I tried to find out the reason for this but unfortunately couldnt. Please help me what I was doing wrong. Thanks a lot in advance.

  9. #6
    Join Date
    18.01.2019
    Posts
    161
    Danke
    72
    Erhielt 31 Danke für 30 Beiträge

    Default


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    x000 und x001 sind voneinander unabhängig, also nicht geswitcht beim cx5130.

    Unter http://ip_cx5130/config sollte der Beckhoff-Device-Manager erreichbar sein. da kannst Du die Konfiguration der Schnittstellen prüfen. Seite 51 der Anleitung geht darauf ein.
    Die Doku: https://download.beckhoff.com/downlo...x5100_hwen.pdf

  10. Folgender Benutzer sagt Danke zu andy_ für den nützlichen Beitrag:

    karthik.CH (14.03.2019)

Similar Threads

  1. TC3: Warnung!!! Nicht versuchen TC3 4022.20 zu deinstallieren
    By oliver.tonn in forum CODESYS und IEC61131
    Replies: 7
    Last Post: 16.11.2018, 08:43
  2. Homing Mode und Profile Position Mode in CANopen
    By senmeis in forum Feldbusse
    Replies: 2
    Last Post: 10.06.2011, 08:32
  3. TeleService mit XP-Mode?
    By bacardischmal in forum Simatic
    Replies: 1
    Last Post: 01.04.2011, 09:02
  4. OP 7 in Transfer Mode bringen
    By Deep Blue in forum HMI
    Replies: 5
    Last Post: 22.04.2010, 11:49
  5. OP17-Transfer-Mode
    By ci 600 in forum HMI
    Replies: 3
    Last Post: 20.09.2006, 06:00

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •