Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 16

Thema: EPlan 8 export nach PCWorx

  1. #1
    Registriert seit
    17.09.2014
    Ort
    BW
    Beiträge
    217
    Danke
    18
    Erhielt 28 Danke für 26 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Forum Mitglieder.

    Vorab ich habe in der Suche nichts passendes gefunden.
    Sollte es doch einen Eintrag geben dann Sorry für den doppelten Post.

    So nun zu meinem Problem:

    Wir setzen ILC Steuerungen von Phoenix ein. Damit haben wir schon einiges an Erfahrung. Allerdings verwenden wir erst seit kurzem EPlan 8 incl. SPS Modul.
    Alletdings bekommen wir beim Export immer leere Dateien.
    Und vom Support gibts keine hilfreichen Infos.
    Deshalb hoffe ich hier kann mit jemand sagen auf was wir bei der Planerstellung achten müssen um erfolgreich zu exportieren.

    Grüße

    Rene
    Zitieren Zitieren EPlan 8 export nach PCWorx  

  2. #2
    Registriert seit
    30.08.2010
    Ort
    Östereich
    Beiträge
    1.458
    Danke
    503
    Erhielt 217 Danke für 192 Beiträge

    Standard

    In den SPS Klemmen die entsprechenden Datenfelder befüllen (Adresse, Funktionstext, . . .)
    Elektrotechnik und Elektronik funktioniert mit Rauch (Beweis: Tritt Rauch aus, funktioniert auch das Bauteil nicht mehr)

  3. Folgender Benutzer sagt Danke zu winnman für den nützlichen Beitrag:

    schaible.r (13.10.2014)

  4. #3
    schaible.r ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    17.09.2014
    Ort
    BW
    Beiträge
    217
    Danke
    18
    Erhielt 28 Danke für 26 Beiträge

    Standard

    Danke erst mal. Für die schnelle Antwort.
    Werde ich mal Versuchen.
    Allerdings dazu noch eine Frage.
    Wir müssen dann warscheinlich auch die EPLan Vorlagen von Phoenix nehmen oder?

    Zudem habe ich gerade eben doch noch eine Info vom EPlan Support bekommen.
    Scheint wohl ein Bug zu geben in Sachen Phoenix und soll angeblich mit der EPlan Version 2.4 behoben werden.

    Werde es zwar mal mit dem Beschriftungsfeldern Testen, allerdings wenn das mit dem Bug stimmt, dann werd ich das evtl. mal bis zur neuen Version auf schieben.

  5. #4
    Registriert seit
    08.09.2010
    Ort
    Blomberg
    Beiträge
    421
    Danke
    1
    Erhielt 66 Danke für 63 Beiträge

    Standard

    Hallo schaible.r,

    im Normalfall sollten alle E.Plan Makros unter den entsprechenden ILC in unserem Online Shop hinterlegt sein.
    Mit diesen Makros solltest auch dein Export funktionieren.

    Solltest du mal ein Makro nicht im E Shop finden kannst du dir unter Eingabe der Artikelnummer unter folgenden Link:

    https://www.phoenixcontact.com/onlin...8_data_manager
    das Makro erstellen lassen.

    Sollte das mal nicht funktionieren, wende dich an die Automationworx Hotline unter +495281 9462888 dann können wir gemeinsam nach einer Lösung suchen.

    Gruß

    Phoenix Contact Electronics
    Business Unit Automation
    Competence Center AUTOMATIONWORX
    05281 / 9462888
    www.automation.phoenixcontact.com
    PHOENIX CONTACT Deutschland GmbH
    Hotline: 05281-946-2888
    automation-service@phoenixcontact.com
    www.phoenixcontact.de

  6. Folgender Benutzer sagt Danke zu Phoenix Contact für den nützlichen Beitrag:

    schaible.r (13.10.2014)

  7. #5
    schaible.r ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    17.09.2014
    Ort
    BW
    Beiträge
    217
    Danke
    18
    Erhielt 28 Danke für 26 Beiträge

    Standard

    Danke erst mal für die Info.

    Eigentlich haben wir es mit offizielen Makros versucht, aber ich werde es nochmal Kontrollieren.

    Wie schon erwähnt ich denke es wird schon ein Problem mit EPlan geben, zumindest nach den Andeutungen vom EPlan Support.
    Und nach der Antwort winnmann.
    Wobei mich natürlich interessieren würde ob winnmann seine Erfahrung mit Phoenix gemacht hat oder mit einer anderen Steuerung das das SPS-Addon unterstützt.

    Sollte noch jemand eine Idee haben gerne her damit .
    Für mich ist das ganze erst wirklich abgeschlossen wenns funktioniert.
    Was aber primär nicht zwingend was mit Antworten aus dem Forum zusammen hängt.
    Werde es auch posten wenn wir es zum laufen gebracht haben.
    Falls nochmal jemand das gleiche Problem hat.

    Grüße

    René

  8. #6
    Registriert seit
    30.08.2010
    Ort
    Östereich
    Beiträge
    1.458
    Danke
    503
    Erhielt 217 Danke für 192 Beiträge

    Standard

    Wir arbeiten nicht mit phoenix AO.

    Aber das AO zieht normalerweise die Daten aus der Datenbank aus den Feldern die durch die SPS klemmen gefüllt werden sollten. Daher mein Ansatz mal ganz vorne anzufangen.

    Stell mal einen Screenshot rein, mit SPS klemme mit geöffnetem Eigenschaftsdialog.
    Elektrotechnik und Elektronik funktioniert mit Rauch (Beweis: Tritt Rauch aus, funktioniert auch das Bauteil nicht mehr)

  9. #7
    schaible.r ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    17.09.2014
    Ort
    BW
    Beiträge
    217
    Danke
    18
    Erhielt 28 Danke für 26 Beiträge

    Standard

    Erst mal Danke fürs Gedanken machen.

    Allerdings würde es bedeuten das wir zuerst das SPS Programm erstellen. Zumindest verstehe ich das so aus Deinem Post.

    Mein Ansatz ist allerdings genau anders herum.
    Es wird zuerst der Schaltplan durch Planer und Zeichner erstellt, dann wird eine XML Datei aus EPlan erzeugt. Und diese soll dann in PCworx von Phoenix Importiert werden.
    Und da ist der Hacken.
    Diese Datei hat ausser dem Header keinen Inhalt.

    Nun habe ich aber gestern eine Musterdatei vom Phonix Support an geschaut. Und dort finden sich verweise auf eine PCWorx Installation bzw. ein PCWorx Projekt.
    Jetzt habe ich den Verdacht das PCWorx evtl. auf dem Rechner mit EPlan installiert sein muss.

    Das werd ich mal testen.

  10. #8
    Registriert seit
    30.08.2010
    Ort
    Östereich
    Beiträge
    1.458
    Danke
    503
    Erhielt 217 Danke für 192 Beiträge

    Standard

    Glaub nicht dass worx installiert sein muss.

    Du musst im Plan bei den Klemmen die richtigen Daten eintragen.
    Ich vermute mal da steht jetzt nichts drinnen.
    Wenn nix drin steht kann E-Plan auch nix rausgeben, daher bitte mal einen Screenschot wie oben beschrieben.
    Elektrotechnik und Elektronik funktioniert mit Rauch (Beweis: Tritt Rauch aus, funktioniert auch das Bauteil nicht mehr)

  11. #9
    schaible.r ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    17.09.2014
    Ort
    BW
    Beiträge
    217
    Danke
    18
    Erhielt 28 Danke für 26 Beiträge

    Standard

    Ok.

    Dann mach ich mal einen allerdings kanns bis Freitag dauern.
    Bin grad bei ner IBS.

  12. #10
    schaible.r ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    17.09.2014
    Ort
    BW
    Beiträge
    217
    Danke
    18
    Erhielt 28 Danke für 26 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    So jetzt hats endlich geklappt mit den Bildern.

    Bild1.png

    Bild2.png

    Ich hoffe das ist nicht zu klein.

Ähnliche Themen

  1. Programm für Datenbaustein-Export nach Excel
    Von Thomas_v2.1 im Forum Simatic
    Antworten: 10
    Letzter Beitrag: 14.02.2016, 11:53
  2. TIA Baustein Export von TIA nach S7 Classic
    Von SPSGreenhorn im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 12.06.2013, 12:26
  3. Antworten: 6
    Letzter Beitrag: 19.03.2009, 21:07
  4. Export von Maschine nach China
    Von Integer im Forum Maschinensicherheit - Normen und Richtlinien
    Antworten: 1
    Letzter Beitrag: 19.08.2008, 16:33
  5. Export DB aus Step7 nach Excel
    Von Anonymous im Forum Simatic
    Antworten: 23
    Letzter Beitrag: 22.09.2005, 12:02

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •